+ Responder ao Tópico



  1. #1
    ralmeida
    Viva pessoal!
    Podem ajudar-me?

    Tenho instalado um cluster "Clusterknoppix on Debian e funciona as mil maravilhas , só quando tento executar o netperf para medir a latência do cluster dá erro.

    Os passos que executei foram os seguintes para a instalação do
    programa :

    1)instalei no clusterknoppix on debian o netperf-2.1pl3 e fiz as
    alterações aos ficheiros
    /etc/services
    acrescentei ---> netperf 12865/tcp
    2) /etc/inetd.conf
    acrescentei ----> netperf stream tcp nowait root
    /opt/netperf/netserver netserver
    3)corri no cliente ./netserver porque se trata de uma aplicação
    client-server e está correr
    4) e no servidor corri para ver se funciona
    o seguinte comando no directório /opt/netperf:
    ./netperf -H slave1 * no master onde
    está instalado o netperf cliente , no slave1 onde tenho instalado o
    netperf server
    o erro é:
    establish_control: control socket connect failed: connection refused
    Are you sure there is a netserver running on slave1 at port 12865?

    Já estou desesperado !!!!
    Há alguém que me possa ajudar-me a ultrapassar este problema?

  2. Execute o nmap no cliente e veja se o netserver está em execução na porta 12865...

    Exporte no seu bash_profile o diretório NETHOME=/opt/netperf

    use os scripts tcp_stream_script e tcp_range_script, para testar sua performance..

    De uma olhada aqui....
    não uso o knoppix, mas veja se ele também tem o XINETD

    establish_control: control socket connect failed: Connection refused

    When this message is displayed, it can mean one of the following:


    Netperf has not been installed on the remote system, or you forgot to run the netserver program explicitly. Either install netperf following the instructions at the beginning of this document, or run netserver explicitly on the remote system.

    You made a typo in the files /etc/services, or /etc/inetd.conf. Check your entries against those in the installation section. If changes are needed, make them and then reconfigure inetd as described in the installation section.

    You forgot to reconfigure inetd. Reconfigure inetd following the instructions in the installation section.

    You specified a port number with the -p option to netperf that is not the same as the port number being used by the netserver program on the remote system.

    Inetd security on the remote system is not configured to allow connections from the local system. Follow the instructions in the manpage for inetd.sec.

    []´s

    Marcos Pitanga






Tópicos Similares

  1. Problemas ao conectar php com mysql
    Por Lili no fórum Servidores de Rede
    Respostas: 44
    Último Post: 12-11-2002, 09:19
  2. Problemas ao receber e-mail
    Por ediguedes no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-09-2002, 12:30
  3. QMAIL URGENTE - Problemas ao enviar e-mails
    Por chelio no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-08-2002, 10:05
  4. QMAIL URGENTE - Problemas ao enviar e-mails
    Por chelio no fórum Servidores de Rede
    Respostas: 0
    Último Post: 21-08-2002, 10:00
  5. Problemas ao adicionar o samba ao dominio nt
    Por clmr no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-04-2002, 10:31

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L