+ Responder ao Tópico



  1. #1
    veiga
    Visitante

    Padrão RSH sem senha!!

    Ola todos,

    O que é necessario fazer para usar o rsh sem senha, além de colocar o ~/.rhosts nas homes dos usuarios??



    t+



    Marcelo Veiga Neves
    http://www.inf.ufsm.br/~veiga

  2. #2

    Padrão RSH sem senha!!

    Você já pensou em utilizar como alternativa o SSH?



  3. #3
    veiga
    Visitante

    Padrão RSH

    Ola,

    Eu quero usar o rsh porque tem uma latencia menor! eu preciso de desempenho não de segurança!

    falo!





    Marcelo Veiga Neves
    http://www.inf.ufsm.br/~veiga

  4. #4
    veiga
    Visitante

    Padrão RSH sem senha!!

    Ola,

    O xinetd ja ta rodando e o rsh ja ta funcionando! eu consigo executar um comando remoto na outra maquina soh que sempre pede senha!!! O que eu preciso fazer para executar um comando remoto sem senha?

    Eu to usando o mesmo nome de usuario, mesmo nome home e mesmo UID e GID!!

    Alguem sabe oq ainda falta!!

    Obrigado!





    Marcelo Veiga Neves
    http://www.inf.ufsm.br/~veiga



  5. #5
    Marcelo Oliveira
    Visitante

    Padrão RSH sem senha!

    Marcelo,

    Estou com a mesma situação na minha aplicação.

    Já configurei o inetd.conf e também os arquivos rsh e rlogin dentro de /etc/xinetd.d e ainda segue solicitando senha.

    Quais passos faltam?

    Agradeço desde já

  6. #6
    veiga
    Visitante

    Padrão RSH sem senha!

    Dae cara, blz?

    eu consegui fazer o rsh funcionar sem senha aqui no meu cluster... eu fiz o seguinte:

    1) instalei o xinetd e o netkit-rsh

    2) editei os arquivos:
    /etc/xinet.d/rsh
    /etc/xinet.d/rexec
    /etc/xinet.d/rlogin

    em todos eles coloquei "no" em:
    disable = no (o default eh yes)

    3) editei o arquivo:
    /etc/xinetd.conf

    comentei a linha:
    #only_from = localhost

    4) /etc/init.d/xinetd start

    5) colocar um ~/.rhost com o nome de todas maquinas nas homes dos usuários


    ps: para não pedir senha tem q ter o mesmo usuario em todas as maquinas, isto eh, tem q ter o mesmo uid e gid. (aqui eu autentico pelo nis então ficou mais fácil!)

    Espero ter ajudado, qualquer coisa posta ae!


    Feito!


    Marcelo Veiga Neves
    http://www.inf.ufsm.br/~veiga