Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    mariborghi
    Visitante

    Padrão Pop com Postfix

    Olá pessoal,
    Estou com o seguinte problema.
    Uso o RH9 e estou montando um servidor de email com o Postfix. E para pop já tentei 3 diferentes. Até aquele Mailutils eu tentei, mas nada.
    Acontece que qdo eu dou um echo teste | mail [email protected] ele manda o email para /var/spool/mail/meuemail. Dai configurei a conta no outlook tanto com o numero ip do servidor tanto qto o nome do servidor e ele não baixa. Telnet localhost 110 e 15 funciona. Parece estar tudo ok, mas qdo tento baixar pelo outlook depois de um tempo procurando algo, ele dá a seguinte mensagem Não foi possível conectar-se ao servidor. Conta: 'meuemail, Servidor: '200.211.X.X', Protocolo: POP3, Porta: 110, Segura (SSL): Não, Erro de soquete: 10054, Nº do erro: 0x800CCC0E

    A conta e o numero ip sa mensagem são fictícios. eu os alterei para enviá-los o problema.

    Será que alguém pode me ajudar?

    Obrigada pessoal

  2. #2

    Padrão Pop com Postfix

    cara o redhat jah vem com um server pop3 q eh o ipop3 edite o arquivo /etc/xinetd.d/ipop3 onde tem a linha disable=yes coloca no e restarta o xinetd
    pronto seu pop esta rodando



  3. #3
    mariborghi
    Visitante

    Padrão Pop com Postfix

    mas já está disable=no e a mensagem continua. Por isso resolvi instalar outro tipo de pop.

  4. #4
    mariborghi
    Visitante

    Padrão Pop com Postfix

    E o pop está rodando

    [[email protected] init.d]# ps -aux | grep pop
    root 28996 0.0 0.7 4092 892 ? S 13:49 0:00 [pop3d]

    O que pode ser?



  5. #5

    Padrão Pop com Postfix

    da um
    tail -f /var/log/maillog
    tenta se autenticar e cola aki oq aparecer no log

  6. #6
    mariborghi
    Visitante

    Padrão Pop com Postfix

    [[email protected] init.d]# tail -f /var/log/maillog
    Jun 14 13:23:27 mail postfix/pickup[29249]: 4D0E3DBB5A: uid=0 from=<root>
    Jun 14 13:23:27 mail postfix/pickup[29249]: 4D0E3DBB5A: uid=0 from=<root>
    Jun 14 13:23:27 mail postfix/cleanup[29255]: 4D0E3DBB5A: message-id=<[email protected]>
    Jun 14 13:23:27 mail postfix/cleanup[29255]: 4D0E3DBB5A: message-id=<[email protected]>
    Jun 14 13:23:27 mail postfix/nqmgr[29250]: 4D0E3DBB5A: from=<[email protected]>, size=319, nrcpt=1 (queue active)
    Jun 14 13:23:27 mail postfix/nqmgr[29250]: 4D0E3DBB5A: from=<[email protected]>, size=319, nrcpt=1 (queue active)
    Jun 14 14:23:27 mail postfix/local[29257]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Jun 14 14:23:27 mail postfix/local[29257]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Jun 14 14:23:27 mail postfix/local[29257]: 4D0E3DBB5A: to=<[email protected]>, relay=local, delay=0, status=sent (mailbox)
    Jun 14 14:23:27 mail postfix/local[29257]: 4D0E3DBB5A: to=<[email protected]>, relay=local, delay=0, status=sent (mailbox)



  7. #7

    Padrão Pop com Postfix

    ta mas qdo vc fizer o tail abra seu cliente de email e tente logar no pop3, ai cola aki denovo

  8. #8
    mariborghi
    Visitante

    Padrão Pop com Postfix

    Olha só.
    Eu apaguei todo o mailog. Fiz o que vc pediu.

    tail -f /var/log/maillog

    Fui no outlook e tentei baixar o email novamente e não gerou nada no mailog.

    e a mensagem continua.

    Mandei um email do outlook para um usuário criado e ele mandou normal. Tá lá no spool. Mas ele não quer baixar nem com reza brava.
    Dá o erro de socket.



  9. #9

    Padrão Pop com Postfix

    bom faz o seguinte to achando q seu pop num ta subindo..

    da um telnet IP 110
    veja oq ele vai mostrar,... rode o xinetd novamente e veja em /var/log/messages se ele subiu mesmo

  10. #10
    mariborghi
    Visitante

    Padrão Pop com Postfix

    [[email protected] init.d]# ps -aux | grep pop
    root 29760 0.0 0.5 3628 672 pts/1 S 14:56 0:00 grep pop

    [[email protected] init.d]# find / -name pop3d
    /usr/local/sbin/pop3d

    [[email protected] init.d]# find / -name ipop3d
    /etc/log.d/scripts/services/ipop3d
    /usr/sbin/ipop3d

    [[email protected] init.d]# telnet localhost 110
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    +OK POP3 mail v2001.78rh server ready

    [[email protected] init.d]# tail -f /var/log/messages
    Jun 14 14:55:47 mail xinetd[29696]: Exiting...
    Jun 14 14:55:47 mail xinetd: desligar xinetd succeeded
    Jun 14 14:55:48 mail xinetd: desligar xinetd failed
    Jun 14 14:55:49 mail xinetd[29754]: xinetd Version 2.3.10 started with libwrap options compiled in.
    Jun 14 14:55:49 mail xinetd[29754]: Started working: 7 available services
    Jun 14 14:55:52 mail xinetd: início de xinetd succeeded


    agora depois de tudo eu dou um grep no pop e ele não está ativo no processo.



  11. #11
    mariborghi
    Visitante

    Padrão Pop com Postfix

    [[email protected] sbin]# ipop3d
    +OK POP3 mail v2001.78rh server ready

    [[email protected] sbin]# ps -aux | grep pop
    root 29808 0.0 0.5 3624 668 pts/1 S 15:03 0:00 grep pop

    ele não está subindo mais.

    qdo eu dou um ipop3d para eu sair da mensagem é com CRTL+C? Ou estou fazendo coisa errada?
    Como eu deixo ele ativado?

  12. #12

    Padrão Pop com Postfix

    da uma checada se vc num ta subindo nenhum outro servico de pop junto com o xinetd pode ser q um mate o outro



  13. #13

    Padrão Pop com Postfix

    Citação Postado originalmente por mariborghi
    [[email protected] sbin]# ipop3d
    +OK POP3 mail v2001.78rh server ready
    e naum faca isso vc DEVE subir o ipop3 atraves do xinetd!

  14. #14
    mariborghi
    Visitante

    Padrão Pop com Postfix

    mas ele não tá subindo pelo xinetd.

    [[email protected] init.d]# vi /etc/xinetd.d/ipop3

    # default: off
    # description: The POP3 service allows remote users to access their mail \
    # using an POP3 client such as Netscape Communicator, mutt, \
    # or fetchmail.
    service pop3
    {
    disable = no
    socket_type = stream
    wait = no
    user = root
    server = /usr/sbin/ipop3d
    log_on_success += HOST DURATION
    log_on_failure += HOST
    }

    e o pop3s e o ipop2d estão com disable=yes.



  15. #15

    Padrão Pop com Postfix

    como nao? oq acontece qdo roda o xinetd?

  16. #16
    mariborghi
    Visitante

    Padrão Pop com Postfix

    Óh.
    Partes de testes.

    Apaguei tudo do /var/log/messages e do /var/log/mailog.

    Parei e iniciei o xinetd

    [[email protected] init.d]# ./xinetd stop
    Parando o xinetd: [ OK ]

    [[email protected] init.d]# ./xinetd start
    Iniciando xinetd: [ OK ]


    e ele me retorna isso

    [[email protected] init.d]# mcedit /var/log/messages

    Jun 14 15:32:34 mail xinetd[30024]: Exiting...
    Jun 14 15:32:35 mail xinetd: desligar xinetd succeeded
    Jun 14 15:32:37 mail xinetd[30055]: xinetd Version 2.3.10 started with libwrap options compiled in.
    Jun 14 15:32:37 mail xinetd[30055]: Started working: 6 available services
    Jun 14 15:32:40 mail xinetd: início de xinetd succeeded
    ~


    Mas se eu verifico os processos:

    USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
    root 1 0.0 0.0 1372 88 ? S Jun09 0:05 init [3]
    root 2 0.0 0.0 0 0 ? SW Jun09 0:00 [keventd]
    root 3 0.0 0.0 0 0 ? SW Jun09 0:00 [kapmd]
    root 4 0.0 0.0 0 0 ? SWN Jun09 0:00 [ksoftirqd_CPU0]
    root 9 0.0 0.0 0 0 ? SW Jun09 0:00 [bdflush]
    root 5 0.0 0.0 0 0 ? SW Jun09 0:01 [kswapd]
    root 6 0.0 0.0 0 0 ? SW Jun09 0:00 [kscand/DMA]
    root 7 0.0 0.0 0 0 ? SW Jun09 1:47 [kscand/Normal]
    root 8 0.0 0.0 0 0 ? SW Jun09 0:00 [kscand/HighMem]
    root 10 0.0 0.0 0 0 ? SW Jun09 0:01 [kupdated]
    root 11 0.0 0.0 0 0 ? SW Jun09 0:00 [mdrecoveryd]
    root 15 0.0 0.0 0 0 ? SW Jun09 0:02 [kjournald]
    root 72 0.0 0.0 0 0 ? SW Jun09 0:00 [khubd]
    root 1178 0.0 0.0 0 0 ? SW Jun09 0:00 [kjournald]
    root 1569 0.0 0.1 1456 164 ? S Jun09 0:01 syslogd -m 0
    root 1573 0.0 0.0 1368 24 ? S Jun09 0:00 klogd -x
    rpc 1585 0.0 0.0 1544 36 ? S Jun09 0:00 [portmap]
    rpcuser 1604 0.0 0.0 1524 0 ? SW Jun09 0:00 [rpc.statd]
    root 1671 0.0 0.0 1360 4 ? S Jun09 0:00 /usr/sbin/apmd -p 10 -w 5 -W -P /etc/sysconfig/apm-scripts/apms
    root 1720 0.0 0.2 3504 324 ? S Jun09 0:02 /usr/sbin/sshd
    root 1789 0.0 0.0 1412 28 ? S Jun09 0:00 gpm -t ps/2 -m /dev/mouse
    root 1798 0.0 0.1 1416 132 ? S Jun09 0:00 crond
    daemon 1820 0.0 0.1 1408 164 ? S Jun09 0:00 [atd]
    root 1829 0.0 0.0 1348 4 tty2 S Jun09 0:00 /sbin/mingetty tty2
    root 1830 0.0 0.0 1348 4 tty3 S Jun09 0:00 /sbin/mingetty tty3
    root 1831 0.0 0.0 1348 4 tty4 S Jun09 0:00 /sbin/mingetty tty4
    root 1832 0.0 0.0 1348 4 tty5 S Jun09 0:00 /sbin/mingetty tty5
    root 1833 0.0 0.0 1348 4 tty6 S Jun09 0:00 /sbin/mingetty tty6
    root 25620 0.0 0.1 2252 252 ? S 12:29 0:00 login -- root
    root 25621 0.0 0.1 4316 216 tty1 S 12:29 0:00 -bash
    root 25887 0.0 0.0 0 0 ? SW 12:29 0:00 [eth0]
    root 25978 0.0 0.0 0 0 ? SW 12:29 0:00 [eth1]
    root 26549 0.0 1.2 6776 1608 ? S 13:46 0:00 /usr/sbin/sshd
    root 26551 0.0 1.1 4328 1416 pts/0 S 13:46 0:00 -bash
    root 29017 0.0 1.3 6812 1640 ? S 13:56 0:01 /usr/sbin/sshd
    root 29019 0.0 1.1 4332 1428 pts/1 S 13:56 0:03 -bash
    root 29547 0.0 1.1 4512 1388 ? S 14:46 0:00 [master]
    postfix 29548 0.0 1.1 4540 1416 ? S 14:46 0:00 [pickup]
    postfix 29549 0.0 1.3 5896 1716 ? S 14:46 0:00 [nqmgr]
    root 30055 0.0 0.6 2028 812 ? S 15:32 0:00 xinetd -stayalive -reuse -pidfile /var/run/xinetd.pid
    root 30063 0.0 0.5 2620 672 pts/1 R 15:34 0:00 ps -aux


    ou apenas o ipop3d

    não possuo ele rodando

    [[email protected] init.d]# ps -aux | grep ipop3d
    root 30065 0.0 0.5 3636 680 pts/1 S 15:34 0:00 grep ipop3d



    Tô ficando chateada meu amigo;



  17. #17

    Padrão Pop com Postfix

    naum mostrar no ps eh normal, o meu tb num aparece....
    da um telnet localhost 110 e veja se ele responde, ele tem q abrir uma msg do servidor pop

  18. #18
    mariborghi
    Visitante

    Padrão Pop com Postfix

    [[email protected] init.d]# telnet localhost 110
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    +OK POP3 mail v2001.78rh server ready


    [[email protected] init.d]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mail.perky.com.br ESMTP Postfix

    O teste do POP tb não deveria mostrar o mail.perky.com.br tb? Ao invés do POP3 mail v2001.78rh server ready?



  19. #19

    Padrão Pop com Postfix

    naum, eh assim mesmo ele mostra a versao do pop naum do email
    bom jah sabemos q o pop ta certo agora faz + um teste
    telnetl localhost 110
    user usuario
    pass senha (num lembro se eh pass ou password)

    ele deve mostrar o numero de msgs q vc tem

  20. #20
    mariborghi
    Visitante

    Padrão Pop com Postfix

    [[email protected] root]# telnet localhost 110
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    +OK POP3 mail v2001.78rh server ready
    user xunda
    +OK User name accepted, password please
    pass 123456
    +OK Mailbox open, 2 messages