+ Responder ao Tópico



  1. #1
    Eduardo Terzella
    Visitante

    Padrão Problemas com o Nagios e o Apache

    Boa noite,

    Estou com um problema com o Nagios em Freebsd 4.9

    Estou utilizando o seguintes, o nagios 1.2, com o plugin 1.3.

    Já esta tudo instalando, quando eu rodo o ./nagios -v ele não me volta nenhum erro.

    Bem vamos ao problema, quando eu acesso a console do nagios e tento visualizar algum host, servico ativo ou qualquer outra informação ele me traz o seguinte erro:

    It appears as though you do not have permission to view information for any of the hosts you requested...
    If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
    and check the authorization options in your CGI configuration file.


    Alguem sabe como resolver isso ???

  2. #2

    Padrão Problemas com o Nagios e o Apache

    na conf do apache vc habilitou a execucao de CGI na pasta onde estao os cgis do nagios?



  3. #3

    Padrão nagios

    Eu consegui configurar a autenticção, tem um site com uns arquivos de exemplo ótimos, http://demo.square-box.com e um demos rodando em http://nagios.square-box.com.

    Mas estou com problemas com 3 itens do menu de monitoramento do Nagios:
    1º Scheduling Queue
    2º Process Info
    3º Event Log

    E nunca consiguo passar um comand o para ele mudar o horário de execução, a não ser que eu mude a permissão do nagios.lock manulmente

  4. #4
    Visitante

    Padrão Re: Problemas com o Nagios e o Apache

    Citação Postado originalmente por Eduardo Terzella
    Boa noite,

    Estou com um problema com o Nagios em Freebsd 4.9

    Estou utilizando o seguintes, o nagios 1.2, com o plugin 1.3.

    Já esta tudo instalando, quando eu rodo o ./nagios -v ele não me volta nenhum erro.

    Bem vamos ao problema, quando eu acesso a console do nagios e tento visualizar algum host, servico ativo ou qualquer outra informação ele me traz o seguinte erro:

    It appears as though you do not have permission to view information for any of the hosts you requested...
    If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
    and check the authorization options in your CGI configuration file.


    Alguem sabe como resolver isso ???