+ Responder ao Tópico



  1. Pessoal da lista, boa noite ....
    Estou configurando um pc para ser um servidor de internet. Estou usando o Conectiva 8. Já instalei o Conectiva 8 e está funcionando ok. Quando entrei na empresa, o servidor principal já estava devidamente configurado e nunca tive a oportunidade de configurar sózinho, um servidor para acesso a internet. Aí peguei um pczinho que estava dando sopa e quero tentar aprender.

    A minha configuração é a seguinte :

    2 placas de redes que já foram detectadas pelo Conectiva 8.
    1 modem alcatel speed touch pro com endereço 10.0.0.138
    1 hub switch com 16 portas
    A ADSL (BrasilTelecom) que a empresa utiliza tem ip fixo (200.xxx.yyy.zzz)

    Uma placa vai ser a eth0 para acessar o modem, e a outra eth1 para acesso de 6 máquinas windows.

    Nesse servidor, configurei a eth0 e eth1 assim :

    #ifconfig eth0 10.0.0.10 netmask 255.255.255.0
    #ifconfig eth1 192.168.1.4 netmask 255.255.255.0

    Como seria o comando route para o servidor ???

    Também pelo que já li tenho que executar :

    #echo "1" > /proc/sys/net/ipv4?ip_forward
    #modprobe iptable_nat
    #iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Galera , me dêem uma luz, por favor e veja se é somente isso para fazer com que as máquinas windows acessem a internet.
    Obrigado a todos .....


    :wink:

  2. eh isso mesmo, a regra do masquerade vc tem q usar -o ethX onde o ethX eh a placa q ta ligada ao modem

    e se a eth0 eh a placa q vai conecar ao modem vc num teria q coloca o seu ip fixo ao inves desse 10.10 q vc coloco?



  3. Ok caro amigo.
    Pelo que vi na rede que funciona na empresa, quando dá o ifconfig, a eth0 que está ligada ao modem ela está com endereço 10.0.0.100, por isso eu coloquei 10.0.0.10, porque depois eu vou desconectar o servidor da internet da empresa e colocar o pc que estou tentando configurar, para ver se funciona.

    A outra coisa que não entendi legal, é como fica o comando route nesse servidor ???

    #route add default gw 10.0.0.138

    Seria isso ??? E nas máquinas windows eu configuraria o gateway como 192.168.1.4 ???

    Obrigado mais uma vez, pela ajuda .....

  4. #route add default gw 10.0.0.138
    eh o comando eh esse mesmo, mas eh esse o endereco certo o gw?

    nos cliente vc tem q colocar como rota padrao o ip da sua eth1



  5. Faz assim oh:

    # route add -net 10.0.0.0/24 gw 10.0.0.10
    #route add -net 192.168.1.0/24 gw 192.168.1.4



    Acho que isso resolve, mas se a máscara de sub-rede que você estiver utilizando for outra (como 8 ou 16), é só alterar...


    Abraços!






Tópicos Similares

  1. configuraçao de placa de rede
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 06-07-2005, 08:36
  2. problemas com configuração de duas placas de rede
    Por mario meirles fielho no fórum Redes
    Respostas: 3
    Último Post: 04-05-2005, 16:53
  3. Configuração Placa de Rede Realtek
    Por RQG_ no fórum Servidores de Rede
    Respostas: 14
    Último Post: 19-05-2004, 21:10
  4. Configuração de duas placas de rede no Slackware 9
    Por Wal no fórum Servidores de Rede
    Respostas: 6
    Último Post: 14-12-2003, 08:24
  5. Configuração de Placa de Rede ISA no Conectiva Linux 8+
    Por Zen no fórum Servidores de Rede
    Respostas: 0
    Último Post: 18-09-2003, 15:52

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L