+ Responder ao Tópico



  1. #1
    13urton
    Visitante

    Padrão nao consigo installar o php5.0 aki!

    gallera eu rodo o ./configure do php 5.0 e ele da o seguinte erro...

    checking libxml2 install dir... no
    configure: error: libxml2 version 2.5.10 or greater required.

    eu fui la e baixei esse rpm libxml2-2.6.10-2.src.rpm e instalei...

    rodei de novo o ./configure.. e deu o mesmo erro...

    estou tentando começar com php, mas esse começo ta terrivel... nao consigo instalar o proprio php, nem phpmyadmin, nem mySQL nem nada! ahh!

    como faz falta os wizards do windows =]

    um abraço... espero q me ajudem

  2. #2
    hez4el
    Visitante

    Padrão nao consigo installar o php5.0 aki!

    Meu amigo foi por causa dos wizards da vida q a maioria
    das pessoas num sabe mais instalar um programa.

    Vamo passo a passo pra saber qual o melhor jeito de instalar
    php na sua maquina.

    O php voce não precisa compilar, ele ja vem pré complilado
    em rpm também no www.rpmfind.org

    O mysql tem rpm e o apache também.
    è só instalar ele e depois mexer na conf do apache pra rodar certinho
    mas instruções pra isso vem direto na documentação do php.

    Abraços



  3. #3
    13urton
    Visitante

    Padrão nao consigo installar o php5.0 aki!

    ppois eh.. nao consegui instalar o php5, mas consegui instalar o php4

    so q meu apache nao esta decifrando os codigos php.... ele me joga na tela como um bloco de notas... como posso ter certeza q meu php4 ta fuincionando?

    li algo sobre adicionar modulos nas linhas addmodule do httpd.conf

    aos trancos e barrancos eu chego lah... =]

    valeu pela resposta bruxo...

  4. #4

    Padrão nao consigo installar o php5.0 aki!

    aew cara....eh isso msm, vc precisa adiciona as linhas pra carregar os modulos do php...senao nem funfa....soh q depende de qual versao do apache vc ta usando....da uma olhada aki:

    http://www.php.net/manual/pt_BR/installation.php


    ele ta meio traduzido pro portugues....boa sorte.... :wink:



  5. #5
    Gutenberg
    Visitante

    Padrão PHP5+apache2

    Kracas to sofrendo do mesmo pro.... Preciso instalar o PHP5 com apache 2 so que4 ele vive dando pau na libxml2 como resolvo esse pro???
    Detalhe já a instalei (via rpm) no meu conectiva 10, e precisei compilar o meu php por conta de uma OCI

  6. #6
    guardian_metal
    Visitante

    Padrão nao consigo installar o php5.0 aki!

    Notei um erro ae, Vc não deve instalar o libxml2-2.6.10-2.src.rpm e sim o libxml2-2.6.10-2.i386.rpm. O pacote que você instalou são os fontes (src) e não o pacote ja pronto.

    Pega aqui estes dois:

    ftp://ftp.conectiva.com.br/pub/conec...0_1cl.i386.rpm

    ftp://ftp.conectiva.com.br/pub/conec...0_1cl.i386.rpm

    ou dá um apt-get install libxml2

    e depois compila seu php.