+ Responder ao Tópico



  1. #1
    vandemberg
    Visitante

    Padrão Problema com o mount...

    Colegas,
    Tive um problema aqui com o meu servidor de arquivos (kernel panic, nao iniciava) e tive que instala-lo em outro hd. depois da instalação quero agora tranferir os arquivos pra o hd atual. Acontece que quando vou montar o distema de arquivos pra copiar ele me dá os seguintes erros:

    [[email protected] root]# mount -t ext3 /dev/hdb2 /root/backup/
    mount: tipo de sistema de arquivos incorreto, opção inválida, superbloco inválido em /dev/hdb2,
    ou número excessivo de sistemas de arquivos montados


    [[email protected] root]# mount -t auto /dev/hdb3 /root/backup/
    /dev/hdb3 parece espaço de permuta - não montado
    mount: você precisa especificar o tipo do sistema de arquivos

    O que é isso? como faço pra montar o hd e copiar meus dados?

    Grato.

  2. #2

    Padrão Problema com o mount...

    primeiro vc tem q descobrir o filesystem q ele usa e em qual particao ele ta

    fdisk -l /dev/hda
    isso vai listar as particoes



  3. #3
    Visitante

    Padrão Problema com o mount...

    Sei que ele usa ext3 e tá no hdb2

    [[email protected] samba]# fdisk -l /dev/hdb

    Disco /dev/hdb: 255 cabeças, 63 setores, 2434 cilindros
    Unidades = cilindros de 16065 * 512 bytes

    Dispositivo Boot Início Fim Blocos Id Sistema
    /dev/hdb1 * 1 8 64228+ 83 Linux
    /dev/hdb2 9 2368 18956700 83 Linux
    /dev/hdb3 2369 2433 522112+ 82 Linux swap

  4. #4
    Visitante

    Padrão Problema com o mount...

    Citação Postado originalmente por Anonymous
    Sei que ele usa ext3 e tá no hdb2

    [[email protected] samba]# fdisk -l /dev/hdb

    Disco /dev/hdb: 255 cabeças, 63 setores, 2434 cilindros
    Unidades = cilindros de 16065 * 512 bytes

    Dispositivo Boot Início Fim Blocos Id Sistema
    /dev/hdb1 * 1 8 64228+ 83 Linux
    /dev/hdb2 9 2368 18956700 83 Linux
    /dev/hdb3 2369 2433 522112+ 82 Linux swap
    a partição hdb1 ele monta normalmente. muito estranho.



  5. #5
    Visitante

    Padrão Problema com o mount...

    mano
    descobre a partico depoos mount -t tipo /dev/hdbx /montado
    e num tem erro , foi feito para naum ter erro ..... eh soh digitar isso , que naum tera erro
    fui

  6. #6
    vandemberg
    Visitante

    Padrão Problema com o mount...

    Mas eu to fazendo isso cara..
    [[email protected] root]# mount -t ext3 /dev/hdb3 /root/backup/
    mount: tipo de sistema de arquivos incorreto, opção inválida, superbloco inválido em /dev/hdb3,
    ou número excessivo de sistemas de arquivos montados
    [[email protected] root]#

    Lembro-me que em algum momento ele me informou algo assim " No journal ... " ao tentar montar. só lembro disso.



  7. #7
    LenTu
    Visitante

    Padrão Problema com o mount...

    bom... q q rola dentro do hd... ?... tem algum SO diferente... sei lah...... algo do tipo...

  8. #8
    LenTu
    Visitante

    Padrão Problema com o mount...

    dah mais ou menos uma descrição do q tem na hd ai... pq eu to saindo fora... qq coisa me procura no icq, msn, email, sinal di fumaça, dança da chuva... q amanha eu to por ai... c ngm conseguir resolver..... logico.... o q eu acho beeeeeeeem dificil...

    di qq forma... FUI...

    abraços pra vcs q fikam.... naum chorem.. sei q vcs me amam... hauhauaua

    :twisted: :twisted: :twisted:



  9. #9
    vandemberg
    Visitante

    Padrão Problema com o mount...

    Roda o mesmo so que o outro. REdHat 8.0 com ext3
    .. Vejae a msg que sai no messages.
    Jul 2 08:02:21 server kernel: ext3: No journal on filesystem on ide0(3,66)
    tenho uma uma partição nesse hd que é a /boot, essa ele monta normalmente.

    Alguma idéia?

  10. #10

    Padrão Problema com o mount...

    Tenta dar um fsck.ext3 nessa partiçaum sua:
    fsck.ext3 /dev/hdb2

    e veh se tem alguma coisa errada com ela...



  11. #11
    vandemberg
    Visitante

    Padrão Problema com o mount...

    [[email protected] root]# fsck.ext3 /dev/hdb2
    e2fsck 1.27 (8-Mar-2002)
    /: clean, 204329/2371040 files, 3183564/4739175 blocks

  12. #12

    Padrão Problema com o mount...

    Entaum tenta montar o sistema de arquivos como ext2.
    mount /dev/hdb2 /root/backup -t ext2



  13. #13
    vandemberg
    Visitante

    Padrão Problema com o mount...

    nao monta..
    [[email protected] root]# mount /dev/hdb2 /root/backup/ -t ext2
    mount: tipo de sistema de arquivos incorreto, opção inválida, superbloco inválido em /dev/hdb2,
    ou número excessivo de sistemas de arquivos montados
    [[email protected] root#

  14. #14
    LenTu
    Visitante

    Padrão Problema com o mount...

    eh um chute mas vamo lah.....

    c jah tem otras coisas montadas ???

    se sim... desmonta... e tenta montar essa hd sozinha ai....

    :wink:



  15. #15

    Padrão Problema com o mount...

    Tira o disco desta máquina, coloca em outra máquina com linux, e tenta montar ele...

  16. #16
    vandemberg
    Visitante

    Padrão Problema com o mount...

    pessoal... acho que o problema é bem mais complicado do que agente pensa... tentei mudar o sistema de arquivos para ext2 e ver se dava certo.. uma partição deu certo a /boot /dev/hdb1 mas a que quero montar nao deu certo.. veja o erro:

    [[email protected] root]# tune2fs -O^has_journal /dev/hdb1
    tune2fs 1.27 (8-Mar-2002)


    [[email protected] root]# tune2fs -O^has_journal /dev/hdb3
    tune2fs 1.27 (8-Mar-2002)
    tune2fs: Bad magic number in super-block while trying to open /dev/hdb3
    Couldn't find valid filesystem superblock.

    Tem como eu reinstalar o RH sem apagar os dados existentes?



  17. #17

    Padrão Problema com o mount...

    Mas seu /dev/hdb3 naum eh a swap ???
    Os seus dados naum estaum em /dev/hdb2 ???

  18. #18
    vandemberg
    Visitante

    Padrão Problema com o mount...

    opa cara deu certo aqui....
    acontece que depois de dar o erro ao tentar montar, quando tentei novamente ele montou uma pasta lost+found quando eu entrei nela, adicinha o que tinha?
    1570021 #65580 #66369 #67154 #67941 #68728 #69546 #70334 #998705
    #1570022 #65581
    milhares de arquvos e pastas com esses nomes. quando dei um du -h * ele me mostrou todos os meus lindos arquivos detro de uma desssas pastas.

    Obrigado a todos pelas dicas.



  19. #19
    LenTu
    Visitante

    Padrão Problema com o mount...

    hauahuahuahua... altos problemas estranhos... mas jah q funciono... intaum tah bão neh...

    c vc descobrir algum dia q q foi issu postae.... pode ser q esse ET q te atacou ai.. possa voltar....

    :wink: