Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom Dia amigos,



    Estou enfrentando um problema com meu servidor Proftpd... reinstalei meu servidor e voltei os backups mas o FTP Server não carrega mais. já verifiquei o arquivo proftpd.conf, que antes da instalação funcionava normalmente...
    Com base no meu arquivo conf, será q alguém poderia me dar uma força?

    Obs: onde aparecer "server_name" são mensagens customisadas com o nome de meu servidor...


    # This is a basic ProFTPD configuration file (rename it to
    # 'proftpd.conf' for actual use. It establishes a single server
    # and a single anonymous login. It assumes that you have a user/group
    # "nobody" and "ftp" for normal operation and anon.

    ServerName "ProFTPD server_name"
    ServerType standalone
    DefaultServer on
    ServerAdmin root@server_name.net
    SyslogFacility auth

    # Allow FTP resuming.
    # Remember to set to off if you have an incoming ftp for upload.
    AllowStoreRestart on

    # Port 21 is the standard FTP port.
    Port 21

    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask 022

    MaxInstances 10

    # Set the user and group under which the server will run.
    User nobody
    Group nogroup


    # Normally, we want files to be overwriteable.
    DefaultRoot ~
    DefaultRoot ~
    <Directory /home>
    AllowOverwrite on
    AllowAll
    </Directory>

    # Needed for NIS.

    PersistentPasswd off

    # Default root can be used to put users in a chroot environment.
    # As an example if you have a user foo and you want to put foo in /home/foo
    # chroot environment you would do this:
    #
    # DefaultRoot /home/foo foo
    <Global>
    DefaultRoot ~
    RootLogin off
    AnonymousGroup "ftp ftpusers"
    AuthAliasOnly on
    MaxLoginAttempts 10
    UseFtpUsers on
    </Global>
    RootLogin on
    AuthAliasOnly on
    DisplayConnect ""FTP server_name!!""
    DisplayGoAway ""SERVIDOR OCUPADO - TENTE MAIS TARDE!""
    DisplayLogin ""server_name."
    DisplayQuit ""server_name... ""
    <Anonymous /temp>
    DeleteAbortedStores on
    LoginPasswordPrompt on
    AllowAll
    RequireValidShell on
    UseFtpUsers off
    RootLogin on
    AnonRequirePassword on
    AuthAliasOnly on
    DisplayGoAway ""SERVIDOR OCUPADO! TENTE MAIS TARDE!""
    DisplayLogin ""server_name!!!"""
    DisplayQuit "BYE"
    </Anonymous>
    UseFtpUsers off

    Se alguém tiver alguma dica...



    Abraços.


    Fábio.

  2. da uma olhada nos seus logs q eh + facil encontrar o erro..



  3. Amigos... boa tarde!


    Ainda estou nesta empreitada louca de fazer o Proftpd funcionar... mas creio q deva estar acontecendo algum tipo de conflito com o SQUID...
    vejam a mensagem de erro q é apresentada no Syslog:


    Jul 15 04:48:59 LNXMAIL proftpd: proftpd shutdown failed
    Jul 15 04:49:03 LNXMAIL proftpd[2139]: LNXMAIL - Failed binding to 0.0.0.0, port 21: Address already in use
    Jul 15 04:49:03 LNXMAIL proftpd[2139]: LNXMAIL - Check the ServerType directive to ensure you are configured correctly.



    O q pode estar ocorrendo... já não estou conseguindo visualizar os erros... estou desde às 8hs nisto e não estou conseguindo resolver.


    Alguém poderia me dar uma luz?



    Fábio.

  4. vc tem algum outro servico jah rodando na porta 21... veja qual eh
    fuser -n tcp 21
    ae veja o pid dele



  5. Bom... obrigado pelas dicas até agora... vc me ajudou a chegar no ponto x do problema... havia mesmo um serviço rodando na porta 21 conforme resultado do comando ps -ef abaixo:

    root 1604 1 0 Jul15 ? 00:00:00 xinetd -stayalive -reuse -pidfile /var/run/xinetd.pid


    eu terminando este serviço o Proftpd entra normalmente e funciona como deveria... mas toda vez q reinicio o servidor este serviço volta.
    Que serviço é este? Como posso impedí-lo de ser startado no boot?


    Abraços


    Fábio.






Tópicos Similares

  1. Respostas: 0
    Último Post: 29-03-2006, 16:53
  2. Servidor não aceita conexões
    Por gustavo_marcon no fórum Servidores de Rede
    Respostas: 1
    Último Post: 14-12-2005, 14:44
  3. Servidor VSFTP nao aceita conexoes de fora da rede local
    Por Sergio Jr no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-12-2005, 16:42
  4. Yahoo não aceita emails do meu servidor....
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 27-06-2005, 10:22
  5. Respostas: 6
    Último Post: 01-08-2002, 09:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L