Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    jigabo0
    Ola ! preciso de ajuda... eu estou tentando configurar o FC1 como gateway.. com duas placas de redes
    eth0 - conexao a cabo
    eth1 - interface local (LAN) (192.168.0.1)
    blz, inicia normalmente.. adicionei no /etc/rc.d/rc.local os comandos :
    modprobe iptable_nat
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    echo "1" > /proc/sys/net/ipv4/ip_forward

    configuro nas estacoes ip do gateway: 192.168.0.1
    dns: 192.168.0.1 ou o dns do provedor de internet

    e nao funciona... ! ah.... dei uma olhada no iptables
    olha como fica , ve se estar td certo...

    Tabela: nat
    Chain PREROUTING (policy ACCEPT)
    target prot opt source destination

    Chain POSTROUTING (policy ACCEPT)
    target prot opt source destination
    MASQUERADE all -- anywhere anywhere

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination



    agradeco, desde jah !

  2. Cara, tá tudo certo pelo o que eu estou vendo. As outras tabelas do seu firewall estão bloqueando alguma coisa? Improvável que isso seja verdade... mas o seu kernel está com as opções que o IP Forwarding utiliza?


    Abraços!



  3. no inicio das suas regras digite:

    iptables -F
    iptables -t nat -F

    tente ver como fica assim

    []'s

  4. #4
    Bruno_Freitas
    Olá!

    Como estão definidas as rotas quando vc digita o comando route? Caso o endereco de rede (IP/MASK) de eth0 seja diferente do endereco de rede de eth1 (bem provável se eth0 vai pra internet), vc deverá adicionar uma rota para eth0, senão o roteamento não funciona.

    Dúvidas quanto à rotas? #man route !!

    Espero ter ajudado!

    []s

    Bruno Freitas



  5. #5
    jigabo0
    Jah ! até que enfim descobri o erro... ! realmente a configuracao esta correta.., minha falha foi nao instalar o "BIND",
    nas estacoes eu estava pondo.. como server de dns 192.168.0.1 ! ... eu PENSEI ter posto o end. dns do provedor de internet... ! quando tentei denovo.. pos o end. dns. do prov. ae funcionou.. ! ae instalei o bind e dnsutils.. e pronto.. o end. do dns voltou a ser o do ip do gateway! funcionou.. ! muito obrigado gente... ! pela ajuda... !

    obrigado mesmo !

    muito grato a todos pela ajuda.. !






Tópicos Similares

  1. fonte do kernel no fedora core 5
    Por gleidsonlm no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 29-03-2006, 14:22
  2. atualizar kernel no fedora core 3
    Por underground-sa no fórum Servidores de Rede
    Respostas: 7
    Último Post: 08-03-2005, 14:25
  3. URGENTE!!! HSP On-Board no Fedora Core 2, kernel 2.6.5-1.358
    Por lessandrojf no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 03-08-2004, 23:30
  4. ADSL no FEDORA CORE
    Por MVZS no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-02-2004, 10:09
  5. Instalar Modem no Fedora Core 1
    Por Java no fórum Servidores de Rede
    Respostas: 8
    Último Post: 11-12-2003, 11:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L