+ Responder ao Tópico



  1. #1
    haas
    Visitante

    Padrão Problema com PPPoE

    Tenho um servidor fazendo pppoe com freebsd 5.2, derrepente ele parou de autenticar e no /var/log/messages fica dando direto a seguinte mensagem:

    server: Configuration label not found

    Já olhei um monte de documentação, mas não achei nada.

    o meu ppp.conf está assim:

    pppoe:
    set device "!/usr/sbin/pppoe -i xl0"
    allow users
    enable chap
    enable pap
    allow mode direct
    set mru 1492
    set mtu 1492
    set speed sync
    enable lqr
    set ifaddr 192.168.0.1 192.168.0.3-192.168.0.50 accept dns
    set dns 192.168.0.2 load server
    set timeout 0
    set radius /etc/radius.conf


    o meu rc.local está assim:

    pppoed_enable="YES"
    pppoed_provider="pppoe"
    pppoed_flags="-P /var/run/pppoed.pid"
    pppoed_interface="xl0"


    Alguém sabe que coisa é essa?

    Valeu!

  2. #2

    Padrão Problema com PPPoE

    Cara não sei não mas vc ja tentou reconfigurar o pppoe???



  3. #3

    Padrão Problema com PPPoE

    Bem...
    no rc.conf faz o seguinte

    pppoed_enable="YES"
    pppoed_provider="pppoe"
    pppoed_flags="-P /var/run/pppoed.pid -l server -a server"
    pppoed_interface="xl0"

    e outra.. para um servidor de pppoe funcionar legal, o nameserver local
    tem que estar funcionando muito bem para q o radius funcione legal tambem...
    tah ae! boa sorte
    []'s

  4. #4
    BrunoC
    Visitante

    Padrão Problema com PPPoE

    O erro "Configuration label not found" geralmente acontece quando o você chama o uma "sessão" do ppp.conf que não existe, no caso do seu ppp.conf, o label é 'pppoe:'

    Até onde minha experiência vai, o problema real é que o ppp.conf é um arquivo muito cheio de frescura... as configurações que você passa para cada label devem ser indentadas. Tenta fazer o seguinte: chegue pra direita tudo que vem abaixo da linha "pppoe" e veja se funciona. Assim:

    Código :
    pppoe:
       set device "!/usr/sbin/pppoe -i xl0" 
       allow users
       enable chap
       enable pap
       allow mode direct
       set mru 1492
       set mtu 1492
       set speed sync
       enable lqr
       set ifaddr 192.168.0.1 192.168.0.3-192.168.0.50 accept dns
       set dns 192.168.0.2 load server
       set timeout 0
       set radius /etc/radius.conf