+ Responder ao Tópico



  1. #1

    Padrão Problema na compilaçao do kernel 2.6.7!

    Seguinte ... eu usava slack9.1 e compilava o kernel(2.6.5) nele e funfava blza! Ai uma dia atualizei pro 10! Voltei a compilar o kernel (2.6.7) e continuou funfando perfeitamente.

    Só que eu precisei formatar o computador um dia desse. Daí resolvi logo instalar o Slack10!
    Aí quando fui compilar o kernel(2.6.7) da mesma maneira que sempre compilei aconteceu alguns problemas:

    1) Ele não criou os devices .. /dev/audio /dev/dsp /dev/pcm e por ai vai! Ou seja .. som n funfa!
    2) Ele insiste em dar FATAL ERROR: module aggart not found FATAL ERROR: module snd_algumacoisa not found e FATAL ERROR: module via-rhine not found! Só ki tipo!! a rede funfa(mesmo dando esse erro) .. o resto n sei pq n da pra usar som sem o device .. e nem preciso do aggart!
    AH!!! Não tem nada referente a esses modulos no rc.local rc.modules ou modprobe.conf!

  2. #2

    Padrão Problema na compilaçao do kernel 2.6.7!

    Tem como criar esses devices?



  3. #3

    Padrão Problema na compilaçao do kernel 2.6.7!

    suba todos os modulos q vc vai precisar e depois
    cd /dev/
    ./MAKEDEV

    qq duvida
    man MAKEDEV

  4. #4
    Mr_Mind
    Visitante

    Padrão Problema na compilaçao do kernel 2.6.7!

    qnd compilas um kernel, tens d tomar em atenção s vais compilar tudo monolítico (Y) ou tudo por módulos. eu prefiro instalar o suporte básico, como discos, filesystems, etc. e só depois selecciono módulos para o meu hardware, q o kernel, gentilmente carrega no início.
    esses do som, possivelmente terão a ver com isso mesmo
    verifica q tens o suporte da placa d som como módulo!



  5. #5

    Padrão Problema na compilaçao do kernel 2.6.7!

    A placa de som está como módulo mesmo!
    O problema não é a placa de som(tanto que ela foi detectado no alsaconf) ... são os devices! /dev/cdrom /dev/audio /dev/dsp e por aí vai! Ele não criou vários devices.
    Eu até tentei manualmente, mas o makedev n rolou!
    e agora?

  6. #6
    Mr_Mind
    Visitante

    Padrão Problema na compilaçao do kernel 2.6.7!

    ele n criou o /dev/dsp ?
    qual é a tua placa?

    2) Ele insiste em dar FATAL ERROR: module aggart not found FATAL ERROR: module snd_algumacoisa not found e FATAL ERROR: module via-rhine not found! Só ki tipo!! a rede funfa(mesmo dando esse erro)

    AGPART é do AGP, snd_algumacoisa é do som, via-rhine é de rede! o problema é q tens os drivers todos monolíticos, ou seja, não compilaste como módulos mas como fazendo parte integra do kernel.



  7. #7

    Padrão Problema na compilaçao do kernel 2.6.7!

    Ele n criou o /dev/dsp , nem o /dev/audio nem o /dev/cdrom e muitos outros!!
    Minha placa de som é uma via ac97! E tipo ele insiste em dar esses erros! Mas eu realmente como modulos... tanto que eu consigo carregar o modulo da rede e usar ela(a rede) normalmente!
    Eu tava achando que tinha algo a ver com o rc.local , rc.modules ou modprobe.conf . Aí fui olhar se tinha algo descomentado lá .. mas não achei nada!!
    o hotplug também eswtá desabilitado!
    Sobre o agpgart ... eu nem pus suporte a isso no kernel.

  8. #8

    Padrão Problema na compilaçao do kernel 2.6.7!

    Bom .. eu fiz uma coisa meiu estúpida mas funcionou!
    Eu formatei tudo! Instalei o slack9.1! Atualizei pro 10 com o swaret! Compilei o kernel 2.6.7! E tudo funfou perfeitamente! =P
    Só continua dando o FATAL ERROR: module snd_pcm_oss not found! Mas isso é de menos., já que o som continua funcionando perfeitamente!
    Ah! Outra sáida é fazer um bkp do dsp e mixer do kernel antigo!

    # mkdir /bkp
    # cp /dev/dsp* /bkp
    # cp /dev/mixer* /bkp

    Daí é so entrar no kernel mais novo e copiar de voltar pro /dev

    # cp /bkp/* /dev/

    Só que sempre tem que fazer isso ... e como gosto que tudo role perfeitamente ... preferi reinstalar tudo! =)