+ Responder ao Tópico



  1. #1

    Padrão VI não responde

    Pessoalm, sempre trabalhei com o VI para editar arquivos em modo texto, mas agora que estou usando slackware não estou conseguindo fazer isso.

    Eu sempre dava um ESC+I para entra em modo de edição, dai podia escrever apagar etc.. Agora não dá. Eu posso apagar mas não posso escrever. Pelo que me parece ele não entra mais em modo de edição.

    Alguém sabe porque?

    Obrigado!

  2. #2
    pflamellas
    Visitante

    Padrão VI não responde

    Kra,
    aperta a tecla insert.... aqui funfa legal



  3. #3
    slice
    Visitante

    Padrão VI não responde

    vc tá usando o vi mesmo???

    se vc não prestou atenção durante a instalação o slack instala o elvis por padrão...

    para consertar isso...

    [email protected]:~# whereis vi
    vi: /usr/bin/vi
    [email protected]:~# ls -l /usr/bin/vi
    lrwxrwxrwx 1 root root 3 Jul 17 19:10 /usr/bin/vi -> vim* #aqui ele esta apontando para o vim mesmo, mas o default é o elvis...
    [email protected]:~#cd /usr/bin
    [email protected]:/usr/bin#rm vi
    [email protected]:/usr/bin# ln -s /usr/bin/vim vi
    [email protected]:/usr/bin# cp /usr/share/vim/vim63/vimrc_example.vim /root/.vimrc

    pronto... seu vi já está funcionando belezinha...

    i para inserir;
    k para cima;
    j para baixo;
    l para direita;
    h para esquerda e o restante man vim


    []'s

    Slice

  4. #4

    Padrão Re: VI não responde

    Citação Postado originalmente por gustavo_marcon
    Pessoalm, sempre trabalhei com o VI para editar arquivos em modo texto, mas agora que estou usando slackware não estou conseguindo fazer isso.

    Eu sempre dava um ESC+I para entra em modo de edição, dai podia escrever apagar etc.. Agora não dá. Eu posso apagar mas não posso escrever. Pelo que me parece ele não entra mais em modo de edição.

    Alguém sabe porque?

    Obrigado!
    Se vc está usando o slack 10,
    o comando para inserir é Esc + i
    o comando para apagar é Esc + x
    espero ter ajudado



  5. #5

    Padrão VI não responde

    Tem certeza que o arquivo que tu ta tentando editar pode ser escrito pelo usuário que você está usando?

  6. #6
    Super_Diaulas
    Visitante

    Padrão VI não responde

    Sempre utilizei o Slack, agora estou com o 10, não tive problemas nenhum com vi,
    da mesma forma desde o 9,

    ESC + i



  7. #7
    gmlinux
    Visitante

    Padrão Re: VI não responde

    Citação Postado originalmente por gustavo_marcon
    Pessoalm, sempre trabalhei com o VI para editar arquivos em modo texto, mas agora que estou usando slackware não estou conseguindo fazer isso.

    Eu sempre dava um ESC+I para entra em modo de edição, dai podia escrever apagar etc.. Agora não dá. Eu posso apagar mas não posso escrever. Pelo que me parece ele não entra mais em modo de edição.

    Alguém sabe porque?

    Obrigado!
    <insert> or *i* *insert* *<Insert>*
    i Insert text before the cursor [count] times.

    *I*
    I Insert text before the first non-blank in the line
    [count] times.

    isto no VIM, olha se o vi que esta usando aceita I (maiusculo)