+ Responder ao Tópico



  1. #1
    Isac
    Visitante

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    Galera estou com um problema muito estranho e que nao consegui resolver de maneira alguma.

    Eu tenho um servidor conectiva 9 instalado com PHP4-4.3.1 + MySQL-3.23.46 + php4-mysql-4.3.1.

    Até ai tudo bem, o PHP funciona e o MySQL eu apenas consigo conectar localmente no servidor.

    Se eu utilizar o browser pra fazer alguma consulta ao banco ele simplesmente nao me retorna nada e tmb nao dá erro. Tentei colocar a senha errada para conectar ao banco e ai ele retorna um erro que nao foi possivel conectar ao banco, mas qnd coloco a senha certa ele simplesmente me traz a tela em branco.

    Já coloquei várias versoes do MySQL e nao resolveu.

    Alguém sabe o que pode estar acontecendo???

  2. #2

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    da uma olhada no error_log do apache



  3. #3

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    e/ou tbm da uma olhada nos scripts php pra ver se eles tao fazendo a coisa certa.....ou se tem algum return(0) ou exit() fora de lugar.....ou mesmo pra ver se o echo ta la ou nao..... :wink:

  4. #4
    Isac
    Visitante

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    O log de erro do apache nao tem informação nehuma a respeito disso e ainda por cima só tem erro de ontem, hoje ainda não tem nenhuma informação de erro.

    Com relação aos scripts, os arquivos PHP estão todos funcionando, pois eu utilizo em minha máquina que tem o php e mysql instalados e funciona perfeitamente, mas no servidor tá dando esse problema.



  5. #5

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    hmmmmm mostra pra gente como ta a sua linha do connect do php no mysql,
    jah tentou conectar no mysql pela linha de comando pra ter certeza q ta funfando?

  6. #6
    Isac
    Visitante

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    Pela linha de comando no server eu consigo conectar, consultar.... vá blz.

    no PHP a minha conexão tá sendo feita assim:

    $con=mysql_connect("localhost","usuario","senha");

    e pra selecionar o BD tá assim:

    mysql_select_db("database",$con);



  7. #7

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    faz assim

    $con=mysql_connect("localhost","usuario","senha") or die(mysql_error());

    veja se agora ele mostra alguma coisa na tela

  8. #8
    Isac
    Visitante

    Padrão Problema com MYSQL 3.23.46 + PHP 4-4.3.1

    Fiz o que vc me falou e nao retorna erro nenhum. Inclusive eu coloquei uma mensagem na hora da conexão pra saber se havia conectado ao banco e a mensagem apareceu, entao eu deduzo que está conectando ao banco, mas na hora de trazer os resultados nao funciona.

    É bem estranho o que tá acontecendo.

    Isso tudo funcionava perfeitamente no conectiva 8, mas eu migrei pro 9 e agora a parte do mysql nao quer funcionar