Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Daniels
    Ae galera... montei um serv dns (bind-9.2.3) e postfix no CL 10, Kernel 2.6. O negocio eh o seguinte. Estou com dois problemas... num sei se tem ligação entre eles. Quando tento enviar uma msg apartir dele para um dominio externo, ele vai sem probl. Mas qnd eh pra um dominio interno, a msg num eh enviada. E me retorna a seguinte msg no log do postfix: 'Status=deferred... Name service error... Unknow host'. Lembrando q o serv de email eh outro, e eh o serv de dns secundario. Outra coisa eh q num consigo pingar o dominio interno do serv dns primario. Mas de fora consigo pingar, e quem responde eh ele mesmo. O outro problema eh q qnd o secundario tenta atualizar o dns, no log do serv de dns primario aparece a seguinte msg: 'file not found'. To percebendo q o secundario num ta conseguindo atualizar o dns com o primario. Seria algum problema de firewall??? Ou de configuração dns??? Ou de conf do postfix???

    Valeu ae...

  2. #2
    Daniels
    Outra coisa: qnd eu dou o comando:

    "host -l 'meu_dominio'";

    ...me retorna essa msg:

    "Host 'meu_dominio' not found: 2(SERVFAIL); Transfer failed."'.

    E qnd eu dou o comando:

    "host -d 'nome_da_minha_maq'";

    ...ele me retorna essa msg:

    "Trying 'nome_da_minha_maq_mais_dominio'
    Trying 'nome_da_minha_maq'
    host 'nome_da_minha_maq' not found: 3(NXDOMAIN)
    Received 96 bytes from 120.0.0.1#53 in 1 ms"

    :?

    Alguem ja teve esse problema??? Num consigo resolver de jeito nenhum!!!



  3. #3
    Daniels
    Outra coisa... qnd eu dou do meu serv "nslookup 'meu_dominio_interno'". Aparece a seguinte msg:

    Server: 127.0.0.1
    Address: 127.0.0.1#53

    ** server can't find 'meu_dominio_interno': SERVFAIL

    Falouz.

  4. #4
    jghellere
    Vc tem o dns da sua rede interna configurado ?
    tipo:

    db.externo
    db.interno

    e no seu /etc/named.conf, as entradas:

    zone "interno" {
    type master;
    file "db.interno";
    };

    zone "externo" {
    type master;
    file "db.externo";
    };

    já no caso do host e nslookup, vc tem q ter configurado o dns reverso, para os 2 funcionarem internamente.

    Veja tbm se sua configuração reversa está apontando corretamente para o nome do servidor interno:

    db.interno

    @ IN NS interno.dominio.

    Verifique se o "ponto(.)" no final do nome existe tbm.. isso é importante.

    flw



  5. #5
    amigo , eu estava com o mesmo problema q o seu no meu servidor DNS aqui , apos ver seu topico entrei , e jah consegui arrumar , a parada ta no arkivo de zona mencionado no named.conf

    eh oq nosso amigo ae falo , o SOA tem q estar para ele mesmo , como o meu , olhe

    @ IN SOA NS.254.168.192.in-addr.arpa. root.254.168.192.in-addr.arpa. (
    199802151 ; Serial, todays date + todays serial
    8H ; Refresh
    2H ; Retry
    1W ; Expire
    1D) ; Minimum TTL
    NS NS.254.168.192.in-addr.arpa.
    ;
    1 PTR makina1.MEUDOMINIO.com.br.
    2 PTR makina2.MEUDOMINIO.com.br


    ~~~~~~ > Ali no comesso ta a manha , depois do SOA ...
    OLHE NO NSLOOKUP
    192.168.254.1
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    1.254.168.192.in-addr.arpa name = makina1.MEUDOMINIO.com.br.






Tópicos Similares

  1. Problema com firewall no CL 10
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 05-08-2005, 16:39
  2. Problema com serv DNS - CL 10
    Por Daniels no fórum Servidores de Rede
    Respostas: 9
    Último Post: 15-04-2005, 09:30
  3. Problemas com o DNS reverso no serv
    Por Daniels no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-02-2004, 15:02
  4. Problemas com o DNS - URGENTE
    Por Legolas no fórum Servidores de Rede
    Respostas: 4
    Último Post: 05-01-2004, 20:04
  5. Problemas com Dinamic DNS
    Por no fórum Servidores de Rede
    Respostas: 8
    Último Post: 03-07-2003, 18:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L