+ Responder ao Tópico



  1. #1
    __FERNANDO__
    Putz..me ajudem por favor...
    Vou explicar o cenario.
    No escritorio tenho um servidor win2000srv(192.168.15.10) onde configurei uma VPN e tenho como gateway/firewall um Conectiva Linux 10(200.100.50.25).
    Na loja(rua de trás) tenho um gateway/firewall Linux(200.150.75.10) e uma estação win98se(192.168.30.5).
    Eu quero que desta estação win98 consiga acessar a VPN que está no servidor2000srv.
    No gateway no escritorio eu criei a seguinte regra:
    iptables -t nat -A PREROUTING -s 200.150.75.10 -p tcp -m tcp --dport 1723 -j DNAT --to-destination 192.168.15.10.
    iptables -t nat -A PREROUTING -s 200.150.75.10 -p tcp -m tcp --dport 47 -j DNAT --to-destination 192.168.15.10.
    Mas não está funcionando...ele fica na tela de verificando usuario e senha e depois da erro.... internamente eu acesso a VPN normalmente...mas da loja não está rolando.
    Conversei com um amigo ele disse que eu tinha que fazer um mascaramento, porque VPN não funciona igual a por exemplo: VNC. Terminal Service e etc... Porque depois o linux não sabe para quem entregar a resposta para a rede da loja...não entendi direito...mas precisava que alguém me ajudasse a resolver isto.
    Desde já, obrigado.
    Fernando.
    MSN: fnd@2002@hotmail.com

  2. por um acaso seu modem e um DSLINK ou DYNALINK ou um PARKS? emmodo router?



  3. #3
    dispatcher
    É isso mesmo! Nas suas regras vc especificou o source ( ou seja , a origem , como 200.150.75.10 que é o gateway da loja. Mas o source nao é o gateway , e sim a estacao win. Entao para essas suas regras funcionarem vc tem que acrescentar a seguinte regra no seu gateway da loja:
    iptables -t nat -A POSTROUTING -s 192.168.30.5 -o ethx -j SNAT to 200.150.75.10
    onde ethx é sua interface externa (de saída)
    Com isso , sua estacao vai sair com o ip do gateway. Se vc tiver algum outro endereco valido , pode fazer sua estacao sair com esse outro ip. Para isso basta substituir 200.150.75.10 para 200.150.75.x ( seu outro ip) na regra acima e tambem nas regras do gateway do escritorio






Tópicos Similares

  1. autenticação squid nao esta funcionando
    Por muganga no fórum Servidores de Rede
    Respostas: 6
    Último Post: 18-02-2004, 12:50
  2. Meu SMTP do Qmail não esta funcionando Rede Externa!!!!
    Por maiconovic no fórum Servidores de Rede
    Respostas: 3
    Último Post: 18-10-2003, 09:08
  3. Respostas: 10
    Último Post: 11-06-2003, 07:20
  4. DNS Nao esta funcionando
    Por earaujos no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-02-2003, 14:40
  5. acl no squid não está funcionando. O que fazer ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 16:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L