+ Responder ao Tópico



  1. #1
    goiaba-linux
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Alguém aí pode me ajudar a resolver um problema que tá osso pra mim...!!??
    A parada é o seguinte ... fiz a instalação do Apache-2.0.50 , PostgreSQL-7.4.3 e o PHP-4.3 e o PhpPagAdmin.. Até ai tudo bacana .... más quando eu digito o usuário e a senha .. aparece a seguinte mensagem ..:::

    Você não compilou suporte à banco de dados apropriado em sua instalação do PHP.


    Aí eu fui lá no php.ini e acrescentei o pgsql.so e o caminho dele... aí quando eu dou um php aparece a seguinte mensagem ..

    PHP Warning: Unknown(): Invalid library (maybe not a PHP library) 'pgsql.so' in Unknown on line 0



    Alguém sabe como posso resolver o problema????

    goiaba-linux

  2. #2
    slice
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    na hora de compilar o php use ./configure --help e veja qual o flag que habilita o pgsql no php... de preferencia leia e entenda todo o help que ele vai gerar, pois é aí que vc consegue habilitar/desabilitar tudo no php, sendo assim tua instalação vai ficar bem mais segura, leve e personalizada.

    []'s

    Slice



  3. #3
    goiaba-linux
    Visitante

    Padrão PhpMysql

    O problema é que já passei os parâmetros necessários na minha instalação . Adicionei tabém o PostgreSQL , com o parâmetro --with-pgsql=/DIR

  4. #4
    slice
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    qual foi este /DIR que vc colocou???



  5. #5
    goiaba-linux
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Deixa eu te passar todos os parâmetros em eu executei..!!!
    Isso no PHP

    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-module=so --with-pgsql=/usr/local/src/postgresql-7.4.3/src/interfaces/libpq


    Aí depois disso eu gerei o pgsql.so e o coloquei no php.ini..!

    Gustavo
    goiaba-linux

  6. #6

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Citação Postado originalmente por goiaba-linux

    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-module=so --with-pgsql=/usr/local/src/postgresql-7.4.3/src/interfaces/libpq
    quase perfeito....soh q tenta fazer assim:
    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-module=so --with-pgsql=/usr/local/src/postgresql-7.4.3/



  7. #7
    goiaba-linux
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Olá ..!!
    Quando eu executo o comando que eu estava usando anteriormente.

    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-module=so --with-pgsql=/usr/local/src/postgresql-7.4.3/src/interfaces/libpq

    Dá o seguinte erro.

    /usr/local/src/php-4.3.8/ext/pgsql/pgsql.c:2241: parse error before "oid_long"
    make: ** [ext/pgsql/pgsql.lo] Erro 1

    O erro é no make



    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-module=so --with-pgsql=/usr/local/src/postgresql-7.4.3/

    E quando eu executo o que você me disse .. O erro é o seguinte


    checking for PostgreSQL support... yes
    configure: error: Cannot find libpq-fe.h. Please specify correct PostgreSQL installation path


    E esse erro é no configure

  8. #8
    jamba
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Tente colocar a path do pgsql ja instalado no sistema e nao o pacote descompactado



  9. #9

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Citação Postado originalmente por jamba
    Tente colocar a path do pgsql ja instalado no sistema e nao o pacote descompactado
    perae.....esse dir aki:
    /usr/local/src/postgresql-7.4.3/

    eh o diretorio do fonte?????? vc tem q colocar o diretorio de instalacao....tipo
    /usr/local/pgsql
    ou
    /usr/local/

    eh q eu uso esse padrao pra instala e achei q ele tinha usado tbm

  10. #10
    goiaba-linux
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Eu coloquei na pasta que eu indiquei na compilação .. Através do prefix..!!
    Eu fiz os testes , tanto indicando a pasta com os fontes quanto a pasta que eu indiquei na compilação .. e Nada..!!!!!

    To quase instalando os RPM's mesmo ..!!



    goiaba-linux



  11. #11

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    calma...nao se desespere.....qual foi o prefix q vc usou na instalacao do postgresql, e qual o diretorio q vc coloco pra compilar o php???

  12. #12
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Eu estou achando é o seguinte :
    Teve um cara da Empresa que tinha instalado o PostgreSQL , não sei como , e o maldito entrou de férias . Por isso o que eu fiz..:
    Baixei os Códigos-fonte do PostgreSQL , e passei o seguinte parâmetro no configure


    ./configure --prefix=/usr/local/pgsql

    Isso eu fiz somente para que eu tivesse um lugar para pegar os arquivos do PostgreSQL que eu precisava ( não sei se eu fiz certo).

    E deve ser isso que deve tá dando pau..!! não sei..!

    Aí na compilação do PHP eu indiquei o seguinte caminho

    /usr/local/pgsql


    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-module=so --with-pgsql=/usr/local/pgsql


    Olha pra ver se você me dá uma idéia..!!!
    Como eu tive que colocar o banco em produção eu fiz as configurações com uma outra máquina , com todos os pacotes instalados com os RPM's do Redhat 9.0 . Más a máquina que eu não consegui instalar tá lá ainda..!


    Goiaba-linux



  13. #13

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    nao sei se pode ser isso....mas toda vez q eu instalei o php com suporte ao postgresql eu usei junto a opcao --enable-dbase ve se isso resolve

  14. #14
    jamba
    Visitante

    Padrão Apache + PostgreSQL + PHP + PhpPgAdmin

    Ae maninho se liga na minha compilacao

    PGSQL
    Código :
    ./configure --prefix=/usr/local/postgres --libdir=/usr/lib/postgresql/lib/ --with-perl --with-odbc --with-openssl  --datadir=/etc/postgresql/ --with-pgport=5432 --sysconfdir=/etc/postgresql --bindir=/usr/lib/postgresql/bin/ --mandir=/usr/share/man/ --docdir=/usr/share/postgresql/

    PHP-4.3.4
    Código :
    ./configure --with-pgsql=/usr/local/pgsql/ --with-mysql=/usr/local/mysql/ --with-mysql-sock=/tmp/mysql.sock --with-apxs2=/usr/local/apache2/bin/apxs --with-config-file-path=/etc/ --with-pear=/usr/share/pear/ --with-gettext --with-xml --with-openssl  --with-gd --with-jpeg-dir=/usr/lib/ --with-zlib-dir=/usr/include/ --with-freetype-dir=/usr/include/freetype2/ --with-png-dir=/usr/lib/ --with-xpm-dir=/usr/X11R6/lib/