+ Responder ao Tópico



  1. #1
    Linky
    Visitante

    Padrão Recompilando o Kernel....

    Bom dia a todos,

    Pessoal estou recompilando o meu kernel para a versão 2.6.7 e parei na seguinte dúvida:
    Sei que para instalar o kernel novo tenho que ter alguns programas instalados e/ou atualizados, eu baixei um tutorial onde me passa essa lista para o kernel 2.6.x então como sou novo em linux gostaria de saber se todos esses programas são nescessários ou se posso optar por não atualizar ou instalar alguns que não venham a ser úteis ou nescessários para o kernel, lembrando que: Estou usando um Red Hat 7.3 e instalei somente o modo texto, e irei utilizá-lo como um router.
    Abaixo segue a tal lista:

    Software Versão

    Gnu C 2.95.3
    * Gnu make 3.79.1
    binutils 2.12
    * util-linux 2.10
    * module-init-tools 0.9.10
    -> e2fsprogs 1.29
    jfsutils 1.1.3
    -> reiserfsprogs 3.6.3
    xfsprogs 2.6.0
    pcmcia-cs 3.1.21
    -> quota-tools 3.09
    * PPP 2.4.0
    * isdn4k-utils 3.1pre1
    -> nfs-utils 1.0.5
    -> procps 3.2.0
    oprofile 0.5.3

    O que tá marcado como (*) é que eu já tenho esta versão, o que ta com (->) é que eu tenho que atualizar e os demais eu não tenho pois deu a mensagem "comand not fond" quando eu tentei ver qual era a versão, tipo:

    #ld -V (para o binutils)

    Valeu e desde já agradeço pela ajuda de todos..

  2. #2
    gmlinux
    Visitante

    Padrão Recompilando o Kernel....

    Gnu C 2.95.3 sim
    * Gnu make 3.79.1 sim
    binutils 2.12 sim
    * util-linux 2.10 sim
    * module-init-tools 0.9.10 sim
    -> e2fsprogs 1.29 se usa ext2 ou ext3
    jfsutils 1.1.3 se usa filesystem jfs
    -> reiserfsprogs 3.6.3 se usa filesystem reiserfs
    xfsprogs 2.6.0 se usa filesystem xfs
    pcmcia-cs 3.1.21 se tiver usando device pcmcia
    -> quota-tools 3.09 se usar quota (em router? duvido que esteja)
    * PPP 2.4.0 ja esta
    * isdn4k-utils 3.1pre1 ja esta
    -> nfs-utils 1.0.5 se usa nfs (em router? duvido)
    -> procps 3.2.0 sim
    oprofile 0.5.3 nunca usei este pacote, não sei o que faz



  3. #3
    Linky
    Visitante

    Padrão Recompilando o Kernel....

    Valeu pela ajuda cara ...então é só eu atualizar o que falta e já eras .. valeu vou tentar pra ver se da certo...