+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Pen Driver

    Pessoal acabei de instalar um conectiva 9 e preciso reconhecer minha pen driver de 128.

    dei um dmseg e ele me respondeu o seguinte:

    hub.c: new USB device 00:10.0-1, assigned address 5
    WARING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 5

    Como é a primeira vez que instalalo, não sei o que fazer!!!

    Por favor me ajudem!!!!

    Muito Obrigado

  2. #2

    Padrão Pen Driver

    agora eh soh vc montar ela num precisa fazer + nda

    mkdir /mnt/usb
    mount /dev/sda0 /mnt/usb



  3. #3
    Visitante

    Padrão Pen Driver

    Obrigado pela dica....

    Mas quando eu uso o mount ele pede para eu especificar o tipo de arquivo.

    Eu vou utilizar esse flash para colocar o Star os para rodar em uma torre minha... qual o tipo de arquivo eu preciso especificar para funcionar o que eu preciso????

    Mais uma vez obrigado

  4. #4
    Visitante

    Padrão Pen Driver

    O sistema dis que /dev/sda0 não existe.

    O que pode estar acontecendo????



  5. #5

    Padrão Pen Driver

    modprobe usb-uhci
    modprobe usb-storage

  6. #6
    Visitante

    Padrão Pen Driver

    Beleza amigo

    entrei com os modulos e ele aceitou....

    no dmesg:

    SCSI subsystem driver Revision: 1.00
    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    scsi0 : SCSI emulation for USB Mass Storage devices
    Vendor: S Talent Model: Flash Drive 2.0 Rev: 2010
    Type: Direct-Access ANSI SCSI revision: 02
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 2
    USB Mass Storage support registered.

    mas quando eu digito:

    [[email protected] root]# mount -t vfat /dev/sda0 /mnt/usb/
    mount: o dispositivo especial /dev/sda0 não existe

    Também tentei:

    [[email protected] root]# mount -t vfat /dev/sda1 /mnt/usb/
    mount: /dev/sda1 não é um dispositivo de blocos válido

    Se puder me auxiliar mais uma vez ficaria muito grato!

    Obrigado



  7. #7
    Visitante

    Padrão Pen Driver

    faltou isso!!!

    Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
    SCSI device sda: 252928 512-byte hdwr sectors (129 MB)
    sda: Write Protect is off
    sda:
    FAT: bogus logical sector size 64543
    VFS: Can't find a valid FAT filesystem on dev 08:00.

    Obrigado

  8. #8

    Padrão Pen Driver

    bom tem alguma coisa nele? ou vc vai comecar a usar agora?



  9. #9
    Visitante

    Padrão Pen Driver

    vou começar a usar agora!!!

    eu dei um cfdisk /dev/sda e ele encontrou!!!
    dai eu criei uma partição e reiniciei!!!!

    depois eu dei um dmesg e apareceu o seguinte:

    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    scsi0 : SCSI emulation for USB Mass Storage devices
    Vendor: S Talent Model: Flash Drive 2.0 Rev: 2010
    Type: Direct-Access ANSI SCSI revision: 02
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 2
    USB Mass Storage support registered.
    LVM version 1.0.5+(22/07/2002) module loaded
    loop: loaded (max 8 devices)
    Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
    SCSI device sda: 252928 512-byte hdwr sectors (129 MB)
    sda: Write Protect is off
    sda: sda1

    Ele encontrou e nomeou como sda1 certo?

    Mas quando eu tento montar ele aparece o seguinte:

    [[email protected] root]# mount -t vfat /dev/sda1 /mnt/usb/
    mount: tipo de sistema de arquivos incorreto, opção inválida, superbloco inválido em /dev/sda1,
    ou número excessivo de sistemas de arquivos montados


    O que pode ser?????

    Obrigado mais uma vez!

  10. #10

    Padrão Pen Driver

    como voce nao usou ele nao tem nenhum fileysystem, simplesmente so a memoria, para formatar como por exemplo ext3:

    mkfs.ext3 /dev/sda1

    e por ai vai.



  11. #11
    Visitante

    Padrão Pen Driver

    Putz.... Era isso mesmo!!!!

    olha como ficou quando eu dou o comando mount:

    [[email protected] usb]# mount
    /dev/hda2 on / type ext3 (rw)
    none on /proc type proc (rw)
    usbdevfs on /proc/bus/usb type usbdevfs (rw)
    none on /dev/pts type devpts (rw,gid=5,mode=620)
    /dev/sda1 on /mnt/usb type ext3 (rw)

    Ele finalmente reconheceu a flash!!!

    Se eu colocar no fstab dessa maneira está certo??

    /dev/hda1 swap swap defaults 0 0
    /dev/hda2 / ext3 defaults 0 0
    /dev/cdrom /mnt/cdrom iso9660 defaults,user,noauto,ro 0 0
    /dev/fd0 /mnt/floppy auto defaults,user,noauto 0 0
    none /proc proc defaults 0 0
    none /dev/pts devpts gid=5,mode=620 0 0
    /dev/sda1 /mnt/flash ext3 ro,user,noauto 0 0

    acho que isso é suficiente não é????

    Muito obrigado pessoal do underlinux!

  12. #12

    Padrão Pen Driver

    sim, mas se voce voce por:

    /dev/sda1 /mnt/flash ext3 ro,user,noauto 0 0

    sera somente leitura, e no caso voce quer escrever tambem, entao tire o ro ou entao explicite o rw

    no caso se voce levar para uma maquina ele nao conseguira ler o filesystem jah que nao eh vfat/ntfs ... cabe a voce a decisao de qual FS voce quer manter



  13. #13
    Visitante

    Padrão Pen Driver

    Entendi...

    Na verdade o meu problema era o seguinte:

    eu preciso instalar o star-os nessa flash para dar boot por ela.
    fui informado que eu precisava instalar o linux para reconhecer essa flash para depois de instalada, eu pudesse mandar a imagem do star-os para ela com o comando dd if= \root\imagem.raw of \dev\sad1 , por isso precisava instalar a flash.

    Pelo menos foi a saida que me passaram... se existir outra maneira mais fácil..eu não sabia.

    mas acho que agora tudo está mais fácil, pois só preciso executar esse comando para que a imagem seja transferida para a flash. para eu dar boot.

    ou não???

    Obrigado

  14. #14
    mxmaicon
    Visitante

    Padrão Star-OS

    Eu gostaria de saber se conseguiu dar boot pela pen drive usb... pois eu fiz tudo o que vc fez aqui... eu estava com este mesmo problema... agora naum boota.. parece que esta com pau no lilo... aparece um montão de 99999999999999999999999999999999999999999999.

    Ficarei grato se me ajudar!

    javascript:emoticon('')
    Surprised

    Citação Postado originalmente por Anonymous
    Entendi...

    Na verdade o meu problema era o seguinte:

    eu preciso instalar o star-os nessa flash para dar boot por ela.
    fui informado que eu precisava instalar o linux para reconhecer essa flash para depois de instalada, eu pudesse mandar a imagem do star-os para ela com o comando dd if= \root\imagem.raw of \dev\sad1 , por isso precisava instalar a flash.

    Pelo menos foi a saida que me passaram... se existir outra maneira mais fácil..eu não sabia.

    mas acho que agora tudo está mais fácil, pois só preciso executar esse comando para que a imagem seja transferida para a flash. para eu dar boot.

    ou não???

    Obrigado