+ Responder ao Tópico



  1. #1
    BZ
    Visitante

    Padrão Nagios - Desespero

    Amigos,
    Boa Tarde,
    Antes de mais nada, gostaria de estar pedindo desculpas por esta enchendo o forum com mais uma duvida, é que realmente, empaquei nessa a 5 dias e está batendo o desespero...
    Instalo Nagios a 2 anos, nunca tive esse tipo de problema.
    MEU PROBLEMA É:
    Configuro os Hosts e servios perfeitos, todos os checks funcionam , com status ok, Check HTTP, DNS, FTP, WINS, PROCESOS, USUARIOS, FREE SPACE, todos, em geral, são monitorados e aprovados, setando status ok.
    Até ai tudo as mil maravilhas, nada de errado.

    POREM!!!!!
    o Check PING, em nenhum momento fica com status ok, ele fica laranja com a sigla UNKNOW, sendo quea amquina PINGA.
    1 - Eu copio e colo a sintaxe do check ping no terminal, ela funciona perfeitamente
    2 - se a amquina consegue checar o serviço de dns, http e outros do remoto, quer dizer q encherga / pinga



    No messages, me deparo com a seguinte mensagem:

    "Aug 25 15:28:28 rjoaslnx001 nagios: Warning: Attempting to execute the command "/usr/bin/printf "%b" "***** Nagios *****\n\nNotification Type: PROBLEM\nHost: RJOASSRV002\nState: DOWN\nAddress: 192.168.100.111\nInfo: /bin/ping -n -U -c 1 192.168.100.111\n\nDate/Time: Wed Aug 25 15:28:28 BRT 2004\n" | -s "Host DOWN alert for RJOASSRV002!" [email protected]" resulted in a return code of 127. Make sure the script or binary you are trying to execute actually exists...
    "



    ALGUEM SABE ME AJUDAR?
    ja reistalei e não consigo mais imaginar o que possa estar dando errado :/
    obrigado :/
    []s

  2. #2

    Padrão Nagios - Desespero

    Será que você não teve problema ao compilar os plugins. eu tive um problema em que todos os cgis funiconavam bem, menos um. E por causa disso não conseguia verificar algumas informações. Após recompilar ficou tudo ok!



  3. #3
    gustavofd
    Visitante

    Padrão Nagios - Desespero

    Não sei se vou ajudar muito, mas digita:

    ldd check_ping

    o ldd verifica se os caminhos estão todos corretos...

    e tenta ping <ip>

    pois o dns respondendo, o http e outros não quer dizer q o ping vai responder.

    abraços,

    gustavo

  4. #4
    BZ
    Visitante

    Padrão Nagios - Desespero

    Putz... NADA.. to ficando maluco.. aponto de desistir.. e o pior é que está tudofuncionando....


    [[email protected] libexec]# ldd check_ping
    linux-gate.so.1 => (0xffffe000)
    libc.so.6 => /lib/libc.so.6 (0x40037000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
    [[email protected] libexec]# ./check_ping -H XXX.XXX.XXX.XXX -w 100.0,20% -c 500.0,60%
    PING OK - Packet loss = 0%, RTA = 0.57 ms
    [[email protected] libexec]#



    nâo sei mais o q fazer....



  5. #5
    BZ
    Visitante

    Padrão Nagios - Desespero

    CONSEGUI GALERA!!!
    NAO ACREDITO!!!!!
    E SO DAR:

    chmod 4755 /bin/ping


    o ping não tinha permisao pro user nagios :X lol

    bom, mais uma cascuda expereiencia em 2 anos de nagios!
    []'s
    PS: problema apresentado apenas na Cl10 , as anteriores não davam esse problema!