+ Responder ao Tópico



  1. #1
    violinista
    Falaê, galera !!!

    Estou tendo um probleminha com o apt-get ... há um tempo atrás tentei instalar alguns programas via apt (jogos ou o wine, se não me engano ops: ), mas não deu certo, e eu desisti ... agora, quando tento instalar qualquer coisa via apt, dá essa msg de erro:

    Código :
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Você deve querer rodar `apt-get -f install' para corrigir isso:
    Os pacotes a seguir têm dependências desencontradas:
      libice-dev: Depende: libice6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libsm-dev: Depende: libsm6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libx11-dev: Depende: libx11-6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxext-dev: Depende: libxext6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxi-dev: Depende: libxi6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxmu-dev: Depende: libxmu6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxmuu-dev: Depende: libxmuu1 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxp-dev: Depende: libxp6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxpm-dev: Depende: libxpm4 (= 4.3.0.dfsg.1-4)
      libxrandr-dev: Depende: libxrandr2 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxt-dev: Depende: libxt6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxtrap-dev: Depende: libxtrap6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxtst-dev: Depende: libxtst6 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      libxv-dev: Depende: libxv1 (= 4.3.0.dfsg.1-4) mas não vai ser instalado
      wine: Depende: libwine (= 0.0.20040716-1) mas não vai ser instalado
    E: Dependências desencontradas. Tente `apt-get -f install' sem nenhum pacote (ou especifique uma solução).

    Quanto eu dou um apt-get -f install, conforme sugerido, aparece akela msg padrão do apt-get, listando os pacotes q serão instalados, pedindo confirmação ... eu digito "S" e teclo enter ... ele baixa alguns arquivos e mostra essa msg:

    Código :
    Preparando para substituir libxtst-dev 4.3.0.dfsg.1-4 (usando .../libxtst-dev_4.3.0.dfsg.1-6_i386.deb) ...
    Descompactando substituto libxtst-dev ...
    Descompactando libxtst6 (de .../libxtst6_4.3.0.dfsg.1-6_i386.deb) ...
    dpkg: erro processando /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-6_i386.deb (--unpack):
     tentando sobrescrever `/usr/X11R6/lib/libXtst.so.6.1', que também está no pacote xlibs
    dpkg-deb: subprocesso paste morto por sinal (Broken pipe)

    Obs.: Essa msg se repete para cada um dos arquivos acima. Não coloquei aki pq eh mta coisa ...

    Depois disso o apt mostra que encontrou erros durante o processamento de todos os arquivos listados acima ... e ainda diz q o sub-processo /usr/bin/dpkg retornou um código de erro (1) ...

    Obs.: o apt-get update funciona normalmente.

    Minha distro é o Kurumin, kernel 2.4.22 ...

    Agora eu estou precisando instalar outros programas, mas estou com esse problema (dessa vez não são jogos ... eh para o serviço msm .... :lol: ) ...

    Será q alguém tem uma idéia do q pode estar acontecendo e como faço pra resolver ???

    Desde já, valewssss !!!

    T+ !

  2. Bom, você está pegando os pacotes disponíveis para qual versão do Debian? Como o Kurumin foi baseado na unstable, ele só vai aceitar pacotes da unstable, a não ser que você rode um apt-get dist-upgrade.


    Abraços!



  3. #3
    Arkanoid
    Já tive esses problemas com o kurumin; o problema deve ser nas fontes de pacotes que ele coloca no sources.list. Alguma dessas fontes deve ter pacotes com dependências mal configuradas, que "quebram" o resto...

    Não sei te dar uma resposta direta, mas vai algumas sugestões:
    - parece que o maior problema está em libs usadas pelo Xserver; veja se tem no sources.list uma entrada para algum Xserver diferente do padrão da Debian, comente a linha, rode apt-get update; apt-get dist-upgrade
    - tente postar esse problema no fórum do kurumin, quem sabe o próprio Morimoto ou alguém mais acostumado com ele já sabe de cara uma solução.






Tópicos Similares

  1. APT-GET como fazer para remover pacote driblando as dependências...
    Por luccosta no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 14-06-2006, 16:58
  2. Erro de dependencia no apt-get.
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 01-03-2004, 11:54
  3. Desinstalar o apt-get install dist-upgrade
    Por Zephirot no fórum Servidores de Rede
    Respostas: 1
    Último Post: 20-11-2003, 00:32
  4. Apt-Get
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-02-2003, 17:35
  5. Core Dump executando apt-get check
    Por Jwalker no fórum Servidores de Rede
    Respostas: 2
    Último Post: 21-08-2002, 09:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L