hello pessoas,

Tenho 2 servidores Suse 9.0 identicos na instalaçao

rpm -qi freeswan
Name : freeswan Relocations: /usr
Version : 2.04_1.5.3 Vendor: SuSE Linux AG, Nuernberg, Germany
Release : 45 Build Date: Tue Apr 6 19:25:27 2004
Install date: Wed Oct 01 21:19:22 2004 Build Host: e212.suse.de
Group : Productivity/Networking/Security Source RPM: freeswan-2.04_1.5.3-45.src.rpm
Size : 4917151 License: GPL

############
#MEU IPSEC.CONF
############# sample VPN connection
conn vpn
# Left security gateway, subnet behind it, next hop toward right.
left=200.xxx.xx.73
leftsubnet=172.16.0.0/24
leftnexthop=200.xxx.xxx.1
leftid=@gwcst.vpn.com
leftrsasigkey=(KEY LEFT)
# Right security gateway, subnet behind it, next hop toward left.
right=200.xxx.xxx.11
rightsubnet=192.168.0.0/24
rightnexthop=200.xxx.xxx.1
rightid=@gwcm.vpn.com
righthtrsasigkey=(KEY RIGHT)
auto=start


IPSEC'S IGUAIS NOS DOIS SERVIDORES, os dois ips reais servidores mesma classe, entao o nexthop e o mesmo tanto para o left quanto para o right, estao em bairros diferentes, com suas proprias saida de internet. navegam nomalmente e suas respectivas redes tambem.

consigo estabelecer conexao entre elas

server1#ipsec auto --up vpn
112 "vpn" #8: STATE_QUICK_I1: initiate
004 "vpn" #8: STATE_QUICK_I2: sent QI2, IPsec SA established {ESP=>0x45141a1d <0x44075c58}


server2#ipsec auto --up vpn
112 "vpn" #9: STATE_QUICK_I1: initiate
004 "vpn" #9: STATE_QUICK_I2: sent QI2, IPsec SA established {ESP=>0x44075c59 <0x45141a1e}


Desabilitei o antispoofing(ipsec e eth1(interna) e habilitei o forward nos 2 servidores mas eu não pingar as estacoes, nem de um lado nem do outro, nem traceroute, nada. usando o iptraf eu nao consigo ver nenhum trafego chegando, nem vejo mensagens de erro, nem os pacotes sendo dropados nos logs.

quando digito route ta lah as rotas nos dois servidores tudo ok, eu consigo pingar as interfaces externas , mas nada interno, do tipo estou na rede 172 e quero pingar uma maquina da rede 192, e nao consigo, alguem poderia me ajudar?


A. Carlos Sender