+ Responder ao Tópico



  1. #1
    RicardoVS
    Visitante

    Padrão Problemas com o Telnet

    Olá pessoa,

    Criei um usuário no meu servidor e quando tento acessar esse servidor de uma outra máquina via TELNET com o usuário que eu criei, não consigo executar operações tais, como ADDUSER, VI em ARQUIVO e por aí vai... Acho que é algo com as permissões.

    Então tentei pelo SSH e tudo funcionou, com o mesmo usuário que eu tinha usado no TELNET. O problema é que preciso utilizar o TELNET!

    Alguém pode me ajudar?

    Abraços

  2. #2
    gmlinux
    Visitante

    Padrão Re: Problemas com o Telnet

    Citação Postado originalmente por RicardoVS
    Olá pessoa,

    Criei um usuário no meu servidor e quando tento acessar esse servidor de uma outra máquina via TELNET com o usuário que eu criei, não consigo executar operações tais, como ADDUSER, VI em ARQUIVO e por aí vai... Acho que é algo com as permissões.

    Então tentei pelo SSH e tudo funcionou, com o mesmo usuário que eu tinha usado no TELNET. O problema é que preciso utilizar o TELNET!

    Alguém pode me ajudar?

    Abraços
    Depois que vc loga vc executa su e torna-se root ou su -c adduser??
    Qual a mensagem de erro específicamente?

    Vc esta tentando abrir arquivos que não pertencem ao seu user? vc virou root e tentou?

    Observe o prompt do usuário que vc loga no ssh e no telnet, se tiver um # no final, é root, se tiver um $ é usuário diferente de root



  3. #3
    RicardoVS
    Visitante

    Padrão Re: Problemas com o Telnet

    Depois que vc loga vc executa su e torna-se root ou su -c adduser??
    Qual a mensagem de erro específicamente?

    Vc esta tentando abrir arquivos que não pertencem ao seu user? vc virou root e tentou?

    Observe o prompt do usuário que vc loga no ssh e no telnet, se tiver um # no final, é root, se tiver um $ é usuário diferente de root
    Exatamente, eu conectei como usuário simples, depoisentrei como root (su) e executei o comando adduser nome -g 100 e me retornou:


    bash: adduser: command not found


    Mais se eu logar em SSH e fazer a mesma operação, funciona!

    Como já disse, eu preciso mesmo é o telnet.

    Valeu a atenção.

  4. #4
    Visitante

    Padrão Problemas com o Telnet

    Isso é sṕ questao de path, pois ao dar o comando su vc nao esta usando as variaveis do root e sim do usuario que esta logado.
    De o comando su -
    Ai ele busca as variaves do Root.
    Ou utilize o caminho completo dos comandos.
    Para descobrir os caminhos completos use o whereis nome_do_programa , ou ainda locate, ou ainda which.

    Att.,

    Rodrigo



  5. #5
    gmlinux
    Visitante

    Padrão Problemas com o Telnet

    Citação Postado originalmente por Anonymous
    Isso é sṕ questao de path, pois ao dar o comando su vc nao esta usando as variaveis do root e sim do usuario que esta logado.
    De o comando su -
    Ai ele busca as variaves do Root.
    Ou utilize o caminho completo dos comandos.
    Para descobrir os caminhos completos use o whereis nome_do_programa , ou ainda locate, ou ainda which.

    Att.,

    Rodrigo
    Por isto eu perguntei como ele executava o comando, mais vê se vc concorda, ele disse que loga por ssh e por telnet com o mesmo usuário comum, em seguida usa o comando su, se ele não estivesse executando su - nos dois casos o efeito deveria ser o mesmo, logo, ou ele não esta fazendo a mesma coisa nos dois casos, ou realmente o telnetd e o sshd evocam o shell de login de forma diferente e o usuário esta executando su e não su -.
    Espero que o nosso amigo me tire esta dúvida após ele conseguir fazer funcionar.
    A propósito, qual a plataforma do cliente de telnet?

  6. #6
    RicardoVS
    Visitante

    Padrão Problemas com o Telnet

    Pessoal,

    com o SU - deu certo!

    No ssh eu utilizo somente su e funciona normal. Estou efetuando um telnet de uma servidor Win2k para um Conectiva Linux 8.

    Pessoal valeu pela ajuda!


    Abraços



  7. #7
    gmlinux
    Visitante

    Padrão Problemas com o Telnet

    Citação Postado originalmente por RicardoVS
    Pessoal,

    com o SU - deu certo!

    No ssh eu utilizo somente su e funciona normal. Estou efetuando um telnet de uma servidor Win2k para um Conectiva Linux 8.

    Pessoal valeu pela ajuda!


    Abraços
    Descobri, o script que carrega o sshd configura o path e quando o sshd sobe ele esta erdando ele e repassando para o shel do user

  8. #8
    gmlinux
    Visitante

    Padrão Problemas com o Telnet

    Citação Postado originalmente por RicardoVS
    Pessoal,

    com o SU - deu certo!

    No ssh eu utilizo somente su e funciona normal. Estou efetuando um telnet de uma servidor Win2k para um Conectiva Linux 8.

    Pessoal valeu pela ajuda!


    Abraços
    Porque não usa um putty da vida?