+ Responder ao Tópico



  1. #1
    godelphi
    Oi
    Estou tentando compartilhar uma impressora HP LaserJet 1010 (USB) via samba, mas não estou conseguindo. Estou cups como servidor de impressão e a impressora localmente funciona OK, ou seja, no servidor está imprimindo.

    Fiz o compartilhamento pelo samba e a impressora é reconhecida nas estações Windows e Mac, consigo me conectar passando usuário e senha do samba, mas quando tento uma impressão, o trabalho é pocessado no driver das estações, não retornando erro, mas não é impresso pelo servidor. (a propósito, a impressora está ligada e conectada )

    Segue abaixo o smb.conf, talvez o problema seja este:
    [global]
    workgroup = VIADIGITAL-SMB
    server string = Servidor de Arquivos
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*al
    l*authentication*tokens*updated*successfully*
    username map = /etc/samba/smbusers
    log file = /var/log/samba/%m.log
    max log size = 0
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    printcap name = /etc/printcap
    logon script = logon.bat
    os level = 100
    dns proxy = No
    ldap ssl = No
    printing = bsd
    print command = lpr -r -h -P'%p' %s
    lpq command = lpq -P'%p'
    lprm command = lprm -P'%p' %j

    [Printers]
    comment = Impressora Linux
    path = /var/spool/lpd
    create mask = 0700
    guest ok = Yes
    printable = Yes
    browseable = No

    [hp1010]
    comment = HP LaserJet 1010
    path = /var/spool/lpd
    writeable = yes
    create mask = 0700
    guest ok = Yes
    printable = Yes
    print command = lpr -r -h -P %p %s
    printer name = HP LaserJet 1010

    Qualquer dica é bem vinda.

  2. Tive o mesmo problema aqui e perguntei... pesquisei... perambulei na net até que consegui em um email lá do fim do mundo... hehehehe

    O problema está com o Cups, e para resolvê-lo, segundo o tal e-mail, bastou descomentar as seguinte linhas no seguintes arquivos de configuração do Cups:

    Arquivo: /etc/cups/mime.convs
    Linha: #application/octet-stream application/vnd.cups-raw 0 -

    Arquivo: /etc/cups/mime.types
    Linha: #application/octet-stream

    Basta descomentá-las reiniciar o Cups que funciona, o mais estranho é que tenho uma HP LaserJet 1300, que não precisou que eu fizesse isso pra que as máquinas Ruindou$ imprimissem, não imagino porque, mas agora está resolvido.

    OBS: Utilizo Slackware 10 e Cups que é instalado por padrão e se alguém tiver algum outro modo de resolver eu também agradeço.

    Falow !!!



  3. #3
    godelphi
    Obrigado Márcio!

    Na verdade era burrada minha, tinha passado o nome da impressora errado:
    printer name = HP LaserJet 1010

    e o correto é
    printer name = hp1010

    Depois que verifiquei o log do smbd.log, aparecia o seguinte:
    lpq: Unknown destination "HP LaserJet 1010"!

    Obrigado






Tópicos Similares

  1. Compartilhar impressora Windows
    Por drspuc no fórum Servidores de Rede
    Respostas: 4
    Último Post: 31-03-2003, 13:39
  2. Instalar impressora - HP 930c
    Por dr4k no fórum Servidores de Rede
    Respostas: 4
    Último Post: 20-03-2003, 08:56
  3. compartilhar impressora
    Por Maiko no fórum Servidores de Rede
    Respostas: 3
    Último Post: 05-02-2003, 17:44
  4. compartilhar impressora
    Por Maiko no fórum Servidores de Rede
    Respostas: 7
    Último Post: 05-02-2003, 11:45
  5. Compartilhar Impressora
    Por PandaAzul no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-01-2003, 03:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L