Visite: BR-Linux ·  VivaOLinux ·  Dicas-L


+ Responder ao Tópico

  1. #1
    epf
    pessoal,
    eu instalei a placa rtl 8180l sem problemas, carrego o modulo belezinha..dai eu dou um wlanup infra, ele carrega a placa..eu nao estou sabendo como seto as configuracoes do cancal, essid, netmask, etc...se alguem tive algum exemplo de configuracao para infrastructure...

    quando eu dou um iwconfig, aparece o seguinte:

    wlan0 IEEE 802.11-DS ESSIDff/any Nickname:""
    NWIDff/any Frequency:infGHz Access Point: FF:BF:21:00:00:00
    Bit Rate=-1.07375e+06kb/s Tx-Power=-1073747900 dBm Sensitivity=1162167625/0
    Retryn RTS thr=-1073747900 B Fragment thr=-1073747900 B
    Encryption key:0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000
    Power Management0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000n

    preciso alterar essas configuracoes..
    agradeco


  2.    Publicidade


  3. #2
    dougfunny
    caro colega, qdo vc da "wlan infra" para configurar o essid vc edita o arquivo "wlan"pois eh nele que esta as conf de canal essid, outra coisa, vc tb pode configurar direto no iwpriv, obs: esta placa ainda nao funciona com o iwconfig ( infelizmente )

    qq duvida ou problema mande um email para dougfunny@clubinter.com.br

  4. Use:
    iwpriv wlan0 disable -> desliga antes
    iwpriv wlan0 wlan_para ssid="teste" ->SSID
    iwpriv wlan0 drv_para apclient_enable=1 -> modo cliente
    iwpriv wlan0 drv_para apclient_enable=0 -> modo AP
    iwpriv wlan0 wlan_para Diversity=0 --> antena seleção
    iwpriv wlan0 wlan_para channel=6 -> Canal
    iwpriv wlan0 enable -> liga

    Qualquer coisa:
    man iwpriv

    Falow

  5. #4
    Citação Postado originalmente por epf
    pessoal,
    eu instalei a placa rtl 8180l sem problemas, carrego o modulo belezinha..dai eu dou um wlanup infra, ele carrega a placa..eu nao estou sabendo como seto as configuracoes do cancal, essid, netmask, etc...se alguem tive algum exemplo de configuracao para infrastructure...

    quando eu dou um iwconfig, aparece o seguinte:

    wlan0 IEEE 802.11-DS ESSIDff/any Nickname:""
    NWIDff/any Frequency:infGHz Access Point: FF:BF:21:00:00:00
    Bit Rate=-1.07375e+06kb/s Tx-Power=-1073747900 dBm Sensitivity=1162167625/0
    Retryn RTS thr=-1073747900 B Fragment thr=-1073747900 B
    Encryption key:0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000
    Power Management0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000n

    preciso alterar essas configuracoes..
    agradeco

  6. /sbin/insmod -f rtl8180_24x.o


    case "$1" in
    ap)
    echo "ap"
    #------------------------------------------
    # Config AP mode
    # Assign SSID and operation channel.
    #------------------------------------------
    /sbin/iwpriv wlan0 wlan_para ssid=BIAS
    /sbin/iwpriv wlan0 wlan_para channel=2
    ;;
    infra)
    echo "infra"
    #------------------------------------------
    # Config infrastructure mode
    # Assign network type and desired SSID.
    #------------------------------------------
    #/sbin/iwpriv wlan0 wlan_para networktype=infra
    #/sbin/iwpriv wlan0 wlan_para ssid2scan=NAP_WPA
    iwpriv wlan0 wlan_para networktype=infra
    iwpriv wlan0 wlan_para ssid2scan=SuaSSID
    iwpriv wlan0 wlan_para networktype=infra,authtype=opensystem,channe=6,ssid=SuaSSID,basicrates=0xf
    ;;
    adhoc)
    echo "adhoc"
    #------------------------------------------
    # Config infrastructure mode
    # Assign network type and desired SSID.
    # 'ssid' and 'channel' are the default setting
    # and meaningful if this is the first station
    # in an IBSS.
    #------------------------------------------
    /sbin/iwpriv wlan0 wlan_para networktype=adhoc
    /sbin/iwpriv wlan0 wlan_para ssid2scan=aaaaa
    /sbin/iwpriv wlan0 wlan_para ssid=A_WPA
    /sbin/iwpriv wlan0 wlan_para channel=2
    ;;
    ;;
    *)
    /sbin/rmmod rtl8180_24x
    echo "Usage: $0 {ap | infra | adhoc}"
    exit 1
    esac

    #--------------------------
    # Config WEP mode
    #--------------------------
    iwpriv wlan0 wlan_para encmode=off
    iwpriv wlan0 wlan_para wepmode=off
    wepmode=wep40,wepdkeyid=0,wepkey40_1=1111111111
    iwpriv wlan0 msglevel 1
    iwpriv wlan0 enable
    /sbin/ifconfig wlan0 192.168.200.2 netmask 255.255.255.252 broadcast
    192.168.200.3
    echo "$(/sbin/ifconfig wlan0)"
    route add default gw 192.168.200.1

    Vc só precisa editar de acordo com as suas confg! essa configuração aponta para uma rede infra com SSID SuaSSID, Canal 6, sem criptografia
    só precisa isso pra funcionar!!!

    e de quebra quem souber isso
    http://www.underlinux.com.br/modules...wtopic&t=26041 ficarei muito grato!!!! :lol: :lol:


  7.    Publicidade




Usuários que leram este tópico: 0

Nenhum usuário nesta lista