+ Responder ao Tópico



  1. #1
    mmacoli
    Tenho uma rede com 10 computadores um server linux q estou instalando e 9 estações com Ruindows XP. Estou utilizando o iptables para compartilhar o velox q esta no server linux e ja esta funcionando todas estão navegando a configuração do iptables esta abaixo!

    #inicio iptables
    modprobe ip_tables
    modprobe iptable_nat
    #Inicio abertura das portas para server counter strike

    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

    iptables -A INPUT -s 192.168.0.2/0 -p tcp --dport 27015 -j ACCEPT
    #iptables -A FORWARD -p tcp --dport 27011 -j DROP
    #iptables -A FORWARD -p tcp --sport 27012 -j DROP
    #iptables -A FORWARD -p tcp --sport 27010 -j DROP
    #iptables -A FORWARD -p tcp --sport 27005 -j DROP
    #iptables -A FORWARD -p tcp --sport 7002 -j DROP
    #iptables -A FORWARD -p tcp --sport 5273 -j DROP
    #iptables -A FORWARD -p tcp --sport 27040 -j DROP
    iptables -A OUTPUT -s 0.0.0.0/0 -p udp --sport 27012 -j ACCEPT
    iptables -A OUTPUT -s 0.0.0.0/0 -p udp --sport 27010 -j ACCEPT
    iptables -A OUTPUT -s 0.0.0.0/0 -p udp --sport 27005 -j ACCEPT
    iptables -A OUTPUT -s 0.0.0.0/0 -p tcp --sport 7002 -j ACCEPT
    iptables -A OUTPUT -s 0.0.0.0/0 -p tcp --sport 5273 -j ACCEPT
    iptables -A OUTPUT -s 0.0.0.0/0 -p tcp --sport 27040 -j ACCEPT
    #fim
    iptables -A FORWARD -m unclean -j DROP
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward
    #fim iptables

    O squid esta instalado como default e não esta surtindo efeito nenhum me deem uma ajuda!!1

  2. #2
    gmlinux
    O que vc chama de não surtir efeito?
    Sua rede interna esta na eth1?



  3. #3
    mmacoli
    Sim minha rede interna é a eth1!!

    Coloquei varias acls no squid.conf para barrar palavras pornograficas e rodava o squid so que nao aconteceu nada as urls que eu digitava nas estações rodava tudo sem barrar nada!! o q pode ser??
    Como sei que esta fazendo cache??

  4. #4
    gmlinux
    O primeiro passo é colocar uma única regra de deny geral, só para ver se ele barra, se barrar, o uso de suas acl esta incorreto, se não barrar pode haver um erro externo.

    As acls que vc usa para barrar as palavras pornográficas são do tipo regexp? (expressão regular)

    Se for, o segundo passo é testar se ela esta funcionando, use uma expressão regular simples, que pegue qualquer url, assim, se barrar, o seu problema esta no uso das expressões regulares.



  5. #5
    muganga
    de o seguinte comando
    iptables -t nat -L
    ai vc ve se ta mascarando tudo na sua rede....se tiver tire a seguinte regra
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    depois da um
    /etc/rc.local (se o seu script estiver dentro do rc.local)

    repita o comando
    iptables -t nat -L
    se ainda estiver mascarando toda a rede
    reinicie o server

    Abraço

    Muganga
    MSN: mugangalinux@hotmail.com
    ICQ: 314528019






Tópicos Similares

  1. Meu Squid não funciona.
    Por flaviobatistela no fórum Servidores de Rede
    Respostas: 3
    Último Post: 06-07-2005, 09:16
  2. squid não funciona
    Por giggio no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-06-2003, 17:14
  3. Meu monitor não funciona... Uso o Conectiva 8
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 14-04-2003, 14:54
  4. meu roteamento não funciona
    Por wrochal no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-12-2002, 16:52
  5. Respostas: 3
    Último Post: 25-11-2002, 18:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L