+ Responder ao Tópico



  1. #1

    Padrão Problemas na configuracao do dominio

    Olá galera!
    Há dias venho apanhando de nosso amigo BIND, tenho um determinado dominio que está configurado em um determinado servidor mais gostaria de colocar o mesmo no meu proprio servidor mais infelismente não tive sucesso com a configuracao do DNS......Aparentemente esta levantando o servico mas quando eu pingo no enderereco do meu dominio ele retorna a seguinte mensagem. "ping: unknown host www.meudominio.com.br".
    Abaixo segue o retorno do camando: $tail -f /var/log/messages:
    Sep 28 17:38:50 ns1 named[1693]: listening on IPv4 interface eth0, 200.223.X.X#53
    Sep 28 17:38:50 ns1 named[1693]: listening on IPv4 interface eth1, 192.168.0.1#53
    Sep 28 17:38:50 ns1 named[1693]: command channel listening on 127.0.0.1#953
    Sep 28 17:38:50 ns1 named[1693]: zone 0.0.127.in-addr.arpa/IN: loaded serial 2003072801
    Sep 28 17:38:50 ns1 named[1693]: zone X.223.200.in-addr.arpa/IN: loaded serial 2003072801
    Sep 28 17:38:50 ns1 named[1693]: zone meudominio.com.br/IN: loaded serial 2003030701
    Sep 28 17:38:50 ns1 named[1693]: zone localhost/IN: loaded serial 42
    Sep 28 17:38:50 ns1 named[1693]: running
    Sep 28 17:38:50 ns1 named[1693]: zone 0.0.127.in-addr.arpa/IN: sending notifies (serial 2003072801)
    Sep 28 17:38:50 ns1 named[1693]: zone meudominio.com.br/IN: sending notifies (serial 2003030701)


    Agradeco a todos que lerem a este e muito mais os que tentarem me ajudar....

  2. #2
    gmlinux
    Visitante

    Padrão Re: Problemas na configuracao do dominio

    Citação Postado originalmente por standart
    Olá galera!
    Há dias venho apanhando de nosso amigo BIND, tenho um determinado dominio que está configurado em um determinado servidor mais gostaria de colocar o mesmo no meu proprio servidor mais infelismente não tive sucesso com a configuracao do DNS......Aparentemente esta levantando o servico mas quando eu pingo no enderereco do meu dominio ele retorna a seguinte mensagem. "ping: unknown host www.meudominio.com.br".
    Abaixo segue o retorno do camando: $tail -f /var/log/messages:
    Sep 28 17:38:50 ns1 named[1693]: listening on IPv4 interface eth0, 200.223.X.X#53
    Sep 28 17:38:50 ns1 named[1693]: listening on IPv4 interface eth1, 192.168.0.1#53
    Sep 28 17:38:50 ns1 named[1693]: command channel listening on 127.0.0.1#953
    Sep 28 17:38:50 ns1 named[1693]: zone 0.0.127.in-addr.arpa/IN: loaded serial 2003072801
    Sep 28 17:38:50 ns1 named[1693]: zone X.223.200.in-addr.arpa/IN: loaded serial 2003072801
    Sep 28 17:38:50 ns1 named[1693]: zone meudominio.com.br/IN: loaded serial 2003030701
    Sep 28 17:38:50 ns1 named[1693]: zone localhost/IN: loaded serial 42
    Sep 28 17:38:50 ns1 named[1693]: running
    Sep 28 17:38:50 ns1 named[1693]: zone 0.0.127.in-addr.arpa/IN: sending notifies (serial 2003072801)
    Sep 28 17:38:50 ns1 named[1693]: zone meudominio.com.br/IN: sending notifies (serial 2003030701)


    Agradeco a todos que lerem a este e muito mais os que tentarem me ajudar....
    Bom, primeiramente, verifique se o cliente de DNS (no caso o ping ) sabe quem resolve nomes para ele.

    O ideal para testar um DNS server é uma ferramenta no estilo dig, onde se pode informar o server, e passar diversas querys diferentes.



  3. #3

    Padrão Re: Problemas na configuracao do dominio

    Citação Postado originalmente por gmlinux
    Citação Postado originalmente por standart
    Olá galera!
    Há dias venho apanhando de nosso amigo BIND, tenho um determinado dominio que está configurado em um determinado servidor mais gostaria de colocar o mesmo no meu proprio servidor mais infelismente não tive sucesso com a configuracao do DNS......Aparentemente esta levantando o servico mas quando eu pingo no enderereco do meu dominio ele retorna a seguinte mensagem. "ping: unknown host www.meudominio.com.br".
    Abaixo segue o retorno do camando: $tail -f /var/log/messages:
    Sep 28 17:38:50 ns1 named[1693]: listening on IPv4 interface eth0, 200.223.X.X#53
    Sep 28 17:38:50 ns1 named[1693]: listening on IPv4 interface eth1, 192.168.0.1#53
    Sep 28 17:38:50 ns1 named[1693]: command channel listening on 127.0.0.1#953
    Sep 28 17:38:50 ns1 named[1693]: zone 0.0.127.in-addr.arpa/IN: loaded serial 2003072801
    Sep 28 17:38:50 ns1 named[1693]: zone X.223.200.in-addr.arpa/IN: loaded serial 2003072801
    Sep 28 17:38:50 ns1 named[1693]: zone meudominio.com.br/IN: loaded serial 2003030701
    Sep 28 17:38:50 ns1 named[1693]: zone localhost/IN: loaded serial 42
    Sep 28 17:38:50 ns1 named[1693]: running
    Sep 28 17:38:50 ns1 named[1693]: zone 0.0.127.in-addr.arpa/IN: sending notifies (serial 2003072801)
    Sep 28 17:38:50 ns1 named[1693]: zone meudominio.com.br/IN: sending notifies (serial 2003030701)


    Agradeco a todos que lerem a este e muito mais os que tentarem me ajudar....
    Bom, primeiramente, verifique se o cliente de DNS (no caso o ping ) sabe quem resolve nomes para ele.

    O ideal para testar um DNS server é uma ferramenta no estilo dig, onde se pode informar o server, e passar diversas querys diferentes.

    Caro colega!
    Quanto a sua sugestão de verificar se o DNS esta resolvendo, o resultado dos testes de pings com relacao a este dominio retorna....o seguinte:
    "ping: unknown host www.meudominio.com.br". Sinal que ele não sabe quem está resolvendo pra este dominio....E quanto a ferramenta sugerida...não pude testar porque não a que se refere.

    Fico agradecido pela otima intenção de ajuda..

  4. #4

    Padrão Problemas na configuracao do dominio

    Amigo... pode ser idiota mas... o primeiro item do seu /etc/resolv.conf tá apontando para o teu servidor DNS?


    Abraços!



  5. #5
    gmlinux
    Visitante

    Padrão Problemas na configuracao do dominio

    Você não entendeu o que eu disse..., eu pedi para verificar se o cliente sabe qual é o servidor de DNS, o xstefanox foi até mais direto que eu, ele esta considerando que você esta usando *nix na máquina do qual esta testando... e ele pediu que você verificasse a mesma coisa que eu... com outras palavras

    A mensagem:
    "ping: unknown host www.meudominio.com.br".
    não significa, necessariamente, que o servidor de DNS não resolveu, se seu cliente não sabe a quem perguntar, ou pergunta a máquina errada... sacou agora 8)

  6. #6
    Visitante
    Visitante

    Padrão Suse 9 alugem pode me ajudar

    bom galera to com um problema aqui, to usando o suse9, para configurar um servidor, mas infelizmente ele não ta instalando os pacotes rpm do cd cujo eu o tentei instalar um determinado pacote ele me retornou a seguinte msg package xxxxxxx.rpm is already installed, isto foi com varios pacotes, e tdetalhe não tem o comando o make para que pude-se instalar de outra forma. por favor algue me ajude.



  7. #7
    gmlinux
    Visitante

    Padrão Problemas na configuracao do dominio

    se ele esta falando que esta instalado... é porque talvez esteja

    Supondo que tenha tentado executar algo e não conseguiu, supondo que seu PATH esta ok, que o comando/arquivo pertence realmente ao pacote que você pensa que pertence, vou considerar a hipótese de arquivos deletados/perdidos acidentalmente.

    experimenta
    rpm -V pacote

    lembre-se, pacote é o nome, por exemplo, samba, não precisa colocar o resto do nome que você vê quando olha no cd.

    se o comando não retornar nada, blz, se retornar algo, olha no man do rpm, na opção verify (-V).

    Você ainda pode executar em seguida:
    rpm -ql pacote | grep file

    para ver se o arquivo que você pensa pertencer a este pacote, pertence a ele

  8. #8

    Padrão Problemas na configuracao do dominio

    Citação Postado originalmente por gmlinux
    Você não entendeu o que eu disse..., eu pedi para verificar se o cliente sabe qual é o servidor de DNS, o xstefanox foi até mais direto que eu, ele esta considerando que você esta usando *nix na máquina do qual esta testando... e ele pediu que você verificasse a mesma coisa que eu... com outras palavras

    A mensagem:
    "ping: unknown host www.meudominio.com.br".
    não significa, necessariamente, que o servidor de DNS não resolveu, se seu cliente não sabe a quem perguntar, ou pergunta a máquina errada... sacou agora 8)

    Caros colegas,
    Primeiramente respondendo a pergunta dos colegas...Meu resolv.conf está assim....
    search meudominio.com.be
    nameserver 200.223.x.x (meu ip válido)

    Os testes os que obtive a resposta mensionada no outro tópico foi feito da propria maquina a qual estou rodando o named que esta configurado este meu dominio.

    Obrigado mais uma vez pela boa vontade de ajudar neste meu problema.



  9. #9
    gmlinux
    Visitante

    Padrão Problemas na configuracao do dominio

    netstat -tuanp
    olha se seu named esta fazendo listen no ip indicado por você, acima
    pelo seu log, deveria....

    olha se existe alguma restrição a query

    iptables -L -n

    olha se ha alguma regra bloqueando o acesso a porta 53

    instala o pacote bind-utils para podermos usar as ferramentas de diagnóstico mais avançadas

  10. #10
    Visitante

    Padrão Problemas na configuracao do dominio

    caro Standart pelo que eu entendi voce deve mudar as seguintes entradas no RESOLV.CONF

    onde esta marcando nameserver 200.x.x.x

    troque pelo IP da Maquina que esta seu Servidor Named

    Ex: nameserver 192.168.0.1 que e o ip da maquina

    pois se voce deixar o ip Valido do seu LINK , o named vai perguntar ao 200.x.x.x quem é o (dominio.com.br).

    BELEZA, espero ter ajudado


    Sergio Borges
    Network Adminstrator






    Citação Postado originalmente por standart
    Citação Postado originalmente por gmlinux
    Você não entendeu o que eu disse..., eu pedi para verificar se o cliente sabe qual é o servidor de DNS, o xstefanox foi até mais direto que eu, ele esta considerando que você esta usando *nix na máquina do qual esta testando... e ele pediu que você verificasse a mesma coisa que eu... com outras palavras

    A mensagem:
    "ping: unknown host www.meudominio.com.br".
    não significa, necessariamente, que o servidor de DNS não resolveu, se seu cliente não sabe a quem perguntar, ou pergunta a máquina errada... sacou agora 8)

    Caros colegas,
    Primeiramente respondendo a pergunta dos colegas...Meu resolv.conf está assim....
    search meudominio.com.be
    nameserver 200.223.x.x (meu ip válido)

    Os testes os que obtive a resposta mensionada no outro tópico foi feito da propria maquina a qual estou rodando o named que esta configurado este meu dominio.

    Obrigado mais uma vez pela boa vontade de ajudar neste meu problema.



  11. #11
    gmlinux
    Visitante

    Padrão Problemas na configuracao do dominio

    Citação Postado originalmente por Anonymous
    caro Standart pelo que eu entendi voce deve mudar as seguintes entradas no RESOLV.CONF

    onde esta marcando nameserver 200.x.x.x

    troque pelo IP da Maquina que esta seu Servidor Named

    Ex: nameserver 192.168.0.1 que e o ip da maquina

    pois se voce deixar o ip Valido do seu LINK , o named vai perguntar ao 200.x.x.x quem é o (dominio.com.br).

    BELEZA, espero ter ajudado


    Sergio Borges
    Network Adminstrator






    Citação Postado originalmente por standart
    Citação Postado originalmente por gmlinux
    Você não entendeu o que eu disse..., eu pedi para verificar se o cliente sabe qual é o servidor de DNS, o xstefanox foi até mais direto que eu, ele esta considerando que você esta usando *nix na máquina do qual esta testando... e ele pediu que você verificasse a mesma coisa que eu... com outras palavras

    A mensagem:
    "ping: unknown host www.meudominio.com.br".
    não significa, necessariamente, que o servidor de DNS não resolveu, se seu cliente não sabe a quem perguntar, ou pergunta a máquina errada... sacou agora 8)

    Caros colegas,
    Primeiramente respondendo a pergunta dos colegas...Meu resolv.conf está assim....
    search meudominio.com.be
    nameserver 200.223.x.x (meu ip válido)

    Os testes os que obtive a resposta mensionada no outro tópico foi feito da propria maquina a qual estou rodando o named que esta configurado este meu dominio.

    Obrigado mais uma vez pela boa vontade de ajudar neste meu problema.
    Caro visitante
    O standart fez o teste da própria máquina, se for para mudar o nameserver, então coloca logo o 127.0.0.1 ....

  12. #12

    Padrão Problemas na configuracao do dominio

    Caros Colegas.!
    Gostaria de agradecer a todos os que leram este topico de de certa forma gostaria de ajudar mas não o fez por falta de conhecimento, por motivo de falta de tempo e outros.........E principalmente aos que dispuseram de seu tempo na tentativa de me mostrar o caminho das pedras.
    O problema ja consegui resolver, me problema foi o seguinte:
    No instalação do Bind ele cria o diretorio "caching-example" e no named.conf ele fazia referencia a /var/named e não encontrava os arquivos de zonas porque o mesmos estavam dentro do caching-example.

    hehehehehe!!!!

    Um Abaço a todos!

    Valeu.



  13. #13
    gmlinux
    Visitante

    Padrão Problemas na configuracao do dominio

    Vamos fazer uma análise do problema...

    Na primeira mensagem do standart, os logs não apresentam nenhum problema, o que leva a uma primeira suspeita de que o cliente não esteja configurado para resolver neste server.

    Quando perguntamos ao usuário sobre a configuração do cliente de DNS, ele não soube responder e demonstrou não conhecer ferramentas de diagnósticos de DNS. Assim, isto nos leva a uma abordagem diferente, mais receita de bolo, o xstefanox até colocou o nome do arquivo que deveria ser verificado.

    Finalmente, no post do dia 29, das 4:26 pm, temos a informação que o cliente esta configurado corretamente. Agora sim, vamos partir para outras possibilidades: Será que o server esta abortando (netstat -tuan) ou existe alguma regra de iptables (iptables -L -n) bloquendo o acesso, sera que os arquivos de zona estão corretos (ver os arquivos de configuração ou usar o dig)?

    No meu post do dia 29, 6:30 pm tento cercar isto, a instalação do bind-utils visava poder executar o comando
    dig @127.0.0.1 dominio axfr
    e ver a listagem do domínio dele, ver se não faltava a entrada necessária a resolução do nome em questão.

    E eis que nosso colega chega a resposta, antecipando-se as nossas conclusões... será?

    Observem que o arquivo de zona que deveria resolver o tal nome esta carregando sem erros, então eles estavam referenciados no /etc/named.conf e estavam presentes no /var/named, assim, provavelmente a entrada que provocou o erro:
    "ping: unknown host www.meudominio.com.br"
    não estava presente dentro do arquivo de zona.

    isto que o standart falou:
    "O problema ja consegui resolver, me problema foi o seguinte:
    No instalação do Bind ele cria o diretorio "caching-example" e no named.conf ele fazia referencia a /var/named e não encontrava os arquivos de zonas porque o mesmos estavam dentro do caching-example."
    na parte que diz "...não encontrava os arquivos de zonas..." esta incorreto, ele encontrava sim, se não daria erro nos logs que ele próprio postou.

    a conclusão fica por conta de quem conseguir ler além do texto...

  14. #14

    Padrão Problemas na configuracao do dominio

    Caro colega gmlinux!
    Visto que demostrou ter um imenso conhecimento sobre problemas e soluções relativas a este serviço. Para que eu possa entender melhor o porque que o que foi dito por mim não faz o menor sentido, com relaçao a localizacao dos arquivos, listo abaixo o unico comando usado pra resolver meu problema, espero que possa nos mostrar porque este unico comando resolveu meu problema.
    #cd /var/named/caching-example
    #cp * /var/named

    Valeu.....




    Citação Postado originalmente por gmlinux
    Vamos fazer uma análise do problema...

    Na primeira mensagem do standart, os logs não apresentam nenhum problema, o que leva a uma primeira suspeita de que o cliente não esteja configurado para resolver neste server.

    Quando perguntamos ao usuário sobre a configuração do cliente de DNS, ele não soube responder e demonstrou não conhecer ferramentas de diagnósticos de DNS. Assim, isto nos leva a uma abordagem diferente, mais receita de bolo, o xstefanox até colocou o nome do arquivo que deveria ser verificado.

    Finalmente, no post do dia 29, das 4:26 pm, temos a informação que o cliente esta configurado corretamente. Agora sim, vamos partir para outras possibilidades: Será que o server esta abortando (netstat -tuan) ou existe alguma regra de iptables (iptables -L -n) bloquendo o acesso, sera que os arquivos de zona estão corretos (ver os arquivos de configuração ou usar o dig)?

    No meu post do dia 29, 6:30 pm tento cercar isto, a instalação do bind-utils visava poder executar o comando
    dig @127.0.0.1 dominio axfr
    e ver a listagem do domínio dele, ver se não faltava a entrada necessária a resolução do nome em questão.

    E eis que nosso colega chega a resposta, antecipando-se as nossas conclusões... será?

    Observem que o arquivo de zona que deveria resolver o tal nome esta carregando sem erros, então eles estavam referenciados no /etc/named.conf e estavam presentes no /var/named, assim, provavelmente a entrada que provocou o erro:
    "ping: unknown host www.meudominio.com.br"
    não estava presente dentro do arquivo de zona.

    isto que o standart falou:
    "O problema ja consegui resolver, me problema foi o seguinte:
    No instalação do Bind ele cria o diretorio "caching-example" e no named.conf ele fazia referencia a /var/named e não encontrava os arquivos de zonas porque o mesmos estavam dentro do caching-example."
    na parte que diz "...não encontrava os arquivos de zonas..." esta incorreto, ele encontrava sim, se não daria erro nos logs que ele próprio postou.

    a conclusão fica por conta de quem conseguir ler além do texto...



  15. #15
    gmlinux
    Visitante

    Padrão Problemas na configuracao do dominio

    Sem polimizar, so questionei a frase:
    "...não encontrava os arquivos de zonas..."
    e quando eu disse que a conclusão fica por conta de quem conseguir ler além do texto...

    foi porque quem conseguisse ler alem do texto, poderia perceber que o problema talvez não tenha sido resolvido.

    Veja, o erro estava não na ausência dos arquivos, que foi o que você afirmou, seu logs foram claros quanto a isto, mais no conteúdo dos seus arquivos de zona, explicando melhor:

    No caching-examples não existe um arquivo do seu dominio, quando você copiou para o /etc/named.conf, você provavelmente só capacitou seu server a resolver o www.meudominio.com.br na internet (você ensinou ao seu server onde estão os servidores do domínio raiz da internet), se o dig estiver instalado, vc pode fazer uma query e ver seu server esta ou não respondeu autoritativamente, se ele responder autoritativamente a query, então ele esta configurado corretamente para seu dominio (meudominio.com.br), se não, esta resolvendo no server que você já teria na internet. (acho que você tem um por esta frase: "...tenho um determinado dominio que está configurado em um determinado servidor mais gostaria de colocar o mesmo no meu proprio servidor...").

    :?: