+ Responder ao Tópico



  1. #1
    The Hawk
    Pessoal é o seguinte, estou tentando fazer com que o apache peça usuario e senha ao entrar em uma determinada pasta, www.blabla.com.br/secreto, mas quando eu coloco o arquivo .htaccess na pasta que eu quero proteger e tento acessar pelo navegador aparece a mensagem "server error" dizendo que existe algum erro, criei o arquivo .htaccess com o seguinte conteudo:

    AuthType Basic
    AuthName Minha area secreta.
    AuthUserFile /bla/bla/bla/bla/.htpasswd
    require user secreto

    e criei o arquivo .htpasswd com o comando htpasswd -c .htpasswd secreto, dai eu coloquei minha senha, bem teoricamente está tudo certo, só que fica dando essa mensagem de erro, alguem tem alguma ideia do que possa ser, tenho que mudar alguma coisa no httpd.conf? em qual ponto eu tenho que fazer essa mudança, aguardo respostas, flw.

  2. https://under-linux.org/modules.php?...=19782&forum=2

    Faça uma busca antes de perguntar....

    t+



  3. #3
    The Hawk
    bauer eu já havia visto esse topico que você citou, mas mesmo assim não havia dado certo continuava dando server error, mas consegui achar o defeito no meu httpd.conf e já concertei, agora tá redodinha a autenticação, flw.

  4. o bitio vc criou assim mesmo
    AuthType Basic
    AuthName Minha area secreta.
    AuthUserFile /bla/bla/bla/bla/.htpasswd
    require user secreto

    tente assim
    AuthName "Minha area secreta"
    AuthType Basic
    AuthUserFile /bla/bla/bla/bla/.htpasswd
    require valid-user
    Satisfy Any

    o jeito de criar o arquivo password é estre mesmo

    no http.conf

    no direcorio da sua pagina
    coloque o
    AllowOverride Authconfig
    order Deny,Allow
    Deny from all






Tópicos Similares

  1. Erro em modulo ao compilar kernel
    Por dr4k no fórum Servidores de Rede
    Respostas: 3
    Último Post: 11-03-2003, 22:50
  2. Erro em user
    Por wrochal no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-02-2003, 13:08
  3. Ajuda em Autenticação
    Por PandaAzul no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-01-2003, 17:02
  4. Instalação SQUID - Erro em Filedescriptors
    Por NoiseMaster no fórum Servidores de Rede
    Respostas: 3
    Último Post: 13-11-2002, 10:15
  5. Respostas: 1
    Último Post: 05-09-2002, 14:54

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L