Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Ai galera estou com problema com o squid, como é a 1ª vez que o configuro estou sofrendo um pouco! :cry: :cry:
    aki está o conteudo do squid.cof

    ############################
    http_port 3128
    hierarchy_stoplist cgi-bin ?
    cache_mem 16 MB
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 4096 KB
    cache_dir ufs /var/cache/squid 1000 16 256
    cache_access_log /var/log/squid/access.log
    # ACLS
    acl minha_rede 192.168.5.0/24
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews #portas criptografadas usadas em bancos. n eh aconselhavel passar pelo proxy
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access allow minha_rede
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow all
    icp_access allow all
    visible_hostname on
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    ############################
    peguei este exemplo no Viva o Linux, mas não está dando certo, o que está errado???
    Já configurei o firewall para trabalhar com o squid como proxy transparente mas não estou conseguindo fazer o squid funcionar!!!

    Agradeço desde já a colaboração de todos!

  2. #2
    vechiato
    qual erro no /var/log/messages ?

    sempre que tiver algum problema olhe primeiro o messages



  3. #3
    silmar
    Afinal quem então não está funcionando ?
    Eu tambem precisei fazer essa configuração, porem o squid funcionava quando eu ia no browser e marcava para ele funcionar com o proxy
    no entando quando eu tirava não funcionava o proxy transparente.
    falatava uma regra no meu firewall

    /sbin/iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 8080

    onde eth1 é a placa da rede interna, agora você tem que ver se realmente e o squid.

  4. #4
    O squid não está funcionando aliás ele nem inicia!!!
    ????????



  5. #5
    silmar
    olha faz o seguinte aplica essas configurações no seu squid.conf original.

    As vezes eu pego algo pronto nas aginas e não funciona. e quando aplica essas configurações no original eles funcionam.

    agora caso vc não tem mais ele .. me passa seu e-mail que passo um squid meu que está funcionando .. com essas configurações






Tópicos Similares

  1. Squid não funciona com Firewall
    Por doliveira no fórum Servidores de Rede
    Respostas: 5
    Último Post: 01-03-2004, 17:39
  2. squid nao funciona
    Por pensador-ce no fórum Servidores de Rede
    Respostas: 3
    Último Post: 19-10-2003, 18:48
  3. Squid não funciona
    Por APS no fórum Servidores de Rede
    Respostas: 3
    Último Post: 10-10-2003, 10:32
  4. squid não funciona
    Por giggio no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-06-2003, 17:14
  5. Respostas: 3
    Último Post: 25-11-2002, 18:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L