+ Responder ao Tópico



  1. #1
    Visitante

    Padrão squid não funciona!o q ta errado?

    Ai galera estou com problema com o squid, como é a 1ª vez que o configuro estou sofrendo um pouco! :cry: :cry:
    aki está o conteudo do squid.cof

    ############################
    http_port 3128
    hierarchy_stoplist cgi-bin ?
    cache_mem 16 MB
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 4096 KB
    cache_dir ufs /var/cache/squid 1000 16 256
    cache_access_log /var/log/squid/access.log
    # ACLS
    acl minha_rede 192.168.5.0/24
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews #portas criptografadas usadas em bancos. n eh aconselhavel passar pelo proxy
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access allow minha_rede
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow all
    icp_access allow all
    visible_hostname on
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    ############################
    peguei este exemplo no Viva o Linux, mas não está dando certo, o que está errado???
    Já configurei o firewall para trabalhar com o squid como proxy transparente mas não estou conseguindo fazer o squid funcionar!!!

    Agradeço desde já a colaboração de todos!

  2. #2
    vechiato
    Visitante

    Padrão squid não funciona!o q ta errado?

    qual erro no /var/log/messages ?

    sempre que tiver algum problema olhe primeiro o messages



  3. #3
    silmar
    Visitante

    Padrão squid não funciona!o q ta errado?

    Afinal quem então não está funcionando ?
    Eu tambem precisei fazer essa configuração, porem o squid funcionava quando eu ia no browser e marcava para ele funcionar com o proxy
    no entando quando eu tirava não funcionava o proxy transparente.
    falatava uma regra no meu firewall

    /sbin/iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 8080

    onde eth1 é a placa da rede interna, agora você tem que ver se realmente e o squid.

  4. #4
    Visitante

    Padrão squid não funciona!o q ta errado?

    O squid não está funcionando aliás ele nem inicia!!!
    ????????



  5. #5
    silmar
    Visitante

    Padrão squid não funciona!o q ta errado?

    olha faz o seguinte aplica essas configurações no seu squid.conf original.

    As vezes eu pego algo pronto nas aginas e não funciona. e quando aplica essas configurações no original eles funcionam.

    agora caso vc não tem mais ele .. me passa seu e-mail que passo um squid meu que está funcionando .. com essas configurações

  6. #6

    Padrão squid não funciona!o q ta errado?

    Citação Postado originalmente por vechiato
    qual erro no /var/log/messages ?

    sempre que tiver algum problema olhe primeiro o messages
    O log do Squid fica em /var/log/squid/access.log

    Manda pra gente o que tá dando de erro que fica bem mais simples.

    Monta o seu squid.conf a partir do original, não zera ele não. Fica mais fácil para você estar entendendo ele mais para frente.

    Leia o meu guia: http://squid.linuxit.com.br


    Um abraço!



  7. #7

    Padrão ow

    Eai... qual é sua distro?????
    posta ai e posta tambem o erro que dá!!!!!


    Citação Postado originalmente por Anonymous
    O squid não está funcionando aliás ele nem inicia!!!
    ????????

  8. #8
    Visitante

    Padrão squid não funciona!o q ta errado?

    Já resolvi o problema!
    Estava pegando um arquivo da Net, agora peguei o arq original do squid, reconfigurei tudo!!! mesmo assim dava um erro sobre visible_hostname ai coloquei a seguinte linha e deu certo!!!

    visible_hostname server

    Valeu pela atenção



  9. #9
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.928
    Posts de Blog
    1

    Padrão Re: squid não funciona!o q ta errado?

    Citação Postado originalmente por Anonymous
    Ai galera estou com problema com o squid, como é a 1ª vez que o configuro estou sofrendo um pouco! :cry: :cry:
    aki está o conteudo do squid.cof

    ############################
    http_port 3128
    hierarchy_stoplist cgi-bin ?
    cache_mem 16 MB
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 4096 KB
    cache_dir ufs /var/cache/squid 1000 16 256
    cache_access_log /var/log/squid/access.log
    # ACLS
    acl minha_rede 192.168.5.0/24
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews #portas criptografadas usadas em bancos. n eh aconselhavel passar pelo proxy
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access allow minha_rede
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow all
    icp_access allow all
    visible_hostname on
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    ############################
    peguei este exemplo no Viva o Linux, mas não está dando certo, o que está errado???
    Já configurei o firewall para trabalhar com o squid como proxy transparente mas não estou conseguindo fazer o squid funcionar!!!

    Agradeço desde já a colaboração de todos!

    o bitio olha no inicio da sua acl
    acl minha_rede 192.168.5.0/24
    ta faltando o src
    ficaria assim
    acl minha_rede src 192.168.5.0/24

  10. #10
    Visitante

    Padrão squid não funciona!o q ta errado?

    Obrigado

    mas como disse antes já resolvi os problemas, e o squid tá funcionando blz!!!
    Logo vou começar a altenticaçao por usuario, e vou precisar da ajuda de vc`s