+ Responder ao Tópico



  1. #1
    vandemberg
    Colegas,
    Atualmente tenho o mysql-server-3.23.52-3 e to precisando atualizar para a versão 4.1. Uso o redhat 8.0. Baixei o pacote no mysql.com e tentei atualizar, abaixo vai o erro que apresentou.
    O que eu tenho que fazer pra instalar o MySQL-server-4.1?

    #rpm -Uvh MySQL-server-4.1.7-0.i386.rpm
    aviso: MySQL-server-4.1.7-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
    erro: Failed dependencies:
    libmysqlclient.so.10 is needed by (installed) mod_auth_mysql-1.11-10
    libmysqlclient.so.10 is needed by (installed) perl-DBD-MySQL-2.1017-3
    libmysqlclient.so.10 is needed by (installed) php-mysql-4.2.2-8.0.5

    t+

  2. #2
    Oi,

    Voce não disse qual a distro, pode ser Mandrake, Fedora, RedRat, etc.

    Mas:
    Des-instale:

    mysql
    mysql-client
    mod_auth_mysql
    perl-DBD-MySQL
    php-mysql

    Instale a nova versão do MySQL, e os outros pacotes acima. É importante que o primeiro pacote re-instalado seja o mysql (ou mysql-server, em algumas distros). Caso contrário, vc vai ter falha de dependências como a mostrada pelo log do rpm.
    No futuro, use apt ou yum. É muito mais prático.


    Sds,



  3. #3
    vandemberg
    Nesse caso, eu instalaria os mesmos pacotes mod_auth_mysql, perl-DBD-MySQL e php-mysql, mesma versão que tá hoje, atualizando so o mysql ou tenho que colocar versões mais atualizadas desses 3 pacotes?

  4. #4
    utilize o apt-get , para instalacao dos pacotes corretos

    Citação Postado originalmente por vandemberg
    Colegas,
    Atualmente tenho o mysql-server-3.23.52-3 e to precisando atualizar para a versão 4.1. Uso o redhat 8.0. Baixei o pacote no mysql.com e tentei atualizar, abaixo vai o erro que apresentou.
    O que eu tenho que fazer pra instalar o MySQL-server-4.1?

    #rpm -Uvh MySQL-server-4.1.7-0.i386.rpm
    aviso: MySQL-server-4.1.7-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
    erro: Failed dependencies:
    libmysqlclient.so.10 is needed by (installed) mod_auth_mysql-1.11-10
    libmysqlclient.so.10 is needed by (installed) perl-DBD-MySQL-2.1017-3
    libmysqlclient.so.10 is needed by (installed) php-mysql-4.2.2-8.0.5

    t+



  5. #5
    gmlinux
    Amigo visitante, o apt até pode ser instalado no redhat, mais não é padrão desta distro.
    Esta aplicação é original do Depian e foi portado pela Conectiva para uso com pacotes RPM (originalmente .deb do Debian, ,claro!).
    Nosso amigo acima usa RH8 mais se tiver interessado em usar o apt:
    http://www.fedora.us/wiki/FedoraHOWTO






Tópicos Similares

  1. Postfix X Mysql !!! Help !
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 30-12-2005, 08:55
  2. erro de permissao do mysql =[ help plz
    Por 13urton no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-08-2004, 15:50
  3. não consigo entrar no MYSQL !!! Help Me !!!!
    Por raphaelcm no fórum Servidores de Rede
    Respostas: 13
    Último Post: 16-03-2004, 17:48
  4. atualização de versão do banco mysql -> Slackware
    Por Wal no fórum Servidores de Rede
    Respostas: 13
    Último Post: 26-11-2003, 17:07
  5. Atualização do mysql
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 17-11-2003, 21:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L