+ Responder ao Tópico



  1. #1
    WC
    Visitante

    Padrão OpenVPN + Rota

    Instalei o OpenVPN, liberei a porta 5000 UDP

    Consigo pingar do servidor (tun 10.0.0.198) para o computador cliente (tun 10.0.0.197) e do computador cliente para o servidor.

    Mas não consigo pingar do computador cliente para LAN do servidor. Testei mudando todas as politicas do firewall para ACCEPT tanto no servidor quanto no computador cliente, mesmo assim não consigo pingar a LAN do lado do servidor

    No servidor eu adicionei a seguinte rota:
    route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.0.0.197

    No computador cliente:
    route add -net 10.0.0.0 netmaske 255.0.0.0 gw 10.0.0.198

    Alguém sabe que rota que esta faltando ou alguma regra no iptables?

  2. #2
    karfax
    Visitante

    Padrão OpenVPN + Rota

    Olá,

    1: Sua netmask está errada. Seria 255.255.255.0
    2: Voce não pode colocar as intarfaces tun (servidor e cliente) na mesma range de ip's da rede interna de cá e de lá - caso contrário não será possivel roteamento (estou levando em conta uma netmask /24 existenmte em ambas as redes remotas.

    Tente novamente e dê um feedback.

    PS: Tenho +- 20 instalações OpenVPN em produção agora. (devo saber do que estou falando... :wink:

    Sds,



  3. #3
    loserdracull
    Visitante

    Padrão OpenVPN + Rota

    Ou 255.255.0.0 Tambem da !!

  4. #4
    WC
    Visitante

    Padrão OpenVPN + Rota

    Mas quando eu coloco a mascara 255.255.255.0 ou 255.255.0.0 a internet da rede interna para



  5. #5
    karfax
    Visitante

    Padrão OpenVPN + Rota

    De novo:
    2: Voce não pode colocar as intarfaces tun (servidor e cliente) na mesma range de ip's da rede interna de cá e de lá - caso contrário não será possivel roteamento (estou levando em conta uma netmask /24 existente em ambas as redes remotas.

    Tente novamente e dê um feedback.

    ps: Voce não leu a documentação do OpenVPN? O James Yonan coloca 3 ou 4 exemplos de links diferentes em produção totalmente mastigados.
    Vou dar um exemplo:

    Minha LAN: 192.168.2.0
    Lan Remota: 192.168.0.0
    Meu tun: 192.168.3.1
    tun remoto: 192.168.3.2

    Aqui:
    route add -net 192.168.0.0 netmask 255.255.255.0 gw 192.168.3.2

    Lá:
    route add -net 192.168.2.0 netmask 255.255.255.0 gw 192.168.3.1

    Formula:

    route add -net $lanremota netmask 255.255.255.0 gw $tunremoto


    Sds,

    :wink:

  6. #6
    leolnd
    Visitante

    Padrão Re: OpenVPN + Rota

    Eu também estou com o mesmo problema, sendo as minhas rotas:

    ROTAS DA MATRIZ:

    Tabela de Roteamento IP do Kernel
    Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
    192.168.100.2 * 255.255.255.255 UH 0 0 0 tun0
    cl-smar-stz.ctb * 255.255.255.255 UH 0 0 0 ppp0
    192.168.2.0 192.168.100.2 255.255.255.0 UG 0 0 0 tun0
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
    10.1.1.0 * 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default cl-smar-stz.ctb 0.0.0.0 UG 0 0 0 ppp0

    INTERFACES DA MATRIZ:

    eth0 Encapsulamento do Link: Ethernet Endereço de HW 00:14:2A:13:96:C6
    inet end.: 10.1.1.250 Bcast:10.255.255.255 Masc:255.255.255.0
    endereço inet6: fe80::214:2aff:fe13:96c6/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:22466 errors:0 dropped:0 overruns:0 frame:0
    TX packets:22087 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:11328386 (10.8 MiB) TX bytes:3260794 (3.1 MiB)
    IRQ:10 Endereço de E/S:0xe800

    eth1 Encapsulamento do Link: Ethernet Endereço de HW 00:08:54:2D:08:16
    inet end.: 192.168.1.1 Bcast:192.168.1.255 Masc:255.255.255.0
    endereço inet6: fe80::208:54ff:fe2d:816/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:58343 errors:0 dropped:0 overruns:0 frame:0
    TX packets:65473 errors:0 dropped:0 overruns:0 carrier:0
    colisões:5027 txqueuelen:1000
    RX bytes:12729917 (12.1 MiB) TX bytes:52994530 (50.5 MiB)
    IRQ:11 Endereço de E/S:0xec00

    lo Encapsulamento do Link: Loopback Local
    inet end.: 127.0.0.1 Masc:255.0.0.0
    endereço inet6: ::1/128 Escopo:Máquina
    UP LOOPBACKRUNNING MTU:16436 Métrica:1
    RX packets:1592 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1592 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:0
    RX bytes:2708740 (2.5 MiB) TX bytes:2708740 (2.5 MiB)

    ppp0 Encapsulamento do Link: Protocolo Ponto-a-Ponto
    inet end.: 200.233.186.248 P-a-P:200.225.196.100 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Métrica:1
    RX packets:8647 errors:0 dropped:0 overruns:0 frame:0
    TX packets:9033 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:3
    RX bytes:2977243 (2.8 MiB) TX bytes:1269704 (1.2 MiB)

    tun0 Encapsulamento do Link: Não Especificado Endereço de HW F1-FE-3B-03-62-00-F4-2F-00-00-00-00-00-00-00-00
    inet end.: 192.168.100.1 P-a-P:192.168.100.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1256 Métrica:1
    RX packets:58 errors:0 dropped:0 overruns:0 frame:0
    TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:10
    RX bytes:4772 (4.6 KiB) TX bytes:924 (924.0 b)

    =======================================================

    ROTAS DA FILIAL:

    192.168.100.1 * 255.255.255.255 UH 0 0 0 tun0
    cl-smar-stz.ctb * 255.255.255.255 UH 0 0 0 ppp0
    10.2.1.0 * 255.255.255.0 U 0 0 0 eth0
    192.168.2.0 * 255.255.255.0 U 0 0 0 eth1
    192.168.1.0 192.168.100.1 255.255.255.0 UG 0 0 0 tun0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default cl-smar-stz.ctb 0.0.0.0 UG 0 0 0 ppp0

    INTERFACES DA FILIAL:

    eth0 Link encap:Ethernet Endereço de HW 00:08:54:2C:33:30
    inet end.: 10.2.1.2 Bcast:10.2.1.255 Masc:255.255.255.0
    endereço inet6: fe80::208:54ff:fe2c:3330/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:158533 errors:0 dropped:0 overruns:0 frame:0
    TX packets:152144 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:102397492 (97.6 MiB) TX bytes:23527327 (22.4 MiB)
    IRQ:12 Endereço de E/S:0xd000

    eth1 Link encap:Ethernet Endereço de HW 000:09:F9:4D:72
    inet end.: 192.168.2.1 Bcast:192.168.2.255 Masc:255.255.255.0
    endereço inet6: fe80::2d0:9ff:fef9:4d72/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:143919 errors:0 dropped:0 overruns:0 frame:0
    TX packets:146532 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:21913340 (20.8 MiB) TX bytes:100218366 (95.5 MiB)
    IRQ:12 Endereço de E/S:0xd400

    lo Link encap:Loopback Local
    inet end.: 127.0.0.1 Masc:255.0.0.0
    endereço inet6: ::1/128 Escopo:Máquina
    UP LOOPBACKRUNNING MTU:16436 Métrica:1
    RX packets:2074 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2074 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:0
    RX bytes:3372672 (3.2 MiB) TX bytes:3372672 (3.2 MiB)

    ppp0 Link encap:Protocolo Ponto-a-Ponto
    inet end.: 200.233.153.33 P-a-P:200.225.196.100 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Métrica:1
    RX packets:156636 errors:0 dropped:0 overruns:0 frame:0
    TX packets:150219 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:3
    RX bytes:98835667 (94.2 MiB) TX bytes:20103969 (19.1 MiB)

    tun0 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 192.168.100.2 P-a-P:192.168.100.1 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1256 Métrica:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:500
    RX bytes:672 (672.0 b) TX bytes:3540 (3.4 KiB)




    Detalhe, consigo pingar qualquer IP configurado no servidor da matriz à partir do servidor da filial e vice-versa... só não consigo da filial pingar máquinas da rede da matriz e vice-versa.

    Estou há vários dias tentando solucionar esta questão, se algum souber me ajudar serei eternamente grato !

    Atenciosamente,

    Leonardo Nogueira
    [email protected]



  7. #7
    slackrio
    Visitante

    Padrão Re: OpenVPN + Rota

    Interessante este forum . .estarei acompanhando ate mesmo estou com este problema de rota cliente precisam imprimir nas impressoras que esta atraz da matriz ...

    legal to ligado aqui ...

    valew

  8. #8
    leolnd
    Visitante

    Padrão Re: OpenVPN + Rota

    Olá, eu FELIZMENTE descobri o meu problema... faltava ativar "FORWARD ACCEPT" no firewall...

    E conforme a pessoa que me ajudou (Karfax):
    "Fique atento pra permitir FORWARD apenas pra interface tun e para o
    intervalo de rede da VPN, não para qualquer interface nem 0.0.0.0 , ok?"