+ Responder ao Tópico



  1. #1
    Arocha
    Já configurei o Bind no CL8 e no CL9 com sucesso, no entanto no CL10 estou tendo alguns problemas. Irei descrever tudo passo a passo até chegar no problema, podendo inclusive servir como um bom tutorial a quem desejar configurar o Bind 9.2 no CL10, claro, depois de resolvido o problema.

    Antes de tudo foi configurada a rede. O IP do servidor é 192.168.0.1 e o nome é server01. O domínio é ciatecnica.com.br. Desejo configurar este servidor para resolver nomes internos em minha rede. O /etc/hosts.conf está configurado para dar preferência ao bind. O /etc/resolv.conf é:
    search ciatecnica.com.br
    nameserver 192.168.0.1

    No CL10 o Bind é by default chrootado, portanto o named.conf está em /var/named/etc e seu conteúdo é:
    options {
    directory "/var/named";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    query-source address * port 53;
    dump-file "/var/named/dump/named_dump.db";
    statistics-file "/var/named/dump/named.stats";
    // memstatistics-file "/var/named/dump/named.memstats";
    // remove this next line if you want named to listen on
    // all available interfaces, or adjust add new ones as
    // you see fit
    listen-on { 127.0.0.1/32; };
    // listen-on { 192.168.0.0/24; };

    // named-xfer "/var/named/named.ca";
    pid-file "/var/run/named/named.pid";
    };


    zone "." {
    type hint;
    file "/var/named/named.ca";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "/var/named/127.0.0";
    };

    zone "ciatecnica.com.br" {
    type master;
    file "/var/named/ciatecnica.com.br";
    };

    zone "0.168.192.in-addr.arpa" {
    type master;
    file "/var/named/192.168.0";
    };


    // Use with the following in named.conf, adjusting the allow list as needed:
    key "rndc-key" {
    algorithm hmac-md5;
    secret "nJUL4lCJgJYvU037/OHQBQ==";
    };

    controls {
    inet 127.0.0.1 port 953 allow { 127.0.0.1; } keys { "rndc-key"; };
    };




    Conteúdo de /var/named/var/named/127.0.0

    $TTL 43200
    @ IN SOA server01.ciatecnica.com.br. artur.ciatecnica.com.br. (
    1
    86400
    3600
    1296000
    86400
    )

    @ IN NS server01.ciatecnica.com.br.

    ;loopback
    1 IN PTR localhost.




    Conteúdo de /var/named/var/named/192.168.0

    ;named.rev
    $TTL 43200

    @ IN SOA server01.ciatecnica.com.br. artur.ciatecnica.com.br. (
    1
    86400
    3600
    1296000
    86400
    )

    @ IN NS server01.ciatecnica.com.br.

    ;DNS Server
    1 IN PTR server01.ciatecnica.com.br.



    ;Demais Hosts - todos os hosts da rede
    10 IN PTR win.ciatecnica.com.br.




    Conteúdo de /var/named/var/named/ciatecnica.com.br

    ;named.hosts
    $TTL 43200
    @ IN SOA server01.ciatecnica.com.br. artur.ciatecnica.com.br. (
    1
    86400
    3600
    1296000
    86400
    )

    @ IN NS server01.ciatecnica.com.br.

    ;loopback
    localhost IN A 127.0.0.1

    ;DNS Server
    server01 IN A 192.168.0.1

    ;aliases
    www IN CNAME server01


    ;Demais Hosts a serem nomeados
    win IN A 192.168.0.10




    Em /var/named/var/named/ também tem o named.ca e o diretório dump, que já estava la quando da instalação do Bind, pelo Synaptic, em modo gráfico.

    Em /var/named/ tem os diretórios dev, etc e var, todos já instalados quando da instalação do Bind e com seus respectivos arquivos.

    No /var/named/etc tem os arquivos localtime e named.conf além de:
    rndc.conf:
    # Start of rndc.conf
    key "rndc-key" {
    algorithm hmac-md5;
    secret "nJUL4lCJgJYvU037/OHQBQ==";
    };

    options {
    default-key "rndc-key";
    default-server 127.0.0.1;
    default-port 953;
    };
    # End of rndc.conf



    rndc.key:
    key "rndc-key" {
    algorithm hmac-md5;
    secret "nJUL4lCJgJYvU037/OHQBQ==";
    };





    Creio ter colocado aqui todos os arquivos de configuração do Bind e corretamente configurados, pois o named.conf foi testado com named-checkconf e os arquivos de configuração de zonas testados com o named-checkzone e em todos não retornaram erros.

    Agora, ao levantar o serviço recebo o desejado [OK].
    [root@server01 init.d]# ./named start
    Iniciando named: [ OK ]


    Verifico o serviço com o comando ./named status e tenho como resultado:
    [root@server01 init.d]# ./named status
    named (pid 1240) está rodando...
    number of zones: 5
    debug level: 0
    xfers running: 0
    xfers deferred: 0
    soa queries in progress: 0
    query logging is OFF
    server is up and running


    Agora, vamos aos logs do sistema localizados em /var/log/messages e verificar os logs referentes a este wake up do serviço:
    Nov 28 21:26:00 server01 named[3773]: starting BIND 9.2.3 -u named -t /var/named
    Nov 28 21:26:00 server01 named[3773]: using 1 CPU
    Nov 28 21:26:00 server01 named[3773]: loading configuration from '/etc/named.conf'
    Nov 28 21:26:01 server01 named[3773]: no IPv6 interfaces found
    Nov 28 21:26:01 server01 named[3773]: listening on IPv4 interface lo, 127.0.0.1#53
    Nov 28 21:26:01 server01 named[3773]: command channel listening on 127.0.0.1#953
    Nov 28 21:26:01 server01 named[3773]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1
    Nov 28 21:26:01 server01 named[3773]: zone 0.168.192.in-addr.arpa/IN: loaded serial 1
    Nov 28 21:26:01 server01 named[3773]: zone ciatecnica.com.br/IN: loaded serial 1
    Nov 28 21:26:01 server01 named[3773]: running


    Beleza, né... é, mas vamos agora aos testes.
    No comando dig temos:
    [root@server01 init.d]# dig 192.168.0.1

    ; <<>> DiG 9.2.3 <<>> 192.168.0.1
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    [root@server01 init.d]# dig www.ciatecnica.com.br

    ; <<>> DiG 9.2.3 <<>> www.ciatecnica.com.br
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    Usando o programa nslookup:
    [root@server01 init.d]# nslookup 192.168.0.1
    Note: nslookup is deprecated and may be removed from future releases.
    Consider using the `dig' or `host' programs instead. Run nslookup with
    the `-sil[ent]' option to prevent this message from appearing.
    ;; connection timed out; no servers could be reached

    [root@server01 init.d]# nslookup www.ciatecnica.com.br
    Note: nslookup is deprecated and may be removed from future releases.
    Consider using the `dig' or `host' programs instead. Run nslookup with
    the `-sil[ent]' option to prevent this message from appearing.
    ;; connection timed out; no servers could be reached


    E para os adéptos do host, la vai:
    [root@server01 init.d]# host 192.168.0.1
    ;; connection timed out; no servers could be reached
    [root@server01 init.d]# host www.ciatecnica.com.br
    ;; connection timed out; no servers could be reached


    Bem, creio ter dado as informações necessárias para alguém poder interpretar o que está acontecendo. Possivelmente seja algo muito pequeno, no entanto não estou conseguindo fazer o server funcionar.

    Aguardo retorno.

    Atenciosamente,
    Artur Arocha.

  2. Am... como tá o seu /etc/resolv.conf ?


    Abraços!



  3. #3
    Arocha
    Já mencionei acima.

    O /etc/resolv.conf é:
    search ciatecnica.com.br
    nameserver 192.168.0.1

  4. #4
    karfax
    Uma coisa que eu notei:
    listen-on { 127.0.0.1/32; };
    e mais abaixo, em /etc/resolv.conf:
    nameserver 192.168.0.1

    Mude a diretiva para:
    listen on { any; };

    e veja se adianta alguma coisa.

    Se for, esta evidente que voce está apontando teu resolver para um ip que não é permitido explicitamente escutar pela tua configuração atual.

    ps: dê um retorno, é uma coisa interessante...

    Sds,



  5. #5
    Arocha
    :lol:
    AAAAAAAAAAAAAAAAAAAAALELUIA....
    AAAAAAAAAAAAAAAAAAAAALELUIA...

    UHUUUUUUUUUUUUUUUUU...


    Fucou... O listen-on { any; }; fez TUDO funcionar EXATAMENTE como eu queria.

    Valew.

    Agora eu vou tentar entender o PQ de q apenas essa quase insignificancia estava me impedindo de fazer funcar o server.

    Muito obrigado amigos.

    P.S.: Ahhh... As configurações acima são muito interessantes para ter-se como base na configuração do Bind no CL10, pois FUNCIONA.






Tópicos Similares

  1. Compilei o Kernel 24 com psd mas nao funciona no iptables!!!
    Por analistaslack no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 02-08-2007, 07:43
  2. Instando o Anjuta no Fedora Core 4 mas não funciona...
    Por ibotirama no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 24-11-2005, 10:05
  3. DWL-810+ funciona no AP1000 mas não funciona no AP2000
    Por denilson_rocha no fórum Redes
    Respostas: 4
    Último Post: 12-11-2004, 16:52
  4. Modem USR 56K - configurado, mas nao funciona.
    Por no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 23-07-2003, 17:12
  5. Instalei o Slack9 mas nao funciona..
    Por daniell no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-05-2003, 07:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L