Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal, estou com um problema estou usando NCSA par autenticar, fiz as configurações tudo certinho, mas olha o pipoco, quando eu acesso qualquer pagina ele pede a senha até ai correto, mas eu coloco a senha e ele não autentica ele pede novamente, e assim por diante, o que pode ser ??? alguém pode me dar uma mãozinha...
    Antecipo meus Agradecimento

    H_Franzin

  2. Faça-se essas perguntas:

    A - Você criou o usuário? (É meio idiota, mas acontece...)
    B - Qual é a ordem das suas ACL's?
    C - Como estão os seus http_access?

    Posta o seu squid.conf para a gente dar uma olhada...


    Abraços!



  3. hehe, realmente pode acontecer,mas enfim to enviando o meu squid.conf, sou muito grato, OBRIGADO

    # Squid.conf

    http_port 3128
    icp_port 3130

    hierarchy_stoplist cgi-bin ?

    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY

    auth_param basic program /usr/lib/squid/ncsa_auth /var/spool/squid/passwd
    auth_param basic children 5
    auth_param basic realm IRON_squid
    auth_param basic credentialsttl 2 hours
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320

    cache_mem 8 MB
    cache_swap_low 90
    cache_swap_high 95

    maximum_object_size 4096 KB
    cache_dir ufs /var/spool/squid/cache 5000 16 256
    cache_access_log /var/spool/squid/logs/access.log
    cache_log /var/spool/squid/logs/cache.log
    cache_store_log /var/spool/squid/logs/store.log

    emulate_httpd_log off
    dns_nameservers 200.246.46.132

    #Acl's
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    #acl localhost dst 127.0.0.0/8
    acl SSL_ports port 443 444 447 563 7443 10000
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    ##
    acl rede proxy_auth “/var/spool/squid/user/rede”
    acl master proxy_auth “/var/spool/squid/user/master”
    ##

    acl downloads urlpath_regex .exe$ .zip$ .arj$ .tar.gz$ .tgz$ .rpm$ .mp3$
    acl porno url_regex -i "/var/spool/squid/block/block.txt"

    acl msn dstdomain loginnet.passport.com
    acl msnmessenger url_regex -i gateway.dll
    acl msnaplication req_mime_type -i ^application/x-msn-messenger$
    acl webmsn dstdomain webmessenger.msn.com

    acl icq dstdomain login.icq.com

    #Access
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    ##
    http_access allow master
    ##

    http_access allow msn
    http_access deny msnmessenger
    http_access deny msnaplication
    http_access allow webmsn
    http_access deny icq
    http_access deny downloads
    http_access deny porno

    ##
    http_access allow rede
    ##

    coredump_dir /var/spool/squid
    visible_hostname Master-Iron

  4. Cara, você tem que dar uma organizada nesse teu squid.conf, pois existem várias ACL's que você pode bloquear tudo junto.

    Bom, pelo o que eu notei, você tem que adicionar uma ACL assim:
    Código :
    acl autenticacao proxy_auth REQUIRED

    E um http_access assim:
    Código :
    http_access allow autenticacao

    O http_access você joga logo antes da ACL que você utilizou para liberar a tua rede.

    Acho que depois disso você pode tentar de novo =).


    Abraços!



  5. Olha o pipoco agora, eu coloquei as linha que vc me comentou, mas ele não inicia o squid, mas se eu comento essa linha:

    auth_param basic realm IRON_squid

    ele inicia na boa mas ele ignora todas as linha que tem referencia a autenticação, ele (squid) diz que nenhum esquema de autenticação foi configurado completamente

    Agradeço vossa atenção






Tópicos Similares

  1. Amigos do Abutre, ajude no SQUID - Autenticação não funciona
    Por Abutre no fórum Servidores de Rede
    Respostas: 10
    Último Post: 19-09-2003, 09:28
  2. Amigos do Abutre, ajude no SQUID - Autenticação não funciona
    Por Abutre no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-09-2003, 14:45
  3. Amigos do Abutre, ajude no SQUID - Autenticação não funciona
    Por Abutre no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-09-2003, 14:16
  4. Amigos do Abutre, ajude no SQUID - Autenticação não funciona
    Por Abutre no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-09-2003, 14:12
  5. Amigos do Abutre, ajude no SQUID - Autenticação não funciona
    Por Abutre no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-09-2003, 14:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L