Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    violinista
    Olá, pessoal !!!

    Já há um bom tempo estou procurando o módulo pra placa Realtek 8139, mas não tou conseguindo ... estou usando Debian woody ... na instalação não apareceu o módulo dela, e o arquivo rtl8139too.o não aparece em /lib/modules/2.4.18/............

    Já baixei o arquivo rtl8139.c do site da Realtek, mas não estou conseguindo compilar ... um arquivo que ele precisa, version.h, não está incluído no fonte do kernel que baixei via apt ...

    Se alguém souber de alguma "pista" onde eu possa encontrar esse módulo, ou até mesmo alguma dica pra compilar o que eu baixei, será uma ajuda enorme !

    Valew !!!!!

  2. Amigo, é o seguinte...


    O módulo para a placa de rede Realtek 8139 (A/B/C) mudou de nome na passagem do Kernel 2.2 para o 2.4. Ele agora se chama simplesmente 8139too.o.

    Se você está instalando o Kernel 2.4 no Debian Woody (iniciando a instalação com o parâmetro "bf24"), ele já vem compilado dentro do Kernel. Sendo assim, você não precisa iniciar módulo algum.

    Somente dê um "ifup eth0" que tá rodando... =)


    Abraços!



  3. #3
    violinista
    Eaê, Stéfano !

    ops: ops: ops: puts, que vergonha ... isso que dá postar no desespero ... acabei postando besteira ...

    Meu, desculpa ... a rtl8139 tá funcionando direitinho ... dei um dmesg e vi q tá carregando o módulo dela lá ... então o meu problema tá na outra placa ... uma VIA ... no dmesg não aparece nenhuma msg de erro ... e qdo dou um modprobe via-rhine, aparece que não existe o dispositivo ... mas qdo dou um cat /proc/pci, aparece o seguinte (além da rtl8139 ...):

    Ethernet controller: PCI device 1106:3106 (VIA Technologies, Inc.) (rev 134).
    IRQ 10.
    Master Capable. Latency=64. Min Gnt=3.Max Lat=8.
    I/O at 0xf000 [0xf0ff]
    Non-prefetchable 32 bit memory at 0xffadfe00 [xffadfeff]

    Acho mto estranho ... será q devo tentar carregar outro módulo ?

    Valew mesmo !!!

    Até + !

  4. Dá um modconf e carrega o módulo dela... =)


    Abraços!



  5. #5
    violinista
    Falaê, Stéfano !!!

    K-ra, valew pela dica ... essa do modconf eu não conhecia ... achei interessante pacas !!!

    Mas o problema não era o módulo ... era o kernel ... essa "beleza" dessa VIA6105 é chamada de Rhine III, mas ela só é suportada a partir do kernel 2.4.20 ... e eu estava usando o 2.4.18 ... baixei e compilei um kernel 2.4.28 e ela funfou direitinho !!!

    Bom ... fika registrada aí a experiência ... se algum dia alguém se deparar com um problema desse, já sabe o q fazer !!!

    K-ra, mais uma vez ... muito obrigado pela força !!!!!!!!

    Vlw !!!!!






Tópicos Similares

  1. Modulos Relatorios squid e sendmail!!!
    Por AndrewAmorimdaSilva no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-11-2002, 13:12
  2. Modulos Perl
    Por 1c3m4n no fórum Servidores de Rede
    Respostas: 5
    Último Post: 12-11-2002, 17:20
  3. Modulos Perl
    Por 1c3m4n no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-11-2002, 16:02
  4. Modulos (modprobe) ip_masq_ftp
    Por caps no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-08-2002, 17:21
  5. PCMCIA - 3com modulo i82365
    Por earaujos no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-08-2002, 10:59

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L