Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    guardian_metal
    [root@lasertools-serv lsts]# /sbin/route del default
    [root@lasertools-serv lsts]# /sbin/route add default eth1
    [root@lasertools-serv lsts]# /sbin/route add default gw 192.168.172.1
    [root@lasertools-serv lsts]# /etc/init.d/network restart
    Shutting down interface eth0: [ OK ]
    Shutting down interface eth1: [ OK ]
    Shutting down loopback interface: [ OK ]
    Disabling IPv4 packet forwarding: [ OK ]
    Setting network parameters: [ OK ]
    Bringing up loopback interface: [ OK ]
    Bringing up interface eth0: [ OK ]
    Bringing up interface eth1: [ OK ]
    [root@lasertools-serv lsts]# /sbin/route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth0
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default 192.168.172.1 0.0.0.0 UG 0 0 0 eth0

    Pelo o que me parece é que ele usa o endereço 192.168.172.1 como gateway na eth0 mas eu adicionei o gateway 192.168.172.1 na eth1.

    O que há de errado?

    Agora vejam isso:

    [root@lasertools-serv network-scripts]# cat ifcfg-eth0
    BOOTPROTO=none
    PEERDNS=no
    IPV6INIT=no
    TYPE=Ethernet
    HWADDR=00:07:E9:19:EB:AA
    DEVICE=eth0
    MTU=""
    NETMASK=255.255.255.0
    BROADCAST=192.168.172.255
    IPADDR=192.168.172.4
    NETWORK=192.168.172.0
    USERCTL=no
    ONBOOT=yes
    You have new mail in /var/spool/mail/henrique
    [root@lasertools-serv network-scripts]# cat ifcfg-eth1
    GATEWAY=192.168.172.1
    BOOTPROTO=none
    PEERDNS=no
    HWADDR=00:0BB:8E:98:9B
    TYPE=Ethernet
    IPV6INIT=no
    DEVICE=eth1
    MTU=""
    NETMASK=255.255.255.0
    BROADCAST=192.168.172.255
    IPADDR=192.168.172.2
    NETWORK=192.168.172.0
    ONBOOT=yes
    USERCTL=no

    O gateway esta na interface eth1 mas o comando route me mostra na eth0. O que faço agora?

    Minhas linhas de nat.

    iptables=/sbin/iptables
    #
    IF_EXTERNA=eth1
    IF_INTERNA=eth0
    #
    #Habilita (NAT)
    $iptables -t nat -A POSTROUTING -o $IF_EXTERNA -j MASQUERADE
    #
    #Redireciona Todas as portas para a 8080 (http) (Squid)
    $iptables -t nat -A PREROUTING -s 192.168.172.0/24 -p tcp --dport 80 -j REDIRECT --to 8080
    $iptables -t nat -A PREROUTING -s 192.168.172.0/24 -p udp --dport 80 -j REDIRECT --to 8080
    $iptables -t nat -A PREROUTING -s localhost -p tcp --dport 80 -j REDIRECT --to 8080
    $iptables -t nat -A PREROUTING -s localhost -p udp --dport 80 -j REDIRECT --to 8080

  2. #2
    abc
    Desabilita as interfaces, e levanta tudo na mao,:

    ifconfig e route

    E veja o que acontece

    Se der certo coloque no rc.local



  3. #3
    estanisgeyer
    Você fez uma pequena confusão. Seria assim:

    # route del default
    # route add default gw 192.168.172 eth1
    # service network restart


    Att.

  4. #4
    guardian_metal
    Reiniciei cada uma das interfaces na mão e continua igual e:

    [root@lasertools-serv lsts]# /sbin/route del default
    [root@lasertools-serv lsts]# /sbin/route add default gw 192.168.172.1 eth1
    [root@lasertools-serv lsts]# /etc/init.d/network restart
    Shutting down interface eth0: [ OK ]
    Shutting down interface eth1: [ OK ]
    Shutting down loopback interface: [ OK ]
    Disabling IPv4 packet forwarding: [ OK ]
    Setting network parameters: [ OK ]
    Bringing up loopback interface: [ OK ]
    Bringing up interface eth0: [ OK ]
    Bringing up interface eth1: [ OK ]
    [root@lasertools-serv lsts]# /sbin/route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth0
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default 192.168.172.1 0.0.0.0 UG 0 0 0 eth0



  5. #5
    guardian_metal
    Pra quem acha maluko, veja só:

    1. Configurando o Gateway padrão e reiniciando a rede:

    [root@lasertools-serv lsts]# /sbin/route del default
    [root@lasertools-serv lsts]# /sbin/route add default gw 192.168.172.1 eth1
    [root@lasertools-serv lsts]# /etc/init.d/network restart
    Shutting down interface eth0: [ OK ]
    Shutting down interface eth1: [ OK ]
    Shutting down loopback interface: [ OK ]
    Setting network parameters: [ OK ]
    Bringing up loopback interface: [ OK ]
    Bringing up interface eth0: [ OK ]
    Bringing up interface eth1: [ OK ]
    [root@lasertools-serv lsts]# /sbin/route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth0
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default 192.168.172.1 0.0.0.0 UG 0 0 0 eth0

    Obs: Mesmo configurando o gateway na eth1, ele só funciona na eth0 quando reinicio a rede.

    2. Configurando o Gateway padrão e não reiniciando a rede:

    [root@lasertools-serv lsts]# /sbin/route del default
    [root@lasertools-serv lsts]# /sbin/route add default gw 192.168.172.1 eth1
    [root@lasertools-serv lsts]# /sbin/route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth0
    192.168.172.0 * 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    default 192.168.172.1 0.0.0.0 UG 0 0 0 eth1

    Obs: Mesmo configurando o gateway na eth1, ele só funciona na eth1 se o serviço rede não for reiniciado.

    Solução: Colocar o seguinte em rc.local;

    /sbin/route del default
    /sbin/route add default gw 192.168.172.1 eth1

    E pronto. Loko, né?






Tópicos Similares

  1. Problemas nas rotas Linux <-> PPPoE Mikrotik
    Por tianguapontocom no fórum Servidores de Rede
    Respostas: 8
    Último Post: 25-03-2011, 14:57
  2. Problema na rota ..eu acho....
    Por Duca no fórum Servidores de Rede
    Respostas: 1
    Último Post: 13-08-2005, 21:20
  3. Problemas na impressao pela rede
    Por sartori no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-05-2005, 12:12
  4. Problema na hora de configurar o mouse SOCORRO- URGENTE
    Por Bruno Antelo no fórum Sistemas Operacionais
    Respostas: 8
    Último Post: 02-12-2004, 01:47
  5. Rede ponto a ponto ad-hoc wireless problema na rota de retor
    Por denilson no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-09-2003, 14:32

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L