+ Responder ao Tópico



  1. #1
    TiagoCruz
    Tomei um susto quando vi nos logs do meu PDC que tinha nego "de fora" acessando o meu TUX com CL10 pela interface eth1, sendo que a linha

    interfaces = eth0, 192.168.0.1/255.255.255.0

    está bem explícita no meu smb.conf.

    Logicamente que resolvi com o iptables, mas no SaMBa 2.x isso resolveria..

    Alguem pode comentar algo a respeito?

    Obrigado!

  2. Por que vc não tenta usar:
    hosts allow = 192.168.0. 127.

    Retirado do man smb.conf
    Default: interfaces = # all active interfaces except 127.0.0.1 that are
    broadcast capable
    Example: interfaces = # This would configure three network interfaces
    corresponding to the eth0 device and IP addresses 192.168.2.10 and
    192.168.3.10. The netmasks of the latter two interfaces would be set to
    255.255.255.0. eth0 192.168.2.10/24 192.168.3.10/255.255.255.0

    Tente usar
    interfaces = eth0, 192.168.0.0/255.255.255.0

    Além de que o que vc especificou está errado o correto é 192.168.0.0/255.255.255.0 (rede) ou 192.168.0.1/255.255.255.255 (Host)



  3. #3
    TiagoCruz
    Fred,

    na verdade eu havia usado somente "interfaces = eth0" mas como não funcionou, eu adicionei o IP manualmente, e erroneamente ops:

    Valeu, vou testar... mas não acha que deveria funcionar somente com o eth0?

    Abração!

  4. O lógico seria isso mesmo.



  5. #5
    TiagoCruz
    No SaMBa 3, tem que colocar a linha

    bind interfaces only = Yes

    Para funcionar!

    Mas mesmo assim deu zica pra mim, hehehe
    http://forumgdh.net/viewtopic.php?t=...asc&highlight=

    Valeus ae!






Tópicos Similares

  1. Samba não funciona no Slack 9.1
    Por Tonare no fórum Servidores de Rede
    Respostas: 7
    Último Post: 24-05-2004, 07:48
  2. Comando SETUP no SUSE não funciona..
    Por rfdasilva1 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 22-10-2003, 20:22
  3. Samba não funciona - help me
    Por no fórum Servidores de Rede
    Respostas: 7
    Último Post: 26-06-2003, 14:40
  4. Profiles no Samba-Não Consigo desabilitar
    Por osni_passos no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-02-2003, 08:39
  5. Respostas: 3
    Último Post: 25-11-2002, 18:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L