Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoa,,

    Tenho um probleminha simples que me persegue em alguns clientes que não tem o domínio na empresa (que está em algum provedor)
    Não sou desenvolvedor de páginas, por isso, acho que minha dúvida é simples.
    Sempre que instalo um webserver, crio uma página simples para poder realisar alguns serviços via web (tipo criar usuário, visualizar relatórios do Sarg, etc.)

    O meu problema está ai. Por exemplo, alguns links cgi, que deveria ficar do tipo http://dominio.com.br/cgi-bin/script, como não tenho domínio, tenho que criar http://192.168.0.1/cgi-bin/script.
    Dessa forma funciona internamente, mas quando acesso via Internet, dá erro, devido ao IP inválido. Se mudo para o IP válido na Internet, funciona remotamente, mas não funciona internamente.

    Como posso contornar esse problema?


    Valeu!

  2. #2
    felco
    Hummm vc tem que alterar o IP dentro do CGI ou na conf do Apache, os CGI sao Perl, C, PHP ou oq?



  3. Ai é q tá.
    São gerados por programas do tipo Mailgraph, openwebmail, etc.
    Se tiver que elterar todos manualmente, to ferrado.
    Penso que poderia ser feito via Apache.
    Como ?

  4. #4
    felco
    Vc pode usar um dominio dinamico tipo www.no-ip.org eh gratis eh vc consegue utilizar um dominio valido sem problemas



  5. Eu uso o no-ip e funciona que é uma beleza.






Tópicos Similares

  1. Respostas: 1
    Último Post: 20-04-2017, 16:25
  2. Respostas: 3
    Último Post: 13-01-2015, 12:45
  3. Mikrotik com ip fixo sem acesso
    Por ynsanyty no fórum Redes
    Respostas: 3
    Último Post: 04-05-2013, 04:03
  4. Respostas: 3
    Último Post: 09-02-2012, 14:45
  5. Respostas: 2
    Último Post: 13-07-2007, 16:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L