+ Responder ao Tópico



  1. #1

    Padrão Problema no Apache/mod_proxy

    Daew galera, to com o seguinte problema, tenho 3 maquinas na minha rede,
    uma eh o firewall/roteador, outra eh o apache principal, e outra eh o apache secundario....

    Código :
    (= INTERNET =) ====> [ROTEADOR] ---> [APACHE1/mod_proxy] --> [APACHE2]

    O problema ta quando eu acesso um site do APACHE2 dessa forma:
    www.meusite.com.br/mail
    Ou seja, sem a "/" (barra) no final (mail eh um diretorio Alias no caso), quando eu faco isso na rede interna, funciona q eh uma maravilha...ou quase isso.....pq quando eu acesso na rede interna aquele endereco, ele me manda para algo assim
    192.168.0.1/mail
    onde esse IP(ficticio) eh do APACHE2.....
    eu ja tentei usar o
    Redirect [permanent] /mail http://www.meusite.com.br/mail/
    porem ele entra em loop de redir

    alguem sabe como solucionar issu???

  2. #2
    Aquini
    Visitante

    Padrão Problema no Apache/mod_proxy

    e se vc utilizar o seguinte (no apache 1):

    Código :
    ProxyPass /mail/ http://<ip_do_apache_2>/mail/ 
    ProxyPassReverse /mail/ http://<ip_do_apache_2>/mail/

    daí faça o trafego da LAN e da web acessar somente o apache 1

    T+



  3. #3
    Aquini
    Visitante

    Padrão Problema no Apache/mod_proxy

    E daí SDM... deu certo?

  4. #4

    Padrão Problema no Apache/mod_proxy

    funfo cara....eh isso ae msm...
    vlw...
    :wink:



  5. #5
    TheMage
    Visitante

    Padrão Problema no Apache/mod_proxy

    Bem pessoal vou aproveitar pra fazer uma nova pergunta ,.. bem parecida...

    eu configurei o proxy apache com
    ServerAlias webmail.*
    ProxyRequests Off
    ProxyPass / http://xxx.xxx.xxx.xxx/
    ProxyPassReverse / http://xxx.xxx.xxx.xxx/


    O detalhe é que meu servidor xxx.xxx.xxx.xxx tem virtuais tmb,.. tipo webmail.dominio1.com.br é diferente do webmail.dominio2.com.br ,..
    mas não importa qual configuração eu ponha,... vai sempre abrir o webmail default !,.. ou seja ele não esta repassando todos os headers,.. como corrijo isso ???

  6. #6

    Padrão Problema no Apache/mod_proxy

    vc nao pode configurar os virtualhosts no proxy tbm?



  7. #7
    TheMage
    Visitante

    Padrão Problema no Apache/mod_proxy

    acho que o problema é justamente esse,.. eu tenho virtuais configurado nos dois,.. o problema é quando abre no segundo servidor,.. ele chama sempre o dominio principal,..

    sabe que se vc configurar alguns virtuais e vc abrir aquele servidor atravez do ip ele abre sempre o primeiro virtual configurado né.. meu problema é justamente esse,.. o apache proxy faz a requisição realmente pelo ip.. fazendo com que o servidor de webmail pegue sempre o primeiro dominio,..

    se tiver afim de trocar uma ideia por icq ou msn ta valendo,..
    UIN 31093311 ,.. ou MSN ajsouza[#]webrs.com.br