+ Responder ao Tópico



  1. #1
    ptadeu
    Ae povo...

    Instalei aqui o 'PPPoE + Radius + Bandlimit' e consegui fazer a autenticação, estabeleço a conexão, o ip é atribuído, mas, ñ consigo fazer com q o cliente saia da rede, como se ñ houvesse um GW, como se o nat não tivesse funcionando.

    Ao invés de utilizar ip's válidos, estou utilizando o range 192.168.0.0/24

    Se alguém puder dar uma luz, eu agradeço desde já.

    []s

  2. vc tah colocando a regra d nat no seu pppoe-server, pra jogar o povo pra fora??

    tipow..

    Código :
    iptables -t nat -A POSTROUTING -j MASQUERADE

    []'s



  3. #3
    ptadeu
    Ja ativei o FORWARD, INPUT, OUTPUT e NAT... mas mesmo assim não funfa...

    O q mais poderia ser ?

    []s

  4. poootz.... faz o seguinte:

    postae tdos os seus confs... vamos analisar tdos os q vc fez...

    []'s



  5. Vc ativou o repasse d ip?
    echo 1 > /proc/sys/net/ipv4/ip_forward

    Tenta isso... senaum, faz o q o demiurgo disse: posta as configs aih pra gente ver...

  6. #6
    ptadeu
    Seguinte...

    meu esquema ta da seguinte forma:

    Internet (200.1.2.2) --> eth1 (200.1.2.3) -- lbox -- eth0 (192.168.0.1)

    Tenho um cliente no radius configurado como:

    teste Auth-Type = Local, Password = "teste"
    Service-Type = Framed-User,
    Framed-Protocol = PPP,
    Framed-IP-Address = 192.168.0.10,
    Framed-IP-Netmask = 255.255.255.255,
    Framed-Routing = Broadcast-Listen,
    Framed-Filter-Id = "bo",
    Framed-MTU = 1500,
    Framed-Compression = Van-Jacobson-TCP-IP,
    Idle-Timeout = 600,
    Download = 256,
    Upload = 64

    O arquivo /etc/ppp/ips tem o seguinte conteudo:

    192.168.0.0-255

    Eu inicializo o pppoe-server da seguinte forma:

    pppoe-server -C Teste -L 192.168.0.1 -p /etc/ppp/ips -I eth0

    Em um cliente com windows 98, utilizando o RASPPPoE eu consigo efetuar a conexão, o usuario 'teste' eh autenticado, o IP 192.168.0.10 eh atribuido a ele, os servidores de DNS são configurados com os que eu previamente defini no arquivo /etc/ppp/pppoe-server-options.

    No entanto, ñ consigo sair da rede... como se ñ houvesse NAT.

    No lbox eu configuro o NAT da seguinte forma:

    iptables -A FORWARD -d 0/0 -s 192.168.0.10 -j ACCEPT
    iptables -A FORWARD -d 192.168.0.10 -s 0/0 -j ACCEPT
    iptables -t nat -A POSTROUTING -s 192.168.0.10 -d 0/0 -j MASQUERADE
    iptables -A INPUT -s 192.168.0.10 -d 0/0 -j ACCEPT
    iptables -A OUTPUT -s 192.168.0.10 -d 0/0 -j ACCEPT

    ativo o repasse de pacotes no kernel da seguinte forma:

    echo 1 > /proc/sys/net/ipv4/ip_forward

    Vale ressaltar tb que eu consigo pingar do cliente windows os seguinte ip's:

    192.168.0.1
    200.1.2.3 (ip da outra IF)

    No entanto, não consigo sair dessa rede... nem mesmo alcanço o ip 200.1.2.2

    Gostaria de saber o q pode estar acontecendo.

    Se alguém puder me ajudar... estou antecipadamente grato.

    []s






Tópicos Similares

  1. Netmask no PPPoE-Server
    Por sarna no fórum Servidores de Rede
    Respostas: 2
    Último Post: 28-09-2005, 20:34
  2. PPPOE-server + Radius Conectiva - urgente
    Por aljaab no fórum Servidores de Rede
    Respostas: 8
    Último Post: 21-09-2005, 09:27
  3. Problemas com PPPoE-Server
    Por sarna no fórum Servidores de Rede
    Respostas: 5
    Último Post: 05-09-2005, 16:35
  4. Como Autenticar num Servidor Radius através do PPPoe Server?
    Por caio herdy no fórum Servidores de Rede
    Respostas: 4
    Último Post: 03-08-2005, 08:58
  5. PPPoE server e Mac Address da origem
    Por Goni no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-10-2004, 08:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L