+ Responder ao Tópico



  1. #1

    Padrão proftpd conecta mas não lista

    Uso conectiva 10 - proftpd - squid - apache
    Na rede local tenho acesso, mas não consigo listar pastas no cliente remoto ADSL. Dá o seguinte erro:
    Erro ao abrir pasta na servidor
    Detalhes:
    200 type set to A
    500 Illegal port command
    500 LPRT not understood

  2. #2

    Padrão Re: proftpd conecta mas não lista

    Citação Postado originalmente por mbtec
    Uso conectiva 10 - proftpd - squid - apache
    Na rede local tenho acesso, mas não consigo listar pastas no cliente remoto ADSL. Dá o seguinte erro:
    Erro ao abrir pasta na servidor
    Detalhes:
    200 type set to A
    500 Illegal port command
    500 LPRT not understood
    tenta habilitar o passive mode e ver se funciona

    falows



  3. #3

    Padrão Re: proftpd conecta mas não lista

    Citação Postado originalmente por ruyneto
    Citação Postado originalmente por mbtec
    Uso conectiva 10 - proftpd - squid - apache
    Na rede local tenho acesso, mas não consigo listar pastas no cliente remoto ADSL. Dá o seguinte erro:
    Erro ao abrir pasta na servidor
    Detalhes:
    200 type set to A
    500 Illegal port command
    500 LPRT not understood
    tenta habilitar o passive mode e ver se funciona

    falows
    Como faço isto? é no proftpd.conf

  4. #4

    Padrão proftpd conecta mas não lista

    Se vc tiver fazendo ftp via linux assim que conectar da um passive on, se nao ve no seu programa de ftp como faz isso, se não resolver posta ae

    falows



  5. #5

    Padrão Re: proftpd conecta mas não lista

    Citação Postado originalmente por mbtec
    Uso conectiva 10 - proftpd - squid - apache
    Na rede local tenho acesso, mas não consigo listar pastas no cliente remoto ADSL. Dá o seguinte erro:
    Erro ao abrir pasta na servidor
    Detalhes:
    200 type set to A
    500 Illegal port command
    500 LPRT not understood
    bom colega eu tive problemas igual ao seu, posta ae oque esta acontencendo certinho e que tipo de adsl vc usa e porta do ftp

  6. #6

    Padrão Re: proftpd conecta mas não lista

    Citação Postado originalmente por LinuxKids
    Citação Postado originalmente por mbtec
    Uso conectiva 10 - proftpd - squid - apache
    Na rede local tenho acesso, mas não consigo listar pastas no cliente remoto ADSL. Dá o seguinte erro:
    Erro ao abrir pasta na servidor
    Detalhes:
    200 type set to A
    500 Illegal port command
    500 LPRT not understood
    bom colega eu tive problemas igual ao seu, posta ae oque esta acontencendo certinho e que tipo de adsl vc usa e porta do ftp
    Grato pelo interesse:

    Conectiva 10 - ADSL brturbo com ip-dinamico e no-ip no endereço
    ftp://mbtec.no-ip.org:2121

    Na porta padrão 21 não consegui entrar no ftp então mude para a
    porta 2121.

    No proftpd.conf
    Port 2121

    No squid.conf:
    acl SafePort 2121
    http_access allow SafePort

    Em /etc/service
    ftp 2121/udp
    ftp 2121/tcp

    O que ocorre é este erro, tanto para usuário registrado
    como anonymo:

    Erro ao abrir pasta na servidor
    Detalhes:
    200 type set to A
    500 Illegal port command
    500 LPRT not understood[/quote]



  7. #7

    Padrão proftpd conecta mas não lista

    bom a dica de setar como passivo é mto boa, provavelmente ela deve funcionar, porque bem onde sei, se for no modo ativo ele usa as portas padroes, 21 e 20, 21 para controle (comandos) e 20 para transferencia de dados (ftp e ftp-data), logo so esta indo os comandos.

    Tente fazer o seguinte, configure o seu _CLIENTE_ ftp para utilizar o modo passive, é facil facil, basta procurar nas opções dele e clickar la "Utilizar modo de transferencia passivo" que as portas serão negociadas no momento da transferencia. é isso, teste e veja se funciona para voce.

  8. #8
    Visitante

    Padrão proftpd conecta mas não lista

    Citação Postado originalmente por mistymst
    bom a dica de setar como passivo é mto boa, provavelmente ela deve funcionar, porque bem onde sei, se for no modo ativo ele usa as portas padroes, 21 e 20, 21 para controle (comandos) e 20 para transferencia de dados (ftp e ftp-data), logo so esta indo os comandos.

    Tente fazer o seguinte, configure o seu _CLIENTE_ ftp para utilizar o modo passive, é facil facil, basta procurar nas opções dele e clickar la "Utilizar modo de transferencia passivo" que as portas serão negociadas no momento da transferencia. é isso, teste e veja se funciona para voce.
    Caros amigos,
    Os meus clientes serão, praticamente, da plataforma windows.
    Já utilizei os ws-ftple com modo passivo mas retorna o mesmo erro.



  9. #9

    Padrão proftpd conecta mas não lista

    tem firewall, ja procurou desabiliar ele??? nja viu se a telefonica nao barra pacotes marcacos como sendo de ftp??

    falows

  10. #10

    Padrão proftpd conecta mas não lista

    Citação Postado originalmente por ruyneto
    tem firewall, ja procurou desabiliar ele??? nja viu se a telefonica nao barra pacotes marcacos como sendo de ftp??

    falows
    Obrigado pelo retorno!
    - Firewall e squid desligado
    - uso roteador gr250nec brtelecom
    - clientes de linha discada remota e clientes da rede local conseguem conectar no ftp



  11. #11

    Padrão proftpd conecta mas não lista

    No cliente remoto não tem nda que pode ta bloqueando a conecção, ja tentou dar uma olhada nos logs pra ver se alguma cosia não te sendo bloqueada??

    tenta fazer a conecção enquanto isso fica vendo o messages pra ver se apareçe alguma coisa da um tail -f /var/log/messages e ve se pega alog.

    falows

  12. #12

    Padrão proftpd conecta mas não lista

    Citação Postado originalmente por ruyneto
    No cliente remoto não tem nda que pode ta bloqueando a conecção, ja tentou dar uma olhada nos logs pra ver se alguma cosia não te sendo bloqueada??

    tenta fazer a conecção enquanto isso fica vendo o messages pra ver se apareçe alguma coisa da um tail -f /var/log/messages e ve se pega alog.

    falows
    Acabei de reinstalar o cl10 para refazer todos os procedimentos. Vou começar de novo e rever as configurações.
    Logo darei retorno.
    Obrigado.



  13. #13

    Padrão proftpd conecta mas não lista

    Citação Postado originalmente por mbtec
    Citação Postado originalmente por ruyneto
    No cliente remoto não tem nda que pode ta bloqueando a conecção, ja tentou dar uma olhada nos logs pra ver se alguma cosia não te sendo bloqueada??

    tenta fazer a conecção enquanto isso fica vendo o messages pra ver se apareçe alguma coisa da um tail -f /var/log/messages e ve se pega alog.

    falows
    Acabei de reinstalar o cl10 para refazer todos os procedimentos. Vou começar de novo e rever as configurações.
    Logo darei retorno.
    Obrigado.
    Ok, Boa Sorte e espero que de tudo certo.

    qq cosia estamos ae.

    falows

  14. #14

    Padrão proftpd conecta mas não lista

    Pessoal, tenho o mesmo problema do amigo acima...

    naum tenho firewall abilitado nem nada....

    meu modem esta como router e todas as portas liberadas e direcionadas pro meu Linux...

    naum sei tb oq pode ser...

    uso Slack 10



  15. #15

    Padrão proftpd conecta mas não lista

    Citação Postado originalmente por black_burn
    Pessoal, tenho o mesmo problema do amigo acima...

    naum tenho firewall abilitado nem nada....

    meu modem esta como router e todas as portas liberadas e direcionadas pro meu Linux...

    naum sei tb oq pode ser...

    uso Slack 10
    Caros Amigos,
    Retornei!

    Após reinstalar o Conectiva 10, refis o DNS, proftpd apenas para que nada mais interferisse.
    Mude a porta no /etc/proftpd.conf para 2121 e no /etc/service ftp tcp/udp para 2121 e ftp-data para 2120.
    Muda a mensagem de erro, mas continua não listando pastas.
    Observo no ftptop do terminal que o cliente windows está conectado no servidor mas, mas ele não consegue enxergar as pastas.
    Segue arquivo /etc/proftp.conf

    Grato pela atenção.
    **********************************
    ServerName "ProFTPD - Default Instalation"
    ServerType standalone
    DefaultServer on
    ScoreboardFile /var/run/proftpd/scoreboard
    DeferWelcome on
    ServerAdmin [email protected]
    SyslogFacility AUTH

    # Port 21 (ftp standard) is used in case of standalone more
    Port 2121

    # Umask 022 is a good default value to prevent new directories and
    # files from being writable by the group or by other users
    Umask 022

    # To prevent DoS attacks, the max number of instances is limited to 30.
    # If one wants to allow more then 30 simultaneous connectionva, just
    # increment this value. This directive only applies if running in standalone
    # mode
    MaxInstances 30

    # This option, if enabled, will make the users unable to access anything
    # outside their home directory tree. READ THE DOCS!
    #DefaultRoot ~ !root

    # User and Group the server will run as
    User proftpd
    Group proftpd

    <Directory /*>
    AllowOverwrite no
    </Directory>

    # Default configuration for anonymous ftp, without an incoming directory.

    <Anonymous /srv/ftp>
    User ftp
    Group ftp
    DirFakeUser on
    DirFakeGroup on
    RequireValidShell off
    UserAlias anonymous ftp
    MaxClients 10 "Sorry, max %m users -- try again later"
    MaxClientsPerHost 2 "Too many simultaneous connections"
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    AccessGrantMsg "Anonymous access granted for %u."

    # # Write disabled in anonymous chroot
    <Limit WRITE>
    DenyAll
    </Limit>

    </Anonymous>
    **********************************

  16. #16
    visitante
    Visitante

    Padrão proftpd conecta mas não lista

    colega, ative os modulos do ftp.

    /sbin/modprobe ip_conntrack_ftp
    /sbin/modprobe ip_nat_ftp

    deve funcionar.

    se ok coloque para na inicialização no pc (rc.local ou coisa parecida)

    sds



  17. #17

    Padrão proftpd conecta mas não lista

    Citação Postado originalmente por mbtec
    # This option, if enabled, will make the users unable to access anything
    # outside their home directory tree. READ THE DOCS!
    #DefaultRoot ~ !root

    # User and Group the server will run as
    User proftpd
    Group proftpd

    <Directory /*>
    AllowOverwrite no
    </Directory>

    # Default configuration for anonymous ftp, without an incoming directory.

    <Anonymous /srv/ftp>
    User ftp
    Group ftp
    DirFakeUser on
    DirFakeGroup on
    RequireValidShell off
    UserAlias anonymous ftp
    MaxClients 10 "Sorry, max %m users -- try again later"
    MaxClientsPerHost 2 "Too many simultaneous connections"
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    AccessGrantMsg "Anonymous access granted for %u."

    # # Write disabled in anonymous chroot
    <Limit WRITE>
    DenyAll
    </Limit>

    </Anonymous>
    **********************************
    Seguinte tem o diretorio /srv/ftp para o usuario anonimo?? e para ftp de usuarios eu descomento a linha #DefaultRoot ~ !root

    falows

  18. #18

    Padrão proftpd conecta mas não lista

    bom por default a para srv/ftp ja vem criada mas se não vir crie ela e de um chwon como nobody. a segunda opção e a melhor que funcionou com migo, pois tinha o mesmo problema que o seu. coloque na porta 2222, veio.
    OBs: Talvez esta porta te ajude, pois também passei por este problema e com esta porta consegui resolver. flw.



  19. #19

    Padrão proftpd conecta mas não lista

    Citação Postado originalmente por LinuxKids
    bom por default a para srv/ftp ja vem criada mas se não vir crie ela e de um chwon como nobody. a segunda opção e a melhor que funcionou com migo, pois tinha o mesmo problema que o seu. coloque na porta 2222, veio.
    OBs: Talvez esta porta te ajude, pois também passei por este problema e com esta porta consegui resolver. flw.
    Caros amigos,
    Estou na seguinte situação:

    /etc/proftpd.conf
    port 2121

    /etc/services
    ftp-data 2120\udp
    ftp-data 2120\tcp

    ftp 2121\tcp
    ftp 2121\tcp

    Pastas para FTP
    chown ftp.ftp /srv/ftp/anonymous
    chown nobody.nobody /srv/ftp/incoming

    Squid
    acl SafePorts port 21 20 2121 2120
    http_access allow SafePorts

    Estou testando fazendo estas configurações com
    ADSL IP dinâmico, informando a cada conexão
    ao usuário qual o ip que ele deve conectar.
    Logo será fixo (com ip fixo ou no-ip)

    Estou desconfiado do roteamento das placas
    eth0 e eth1. Acho que não estou liberando a
    passagem entre as duas.

    Podem me auxiliar por favor?

    Segue novo /etc/proftpd.conf

    ****************************
    ServerName "ProFTPD - Default Instalation"
    ServerType standalone
    DefaultServer on
    ScoreboardFile /var/run/proftpd/scoreboard
    DeferWelcome on
    ServerAdmin [email protected]
    SyslogFacility AUTH

    # Port 21 (ftp standard) is used in case of standalone more
    Port 2121

    # Umask 022 is a good default value to prevent new directories and
    # files from being writable by the group or by other users
    Umask 022

    # To prevent DoS attacks, the max number of instances is limited to 30.
    # If one wants to allow more then 30 simultaneous connectionva, just
    # increment this value. This directive only applies if running in standalone
    # mode
    MaxInstances 30

    # This option, if enabled, will make the users unable to access anything
    # outside their home directory tree. READ THE DOCS!
    DefaultRoot ~

    # User and Group the server will run as
    User nobody
    Group nobody

    <Directory /*>
    AllowOverwrite no
    </Directory>

    # Default configuration for anonymous ftp, without an incoming directory.

    <Anonymous /srv/ftp/anonymous>
    User ftp
    Group ftp
    DirFakeUser on ftp
    DirFakeGroup on ftp
    RequireValidShell off
    UserAlias anonymous ftp
    MaxClients 10 "Sorry, max %m users -- try again later"
    MaxClientsPerHost 2 "Muitas conexões simultâneas - Tente mais tarde"
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    AccessGrantMsg "Anonymous access granted for %u."

    # # Write disabled in anonymous chroot
    <Directory *>
    <Limit WRITE>
    DenyAll
    </Limit>
    </Directory>

    <Directory incoming>
    Umask 022 022
    <Limit READ WRITE>
    DenyAll
    </Limit>
    <Limit STOR>
    AllowAll
    </Limit>
    </Directory>

    </Anonymous>
    ****************************