+ Responder ao Tópico



  1. #1
    Sam_bass
    Estou tentando fazer um nat usando o ipmasqadm usando o seguinte comando:

    ipmasqadm portfw -a -P tcp -L 200.xxx.xxx.xxx 8180 -R 100.100.x.x

    mesmo usando este comando o NAT não funciona, quando tento acessar o ip por essa porta dá connection refused e não tem jeito. Detalhe: desabilitei o firewall, mas deixei habilitado o IP masquerading e ainda assim nao funciona.

  2. #2
    Sam_bass
    faltou uma parte do comando:

    ipmasqadm portfw -a -P tcp -L 200.xxx.xxx.xxx 8180 -R 100.100.x.x 8180



  3. Qual seu kernel ?

  4. echo 1 > /proc/sys/net/ipv4/ip_forward

    Outra coisa, não esqueceu de colocar a regra do forward com "-j MASQ" no seu firewall ?



  5. #5
    Sam_bass
    cara só pra tu ter uma idéia... olha só o que eu fiz... queria liberar somente a porta 80 para o acesso á internet para a máquina firewall, isso já com o iptables(kernel 2.4.8)

    usei os seguintes comandos

    iptables -P INPUT REJECT
    iptables -A INPUT -p TCP --dport 80 -j ACCEPT
    iptables -A INPUT -p UDP --dport 80 -j ACCEPT

    e ainda assim náo consigo acessar a internet
    aí tentei liberar o DNS pois pensei que podia ser isso

    iptables -A INPUT -p TCP --dport 53 -j ACCEPT
    iptables -A INPUT -p UDP --dport 53 -j ACCEPT

    mas ainda assim não consigo...

    ------------------------------------------------------------

    quanto ao ipmasqadm estava usando o kernel 2.2.18
    e quanto ao mascaramento da rede e a liberação do ip_forward já tinha feito isso






Tópicos Similares

  1. Continua o problema com rota
    Por redoctober no fórum Servidores de Rede
    Respostas: 13
    Último Post: 08-11-2002, 13:04
  2. Problema com os log do Apache
    Por Good_speed no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-10-2002, 08:51
  3. Problemas com Perl
    Por adcorp no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-08-2002, 11:52
  4. Problema com o ssh pelo windows !!!
    Por embbr no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-07-2002, 18:10
  5. problemas com o IMP
    Por marlonfuchs no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-06-2002, 08:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L