Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    PedroNasc
    Caso de Sucesso: LG LW2110P com CHipset RTL8180 no CL 10

    Amigos depois de muitas tentativas sem sucesso tentando instalar
    uma LG LW2110(RTL8180) no meu CL 10 usando um pacote tar até que
    fim consegui achar um rpm que me salvou a patria:

    1 - baixei e instalai o rpm:

    http://dag.wieers.com/packages/kerne...0.dag.i386.rpm


    rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm

    ok INSTALADO (ufa com o tar dava error pra todo lado)


    2 - Baixei o Driver desse link aqui:

    ftp://202.65.194.18/cn/wlan/rtl8180l/ndis5x-8180(173).zip

    descontactei em uma pastar /driver


    3 - Carreguei o driver:

    ndiswrapper -i /driver/NET8180.INF


    4 - Rodei o comand ndiswrapper -i pra ver se o driver estava ativo e tudo blz:

    5 - Carreguei o modulo:

    modprobe ndiswrapper


    6 - cONFIGUREI A REDE


    iwconfig wlan0 essid xxx
    iwconfig wlan0 channel 10
    ifconfig wlan0 up
    ifconfig wlan0 xxx.xxx.xxx.xxx netmask 255.255.255.0
    route del default
    route add default wlan0
    route add default gw xxx.xxx.xxx.xxx


    7 - AGORA TO NAVEGANDO COM O CONECTIVA.. EHEHHEHEHHEHEHHHEHEHEHHEHE

    Abraços... a Todos...

  2. #2
    Leonardomr
    Parabéns Pedro por ter conseguido fazer a placa funcionar!!

    Estou tendo o seguinte problema. Quando executo o comando:
    'rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Aparece a seguinte mensagem logo abaixo do comando:
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag

    Quais os modulos perl preciso instalar para resolver essas dependencias?

    Grato desde já pela ajuda do amigo!



  3. #3
    doidoht
    Citação Postado originalmente por Leonardomr
    Parabéns Pedro por ter conseguido fazer a placa funcionar!!

    Estou tendo o seguinte problema. Quando executo o comando:
    'rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Aparece a seguinte mensagem logo abaixo do comando:
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag

    Quais os modulos perl preciso instalar para resolver essas dependencias?

    Grato desde já pela ajuda do amigo!
    perl(Fcntl)
    perl(strict)

  4. #4
    Leonardomr
    Certo, tudo bem!

    Onde eu encontro esses pacotes: perl(Fcntl) e perl(strict). Eu já instalei todos os modulos perl do Conectiva, e nada de resolver essas dependencias.

    Grato desde já pela ajuda dos amigos.



  5. Segui os passos do Pedro, com apenas uma pequena diferença: eu instalei o ndiswrapper através do pacote ndiswrapper-utils.rpm, através do apt-get. Instalou blz... Baixei o driver para windows da RTL8180 no site da Realtek.

    Carreguei o driver com o ndiswrapper -i NET8180.INF. Carregou blz, tanto q no comando ndiswrapper -l ele dizia q o hardware estava presente...

    Também carreguei o módulo com o modprobe ndiswrapper.... Não deu nenhum erro. O problema começa com o iwconfig... Ele diz que o device wlan0 não existe...

    Alguém tem alguma dica????

  6. Citação Postado originalmente por Leonardomr
    Parabéns Pedro por ter conseguido fazer a placa funcionar!!

    Estou tendo o seguinte problema. Quando executo o comando:
    'rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Aparece a seguinte mensagem logo abaixo do comando:
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag

    Quais os modulos perl preciso instalar para resolver essas dependencias?

    Grato desde já pela ajuda do amigo!
    ai Galera estou tendo esse mesmo problema qdo tento instalar o pacote pelo rpm ele dah esses dois erros ai descritos acima e via apt-get ele naum encontra os pacotes tem algum macete???
    valew



  7. Bem pessoal a realtek finalmente lançou o driver para o kernel 2.6 para o chipset rtl8180, eu ainda não testei, coloquei um topico no forum para saber se alguem já tinha usado, para quem se interessar o link é esse:

    http://www.realtek.com.tw/downloads/...Unix%20(Linux)

    Até mais, flw.

  8. #8
    pilantrox
    pero q si pero q no senhorrr,,, monta o cd do conectiva no linux, entra dentro da pasta onde tem os pacotes e instala tudo ou soh o que vc desejar heheh,,,,,, rpm -ivh *.rmp

    Citação Postado originalmente por douglassantos
    Citação Postado originalmente por Leonardomr
    Parabéns Pedro por ter conseguido fazer a placa funcionar!!

    Estou tendo o seguinte problema. Quando executo o comando:
    'rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Aparece a seguinte mensagem logo abaixo do comando:
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag

    Quais os modulos perl preciso instalar para resolver essas dependencias?

    Grato desde já pela ajuda do amigo!
    ai Galera estou tendo esse mesmo problema qdo tento instalar o pacote pelo rpm ele dah esses dois erros ai descritos acima e via apt-get ele naum encontra os pacotes tem algum macete???
    valew



  9. Ae garela depois de tantas tentativas consegui instalar minha Lg 2110 no CL10
    agora tah rodando que eh uma maravilha, consegui colocar com o ndiswrapper e o driver para o xp.... obrigado por tudo

    obs: essa mensagem foi postada pelo Mozilla

  10. #10
    pilantrox
    Me desculpem ,, mas eh que no inicio do Tópico o rolo era com CONECTIVA ,,,,,,, mas a intenção foi de ajudar ...

    Citação Postado originalmente por douglassantos
    Ae garela depois de tantas tentativas consegui instalar minha Lg 2110 no CL10
    agora tah rodando que eh uma maravilha, consegui colocar com o ndiswrapper e o driver para o xp.... obrigado por tudo

    obs: essa mensagem foi postada pelo Mozilla



  11. #11
    Quando tento instalar o pacote do ndiswrapper da o seguinte erro

    baixei o arquivo ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm porem quando tento instala-lo da o seguinte erro:

    [root@crs clecio]# rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    [root@crs clecio]#


    tentei tambem pelo aptget-install e tambem deu erro

    [root@crs clecio]# apt-get install ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando ndiswrapper-utils para 'ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Alguns pacotes não puderam ser instalados. Isso pode significar que
    você solicitou uma situação impossível ou se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram tirados do Incoming.

    Já que você solicitou uma única operação é extremamente provável que
    o pacote esteja simplesmente não instalável e um relato de erro sobre
    esse pacote deve ser enviado.
    A seguinte informação pode ajudar a resolver a situação:

    Os seguintes pacotes têm dependências não resolvidas:

    Como posso resolver essas pendêcias de pacotes.

    Grato

    Clecio Rodrigo
    Iniciante em Linux
    ndiswrapper-utils: Depende: perl(Fcntl) mas este não é instalável
    Depende: perl(strict) mas este não é instalável
    E: Pacotes quebrados
    [root@crs clecio]#

  12. #12
    Me desculpem pelo erro acima

    Quando tento instalar o pacote do ndiswrapper da o seguinte erro

    baixei o arquivo ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm porem quando tento instala-lo da o seguinte erro:

    [root@crs clecio]# rpm -ivh ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    erro: Failed dependencies:
    perl(Fcntl) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    perl(strict) is needed by ndiswrapper-utils-0.6-3.rh90.dag
    [root@crs clecio]#


    tentei tambem pelo aptget-install e tambem deu erro

    [root@crs clecio]# apt-get install ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando ndiswrapper-utils para 'ndiswrapper-utils-0.6-3.rh90.dag.i386.rpm'
    Alguns pacotes não puderam ser instalados. Isso pode significar que
    você solicitou uma situação impossível ou se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram tirados do Incoming.

    Já que você solicitou uma única operação é extremamente provável que
    o pacote esteja simplesmente não instalável e um relato de erro sobre
    esse pacote deve ser enviado.
    A seguinte informação pode ajudar a resolver a situação:

    Os seguintes pacotes têm dependências não resolvidas:
    ndiswrapper-utils: Depende: perl(Fcntl) mas este não é instalável
    Depende: perl(strict) mas este não é instalável
    E: Pacotes quebrados
    [root@crs clecio]#

    Como posso resolver essas pendêcias de pacotes.

    Grato

    Clecio Rodrigo
    Iniciante em Linux



  13. Instalação do Ndiswrapper no CL10:

    baixe a ultima versão do Ndiswrapper do site oficial no momento é esse aqui:
    http://easynews.dl.sourceforge.net/s...per-1.1.tar.gz,
    pegue a ultima versão do driver ndis do windows no site da realtek, no momento esse aqui:
    http://152.104.125.9/cn/wlan/rtl8180...-8180(173).zip,
    de posse dos dois, instale o kernel-headers e o kernel-source no seu CL10(se já não estiverem instalados) e para completar entre em /usr/src/linux e dê um make menuconfig e quando abrir a tela de configuração do kernel, desmarque e marque novamente a opção loadable module support(atenção faça apenas isso), dai é só sair do menu de configuração e quando ele pedir para salvar o arquivo de configuração salve!(motivo desse ultimo passo é q esse arquivo de configuração não vem instalado por padrão no CL10 e ele é necessario para a instalção do ndiswrapper), feito esse passos é só descompactar o ndiswrapper que vc baixou e digitar dentro da pasta dele make install(atenção não precisa o make antes, é só make install direto) e por ultimo(ufa).... descompacte o driver ndis do windows em uma pasta qualquer e adicione ele no ndiswrapper com o comando ndiswrapper -i(Ex: ndiswrapper -i /root/ndis/NET8180.INF), com isso é só dar um modprobe ndiswrapper e configurar sua placa wireless normalmente com o iwconfig.....(ufa de novo), só isso.

    Flw.

    PS: Virou um tutorial, hehe.

  14. tentei fazer da forma que falou e não deu muito certo, poderia em ajudar com este erro

    [root@crs root]# cd /usr/src/linux
    [root@crs linux]# make menuconfig
    HOSTCC scripts/basic/fixdep
    /bin/sh: line 1: gcc: command not found
    make[1]: ** [scripts/basic/fixdep] Erro 127
    make: ** [scripts_basic] Erro 2
    [root@crs linux]#

    Grato

    Clecio Rodrigo
    Inciante em Linux

  15. Citação Postado originalmente por cleciorodrigo
    tentei fazer da forma que falou e não deu muito certo, poderia em ajudar com este erro

    [root@crs root]# cd /usr/src/linux
    [root@crs linux]# make menuconfig
    HOSTCC scripts/basic/fixdep
    /bin/sh: line 1: gcc: command not found
    make[1]: ** [scripts/basic/fixdep] Erro 127
    make: ** [scripts_basic] Erro 2
    [root@crs linux]#

    Grato

    Clecio Rodrigo
    Inciante em Linux
    Well...... faz esses 2 passos:
    - apt-get install gcc
    - apt-get install task-c++-devel

    isso ai vai instalar os compiladores, não estão instalados no seu sistema.

    Flw.

  16. #16
    Olha eu aqui novamente enchendo o saco, mais to tentando e posso dizer que mesmo sem a placa esta funcionando estou aprendendo bastante de tanto tenta, por isso quero agradecer aqueles perdem seu tempo ajudando os que estão iniciando nesta nova jornada no universo LINUX.

    Pessoal estou tentando fazer tudo novamente desde o inicio porem estou tendo os seguintes problemas:

    #AO TENTAR INSTALAR O KERNEL-HEADERS
    [root@crs root]# apt-get install kernel-headers
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    E: Não foi possível encontrar o pacote kernel-headers
    [root@crs root]#

    #AO TENTAR INSTALAR O KERNEL-SOURCES
    [root@crs root]# apt-get install kernel-sources
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    E: Não foi possível encontrar o pacote kernel-sources
    [root@crs root]#

    #SUCESSO AO INSTALAR O GCC
    [root@crs root]# apt-get install gcc
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando libgcc para 'gcc'
    libgcc já está na versão mais nova.
    0 atualizados, 0 novos instalados, 0 removidos e 243 não atualizados.
    [root@crs root]#

    #AO TENTAR INSTALAR O TASK-C++-DEVEL
    [root@crs root]# apt-get install task-c++-devel
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    E: Não foi possível encontrar o pacote task-c++-devel
    [root@crs root]#

    no arquivo sources.list ja tentei de tudo, e não tive sucesso.
    Pelo cds consegui instalar o kernel-sources, o gcc, so que o kernel-headers eo task-c++-devel não tive sucesso.

    Alguma dica de como fazer pra instalar esses pacotes.

    Grato a todos

    Clecio Rodrigo
    Iniciante em Linux

  17. #17
    Olha eu aqui novamente enchendo o saco, mais to tentando e posso dizer que mesmo sem a placa esta funcionando estou aprendendo bastante de tanto tenta, por isso quero agradecer aqueles perdem seu tempo ajudando os que estão iniciando nesta nova jornada no universo LINUX.

    Pessoal estou tentando fazer tudo novamente desde o inicio porem estou tendo os seguintes problemas:

    #AO TENTAR INSTALAR O KERNEL-HEADERS
    [root@crs root]# apt-get install kernel-headers
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    E: Não foi possível encontrar o pacote kernel-headers
    [root@crs root]#

    #AO TENTAR INSTALAR O KERNEL-SOURCES
    [root@crs root]# apt-get install kernel-sources
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    E: Não foi possível encontrar o pacote kernel-sources
    [root@crs root]#

    #SUCESSO AO INSTALAR O GCC
    [root@crs root]# apt-get install gcc
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando libgcc para 'gcc'
    libgcc já está na versão mais nova.
    0 atualizados, 0 novos instalados, 0 removidos e 243 não atualizados.
    [root@crs root]#

    #AO TENTAR INSTALAR O TASK-C++-DEVEL
    [root@crs root]# apt-get install task-c++-devel
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    E: Não foi possível encontrar o pacote task-c++-devel
    [root@crs root]#

    no arquivo sources.list ja tentei de tudo, e não tive sucesso.
    Pelo cds consegui instalar o kernel-sources, o gcc, so que o kernel-headers eo task-c++-devel não tive sucesso.

    Alguma dica de como fazer pra instalar esses pacotes.

    Grato a todos

    Clecio Rodrigo
    Iniciante em Linux

  18. Verifique se o seu sources.list está assim:
    Código :
    # Package repository URLs
    #
    # Make sure to use appropriate repositories for your own distribution.
    #
    # Signed repositories have a [cncbr]. If you remove it, no digital
    # signature check will be made!
    #
    # Notice that "all" is a meta-component, including every other
    # component available. If you want, you can customize your
    # component selection. At that time, the following components
    # are available:
    #
    #       audio cross database devel doctools experimental
    #       extra games gnome kde main printer wmaker
    #
    # Official Conectiva Linux 10 package repositories.
    # If these are busy, please use a mirror near you.
    #
    # Updated list of Conectiva mirrors:
    # https://moin.conectiva.com.br/mirrors
    #
    rpm cdrom:[Conectiva Linux 10 CD 3]/ conectiva 003
    rpm cdrom:[Conectiva Linux 10 CD 2]/ conectiva 002
    rpm cdrom:[Conectiva Linux 10 CD 1]/ conectiva 001
    rpm [cncbr] ftp://ftp.conectiva.com/pub/conectiva 10/i386 all
    rpm-src [cncbr] ftp://ftp.conectiva.com/pub/conectiva 10/i386 all
     
    # Updates have their own repository.
    rpm [cncbr] ftp://atualizacoes.conectiva.com.br 10/i386 updates
    rpm-src [cncbr] ftp://atualizacoes.conectiva.com.br 10/i386 updates
     
    # Conectiva Mirrors
    # Since less people use them, they are faster...
     
    # For a complete and up-to-date list, see https://moin.conectiva.com.br/mirrors
     
    # Unicamp.br
    #rpm [cncbr] ftp://ftp.unicamp.br/pub/conectiva 10/i386 main extra kde gnome games
    #rpm-src [cncbr] ftp://ftp.unicamp.br/pub/conectiva 10/i386 main extra kde gnome games
    #rpm [cncbr] ftp://ftp.unicamp.br/pub/conectiva/atualizacoes 10/i386 updates

    Caso não estejá deixe desse jeito ai que dá certo a instalação desses pacotes.

    Flw.

  19. Bom dia, pessoal to quase la agora sei que falta pouco pra minha placa LG 2210P com chip RTL 8180 rodar no Linux CL 10, já consegui instala o ndiswrapper já instalei o NET8180.INF, so que agora quando executo modeprobe nediswrapper é exibido o seguinte erro

    [root@wireless ndiswrapper-1.1]# modeprobe ndiswrapper
    bash: modeprobe: command not found
    [root@wireless ndiswrapper-1.1]#

    como posso solucionar este problema??
    tentei instalar o modprobe, não sei se estive certo mais tambem não deu

    [root@wireless etc]# apt-get install mo*
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    E: Não foi possível encontrar o pacote modprobe.conf
    [root@wireless etc]#

    mais o arquivo modprobe.conf esta dentro de /etc

    Abraços

    Clecio Rodrigo
    Inciante em Linux

  20. Pessoal estou tendo este erro ao tentar executar o modprobe

    [root@wireless root]# modprobe ndiswrapper
    FATAL: Error inserting ndiswrapper (/lib/modules/2.6.5-63077cl/misc/ndiswrapper.ko): Invalid module format
    [root@wireless root]#


    Grato a todos

    Clecio Rodrigo
    Iniciante em Linux






Tópicos Similares

  1. Respostas: 8
    Último Post: 08-09-2011, 19:47
  2. Caso de Sucesso Com Wavion Wbs 2400
    Por Jluminato no fórum Redes
    Respostas: 88
    Último Post: 31-10-2010, 06:37
  3. Respostas: 4
    Último Post: 20-06-2009, 20:54
  4. Problema com o chipset RTL8180 no Rwindows
    Por leofsouza no fórum Redes
    Respostas: 1
    Último Post: 23-10-2004, 08:20
  5. Dependencia de pacote na instalacao do Kylix 3 no CL 10
    Por RicardoVS no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-07-2004, 14:32

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L