+ Responder ao Tópico



  1. E ai galera blzinha ?
    Uso slackware 10.0
    Seguinte to configurando bind na minha makina aki em casa pra testar o servidore de nome , vai ai umas informacoes da maqui e depois os arquivos de configuracao:
    bash-2.05b# hostname
    server
    bash-2.05b# hostname -d
    slack.inc
    O ip da maquinha aqui e' 10.0.0.100 e nele roda server de ftp e www

    O meu named.conf ficou assim:
    options {
    directory "/var/named";
    minimal-responses yes;
    allow-transfer {10.0.0.100};
    listen-on {127.0.0.1; 10.0.0.100};
    allow-recursion {127.0.0.1; localhost; 10.0.0.0/24;};
    };

    zone "." IN {
    type hint;
    file "caching-example/named.ca";
    };

    zone "localhost" IN {
    type master;
    file "caching-example/localhost.zone";
    allow-update { none; };
    };
    zone "0.0.127.in-addr.arpa" IN {
    type master;
    file "caching-example/named.local";
    allow-update { none; };
    };
    zone "0.0.0.10.in-addr.arpa" IN {
    type master;
    file "caching-example/domaind.rev";
    allow-transfer { 10.0.0.100; };
    };
    zone "server.slack.inc" IN {
    type master;
    file "caching-example/server.host";
    allow-transfer { 10.0.0.100; };
    };

    Agroa vou coloakar os arquvos domain.rev e server.host

    domain.rev ------------------------------
    $TTL 86400
    $ORIGIN server.slack.inc.
    0.0.10.in-addr.arpa IN SOA server.slack.inc. root.server.slack.inc. (
    2004101901 ; Serial de sincronização
    3H ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum

    NS dns.server.slack.inc.

    100 IN PTR ftp
    100 IN PTR www
    100 IN PTR dns2
    100 IN PTR smtp


    Agora o server.host ---------------------------
    $TTL 86400

    @ IN SOA server.slack.inc. root.server.slack.inc. (
    2004101901 ;Serial de sincronização
    3H ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum

    NS dns.server.slack.inc.
    IN MX 10 server.slack.inc.

    localhost IN A 127.0.0.1
    server.slack.inc. IN A 10.0.0.100
    dns IN A 10.0.0.100
    dns2 IN A 10.0.0.100
    www IN A 10.0.0.100
    ftp IN A 10.0.0.100
    mail IN CNAME server.slack.inc.
    pop IN CNAME server.slack.inc.
    router IN A 10.0.0.138

    Certo tudo configurado .. apos reiniciar o bind eu dou um
    host 10.0.0.100 pra ver se deu certo e ele da a seguinte mensagem:
    bash-2.05b# host 10.0.0.100
    Host 100.0.0.10.in-addr.arpa not found: 3(NXDOMAIN)

    E quando dou host server.slack.inc
    bash-2.05b# host server.slack.inc
    Host server.slack.inc not found: 3(NXDOMAIN)

    O que esta errado ? tem alguma outra configuracao ke eu eskeci ??

    Abracos

    Carlos Augusto Malucelli

  2. #2
    Super_Diaulas
    zone "0.0.0.10.in-addr.arpa" IN {
    Tenta retirar o 1.º zero do reverso.~..talvez funcione

    verifique tb o arquivo do reverso....post aí oq tem nele






Tópicos Similares

  1. BIND não acha o IP novo
    Por rafaelpazcolles no fórum Servidores de Rede
    Respostas: 0
    Último Post: 07-06-2005, 09:00
  2. BIND não inicia no Conectiva 10
    Por dogmatico no fórum Servidores de Rede
    Respostas: 8
    Último Post: 17-05-2005, 10:58
  3. Bind Não funciona
    Por marcosgw no fórum Servidores de Rede
    Respostas: 10
    Último Post: 04-03-2005, 08:17
  4. BIND não resolve
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 0
    Último Post: 21-07-2004, 11:54
  5. BIND não aceita conexões
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 02-01-2003, 09:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L