Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    mrpicolo
    :? Ja fiz um monte de alterações mas nada funciona... estou usando 2 placas de rede e a saida de internet é eth1 a da rede local é eth0... condigurei nos clientes o seguinte:
    gateway: ip da placa de rede com saída pra internet
    dns: os dois passados pelo provedor

    se eu naum startar o squid naum funciona a internet e nem o outlook se eu startar funciona só a internet....

    olha só o meu firewall como esta:

    # Firewall
    # Carrega os módulos
    modprobe ip_tables
    modprobe iptable_nat

    #Compartilha a conexão
    modprobe iptable_nat
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward

    #Liberar respostas de servidores www para o meu squid
    iptables -A INPUT -p TCP -i ppp0 --sport 80 -j ACCEPT
    iptables -A INPUT -p TCP -i ppp0 --sport 443 -j ACCEPT
    iptables -A INPUT -p TCP -i ppp0 --sport 20 -j ACCEPT
    iptables -A INPUT -p TCP -i ppp0 --sport 21 -j ACCEPT
    iptables -A INPUT -p UDP -i ppp0 --sport 21 -j ACCEPT

    #Bloquear tudo
    iptables -A INPUT -p tcp --dport 3128 -j REJECT --reject-with tcp-reset
    iptables -A INPUT -j LOG --log-prefix "Pacote input descartado: "
    iptables -A INPUT -j DROP

    #Descartar pacotes inválidos
    iptables -A FORWARD -m state --state INVALID -j DROP
    #Aceitar conexões estabilizadas
    iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT

    #Liberar respostas aos servidores de nome
    iptables -A FORWARD -p udp -s 192.168.143.0/255.255.255.0 -d 200.204.0.10 --dport 53 -j ACCEPT
    iptables -A FORWARD -p udp -s 192.168.143.0/255.255.255.0 -d 200.204.0.138 --dport 53 -j ACCEPT
    iptables -A FORWARD -p udp -s 200.204.0.10 --sport 53 -d 192.168.143.0/255.255.255.0 -j ACCEPT
    iptables -A FORWARD -p udp -s 200.204.0.138 --sport 53 -d 192.168.143.0/255.255.255.0 -j ACCEPT

    #Outlook
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 25 -j ACCEPT
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 25 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 21 -j ACCEPT

    #Bloqueando e gerando log
    iptables -A FORWARD -j LOG --log-prefix "Pacote forward descartado: "
    iptables -A FORWARD -j DROP

    #Abre algumas portas
    iptables -A INPUT -p tcp --destination-port 25 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 110 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 143 -j ACCEPT

    #Abre para rede local
    iptables -A INPUT -p tcp --syn -s 192.168.143.0/255.255.255.0 -j ACCEPT

    #Fecha o resto
    iptables -A INPUT -p tcp --syn -j DROP

  2. Cara o gateway das estaçoes e o ip da placa de rede interna!!!

    Tente usar assim o seu script


    # Carrega os módulos
    modprobe iptables
    modprobe iptable_nat

    #Abre algumas portas
    iptables -A INPUT -p tcp --destination-port 25 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 110 -j ACCEPT
    iptables -A INPUT -p tcp --destination-port 143 -j ACCEPT

    #Compartilha a conexão
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward

    #Abre para rede local
    iptables -A INPUT -p tcp --syn -s 192.168.143.0/255.255.255.0 -j ACCEPT

    #Fecha o resto
    iptables -A INPUT -p tcp --syn -j DROP


    Qualquer coisa posta ai !!!



  3. #3
    mrpicolo
    e ai blz? eu fiz exatamente como vc falou... mas naum consigo acessar a internet nos clientes sem startar o squid.... no servidor após conectar a inernet (adsl-start) eu uso o seguinte comando:

    route del -net 0.0.0.0
    route add -net 0.0.0.0/0 dev ppp0
    route del default
    route add default ppp0

    se eu naum usar isso naum consigo acessar site algum... mesmo com o squid startado... isso pode influenciar em algo?

    e outra coisa, no servidor eu consigo pingar pop.jnd.terra.com.br p é o pop do terra, mas nos clientes o outlook naum funfa.....

  4. #4
    dispatcher
    mrpicolo , só uma perguntinha:
    pra que vc esta usando a faixa de enderecos 90.0.0.0 nestas regras?

    #Outlook
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 25 -j ACCEPT
    iptables -A FORWARD -p TCP -s 90.0.0.0/255.255.255.0 --dport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 25 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --sport 21 -j ACCEPT



  5. #5
    mrpicolo
    eu num tinha visto... mas corrigi e mesmo assim naum funcionou...






Tópicos Similares

  1. Meu squid não ta funcionando
    Por ThiagoOverseer no fórum Servidores de Rede
    Respostas: 41
    Último Post: 29-01-2007, 14:22
  2. meu HTTP naum aceita caracteres especiais
    Por Germano_Silva no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-02-2004, 10:17
  3. Meu SMTP do Qmail não esta funcionando Rede Externa!!!!
    Por maiconovic no fórum Servidores de Rede
    Respostas: 3
    Último Post: 18-10-2003, 09:08
  4. meu relay naum funciona
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 01-04-2003, 18:36
  5. Meu problema continua
    Por MrEdu no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 14:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L