Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    whinston
    Pessoal, tava seguindo o tutorial do OpenLDAP (https://under-linux.org/modules.php?...ticle&artid=35) e na hora do configure deu 1 errinho q não faço a mínima idéia de como resolver! To usando Fedora Core1

    checking for Berkeley DB link (-ldb-42)... no
    checking for Berkeley DB link (-ldb-4.2)... no
    checking for Berkeley DB link (-ldb-4-2)... no
    checking for Berkeley DB link (-ldb-4)... no
    checking for Berkeley DB link (-ldb4)... no
    checking for Berkeley DB link (-ldb)... yes
    checking for Berkeley DB version match... yes
    checking for Berkeley DB thread support... yes
    checking Berkeley DB version for BDB backend... no
    configure: error: BDB/HDB: BerkeleyDB version incompatible

  2. #2
    karfax
    Não faz sentido voce compilar um aplicativo para o qual já existe um rpm pronto para sua distro sem conflitos com a versão da db existente no seu sistema. Se vc usa apt no Fedora1, faça:
    apt-get install openldap, etc. Em meu sistema encontro:
    rpm -qa | grep ldap
    openldap-2.1.22-8
    nss_ldap-207-6
    openldap-devel-2.1.22-8
    rpm -qa | grep ssl
    docbook-style-dsssl-1.78-2
    mod_ssl-2.0.50-1.0
    openssl-0.9.7a-33.10
    openssl-devel-0.9.7a-33.10

    HTH,



  3. #3
    Citação Postado originalmente por whinston
    Pessoal, tava seguindo o tutorial do OpenLDAP (https://under-linux.org/modules.php?...ticle&artid=35) e na hora do configure deu 1 errinho q não faço a mínima idéia de como resolver! To usando Fedora Core1

    checking for Berkeley DB link (-ldb-42)... no
    checking for Berkeley DB link (-ldb-4.2)... no
    checking for Berkeley DB link (-ldb-4-2)... no
    checking for Berkeley DB link (-ldb-4)... no
    checking for Berkeley DB link (-ldb4)... no
    checking for Berkeley DB link (-ldb)... yes
    checking for Berkeley DB version match... yes
    checking for Berkeley DB thread support... yes
    checking Berkeley DB version for BDB backend... no
    configure: error: BDB/HDB: BerkeleyDB version incompatible

  4. #4
    Citação Postado originalmente por whinston
    Pessoal, tava seguindo o tutorial do OpenLDAP (https://under-linux.org/modules.php?...ticle&artid=35) e na hora do configure deu 1 errinho q não faço a mínima idéia de como resolver! To usando Fedora Core1

    checking for Berkeley DB link (-ldb-42)... no
    checking for Berkeley DB link (-ldb-4.2)... no
    checking for Berkeley DB link (-ldb-4-2)... no
    checking for Berkeley DB link (-ldb-4)... no
    checking for Berkeley DB link (-ldb4)... no
    checking for Berkeley DB link (-ldb)... yes
    checking for Berkeley DB version match... yes
    checking for Berkeley DB thread support... yes
    checking Berkeley DB version for BDB backend... no
    configure: error: BDB/HDB: BerkeleyDB version incompatible



  5. #5
    alvaro_rs
    Tive esse problema no RED HAT 9

    Uma das exigências do openldap-2.2.23 é o BerkeleyDB mais novo, pois o que vem com a Distro não funcionou por ser uma versão mais antiga eu acho.

    Aí eu baixei a última versão do Berkeley DB e compilei e instalei ela até tudo blz mas o mesmo erro que vc se refere ocorreu na hora do ./configure do openldap-2.2.23.

    Bom começei a fazer algumas tentativas e consegui resolver esse problema criando um link simbólico para a versão mais nova da biblioteca do Berkeley DB:

    Criei o Seguinte Link no /usr/lib

    Código :
    ln -s /usr/local/BerkeleyDB.4.3/lib/libdb-4.3.so libdb-4.3.so

    Pronto aí rodei o ./configure do openldap-2.2.23 e foi

    Código :
    checking for db.h... yes
    checking for Berkeley DB link (default)... no
    checking for Berkeley DB link (-ldb43)... no
    checking for Berkeley DB link (-ldb-43)... no
    checking for Berkeley DB link (-ldb-4.3)... yes
    checking for Berkeley DB version match... yes
    checking for Berkeley DB thread support... yes
    checking Berkeley DB version for BDB backend... yes


    até trancar no seguinte erro:

    Código :
    checking Cyrus SASL library version... no
    configure: error: Cyrus SASL library located but is incompatible

    Mas aí estou trabalhando em cima desse problema agora, mas se tiver alguma sugestão tb só postar.

    Espero ter contribuído.

    :wink:






Visite: BR-Linux ·  VivaOLinux ·  Dicas-L