+ Responder ao Tópico



  1. Galera to tentando instalar o Mon no meu slack10 e estou tendo problemas.

    Ja li a documentacao do Mon (README, INSTALL);
    Ja instalei os seguintes modulo perl:

    Time::Period
    Time::HiRes
    Convert::BER



    Para instalar todos os modulos fiz:

    tar zxvf modulo.tar.gz
    cd Modulo/
    perl Makefile.PL
    make
    make install
    make realclean


    Depois fui para a instalacao do Mon:

    Copiei o arquivo de configuracao:
    cp etc/example.cf mon.cf

    Adicionei no /etc/services:
    mon 2583/tcp # MON
    mon 2583/udp # MON traps

    Depois tentei:

    ./mon -f -M -c mon.m4 -b `pwd`

    E apareceu a seguinte msg de erro:

    Can't locate Mon/SNMP.pm in @INC (@INC contains: /usr/lib/perl5/5.8.4/i486-linux /usr/lib/perl5/5.8.4 /usr/lib/perl5/site_perl/5.8.4/i486-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl .) at ./mon line 51.
    BEGIN failed--compilation aborted at ./mon line 51.

    Dessa msg eu entendo que ele está precisando do modulo SNMP.pm, entao fiz o download do site CPAN desse modulo e copiei para:

    cp SNMP.pm /usr/lib/perl5/5.8.4/i486-linux
    cp SNMP.pm /usr/lib/perl5/5.8.4
    cp SNMP.pm /usr/lib/perl5/site_perl/5.8.4/i486-linux
    cp SNMP.pm /usr/lib/perl5/site_perl/5.8.4
    cp SNMP.pm /usr/lib/perl5/site_perl

    Mesmo assim apareceu e mesma msg.

    Em fim.. vcs estao vendo que eu estou "um pouco" enrolado e estou precisando de ajuda..

    O que eu tenho que fazer, o que eu tenho que ter instalado para colocar o Mon para rodar?


    abraços,

    []'
    Danilo
    Linux User #313166
    Slackware "Keep It Simple and Stupid"

  2. É ninguem me responde.. entao é o seguinte, depois de muito tentar instalar o Mon fazer o meu squid parar de funcionar depois que eu instalalei umas coisas que o INSTALL do Mon mandava instalar ops:

    Fiz de tudo e o troço nao voltou a funcionar, entao, solucao? Backup e voltamos ao zero!!

    Entao estou na seguinte situacao: slackware 10 recem instalado, somente, vou tentar instalar só o Mon, pois da outra vez eu tentei colocar primeiro o HeartBeat..

    Vou tentar e se nao conseguir posto aqui o erro!! :lol:



  3. #3
    Filipa_Nelia
    Oi,
    tb tava c o mm problema, por isso fui buscar o ficheiro, como tu, e dp criei uma pasta Mon dentro da directoria onde tou a trabalhar e coloquei lá dentro o ficheiro SNMP.pm e já funciona. Experimenta!!!!

  4. Tentarei.. qualquer coisa te falo...

    valeu






Tópicos Similares

  1. instalacao do CubePanel no Slackware duvida !!
    Por slackrio no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-09-2006, 11:34
  2. duvida na instalacao do slack 10
    Por bouncer no fórum Servidores de Rede
    Respostas: 2
    Último Post: 01-08-2004, 19:32
  3. Dúvidas nas conf do httpd.conf - Slackware 9
    Por Wal no fórum Servidores de Rede
    Respostas: 4
    Último Post: 31-03-2004, 20:17
  4. Dúvida na instalação do Lilo no Slack9.1
    Por luccosta no fórum Servidores de Rede
    Respostas: 3
    Último Post: 25-03-2004, 12:13
  5. instalação do Licq no Slackware..problemas
    Por Vaza no fórum Servidores de Rede
    Respostas: 9
    Último Post: 15-11-2003, 18:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L