+ Responder ao Tópico



  1. #1

    Padrão Olá, dúvidas e meu primeiro post no fórum. :)

    Olá pessoal, beleza?
    Me chamo Alex e estou estudando na faculdade UNIABEU de Nilópolis. Achei esse lugar graças ao meu professor de sistemas de computação 2 que é um grande fã de Linux. ^^

    Bom, tipo, queria dizer que vocês podem contar comigo para o que precisarem e eu sei que tenho muito que aprender sobre o sistema. Sou um extremo n00ba no sistema, não sei absolutamente nada, apenas tenho os conceitos básicos de S.O.

    Bom, as minhas primeiras dúvidas são:

    1. Que distro teria essas qualidades?
    - Dedicada à desenvolvimento em qualquer linguagem (Pascal, C, php, etc)... em outras palavras com os programas se possível pré-instalados na máquina.
    - Fácil de se atualizar. Uma vez eu usei o Kalango Linux e fiz a atualização completa usando o: apt-get upgrade e esperei um bom tempo pra baixar 300 MB... quando terminou o upgrade, o sistema não funcionava mais como antes... não conseguia conectar a internet (Velox), não conseguia usar o login automático, o painel de controle do Kalango não funcionava e outras coisas mais.
    - Possua suporte ao seguinte hardware, e se não tiver, descobrir como adicionar o suporte:

    Minha placa-mãe é uma PC-Chips M825G, c/
    - VIA S3 UniChrome IGP (aceleradora 3D on-board)
    - VIA AC' 97 Codec Driver (ou C-Media)
    - VIA Rhine II Fast Adapter (Rede)
    - VIA HSP56 Modem (PCTel, Modem)

    Eu ouvi dizer que para adicionar drivers no Linux não é tão fácil quanto no Windows e que é necessário recompilar o Kernel e fazer uma série de mudanças também... é verdade?

    Valeu gente e obrigado pelas infos. \o
    Vou fazer todo o possível para ajudar o pessoal da forma que posso, apesar de não saber nada do S.O. ^^''

  2. #2

    Padrão Re: Olá, dúvidas e meu primeiro post no fórum. :)

    Ola, seja bem vindo
    Citação Postado originalmente por Bit
    - Dedicada à desenvolvimento em qualquer linguagem (Pascal, C, php, etc)... em outras palavras com os programas se possível pré-instalados na máquina.
    QQ distro....soh depende dos pacotes q instala...tipo Kdevelop, Quanta, eclipse, e por ai vai

    Citação Postado originalmente por Bit
    - Fácil de se atualizar. Uma vez eu usei o Kalango Linux e fiz a atualização completa usando o: apt-get upgrade e esperei um bom tempo pra baixar 300 MB... quando terminou o upgrade, o sistema não funcionava mais como antes... não conseguia conectar a internet (Velox), não conseguia usar o login automático, o painel de controle do Kalango não funcionava e outras coisas mais.
    baum....ai eu ja nao sei....eu sempre instalo pacotes pelo fonte

    Citação Postado originalmente por Bit
    - Possua suporte ao seguinte hardware, e se não tiver, descobrir como adicionar o suporte:

    Minha placa-mãe é uma PC-Chips M825G, c/
    - VIA S3 UniChrome IGP (aceleradora 3D on-board)
    - VIA AC' 97 Codec Driver (ou C-Media)
    - VIA Rhine II Fast Adapter (Rede)
    - VIA HSP56 Modem (PCTel, Modem)
    Acredito q qq distro tbm resolva....soh q nao esquece de baixar a versao mais nova da que vc escolher

    Citação Postado originalmente por Bit
    Eu ouvi dizer que para adicionar drivers no Linux não é tão fácil quanto no Windows e que é necessário recompilar o Kernel e fazer uma série de mudanças também... é verdade?
    Acredito que nao....pq eu ja instalei o driver da Nvidia e foi tranquilo...soh tive q dar um ./arquivoqnaolembroonome e ele foi me perguntando os bagulho e instalando

    Citação Postado originalmente por Bit
    Valeu gente e obrigado pelas infos. \o
    Vou fazer todo o possível para ajudar o pessoal da forma que posso, apesar de não saber nada do S.O. ^^''
    Toda ajuda eh bem vinda :wink:



  3. #3

    Padrão Olá, dúvidas e meu primeiro post no fórum. :)

    Existem diversas distros que fazem atualização automatica, todas as conhecidas atualmente consegue fazer, debian, slack, SuSE, conectiva, Kurumin, Fedora.
    Quanto a ter de recompilar o kernel para instalar o driver depende, as distribuiçoes que citei vem com as maiorias dos drivers(modulos) marcadas como modulo, ae se prescisar eh so carregar, mas se nao tiver nem marcada como modulo, nem como obrigatorio, tem sim de recompilar o kernel para adicionar esse modulo na lista.

    O resto eh como o amigo ae falou

    falows

    PS: lembre que ao atualizar via apt-get geralmente tem dois tipos de servidores de atualização um estavel e outro instavel, provavelmente atualizou o seu para a versao instavel por isso gerou os problemas.

  4. #4

    Padrão Olá, dúvidas e meu primeiro post no fórum. :)

    Hum... certo então.
    Baixei o Kurumin aqui e vou ver se consigo instalá-lo na minha máquina.

    Com relação ao servidor do apt-get onde baixa os pacotes estáveis e instáveis, como faço para escolher de onde baixar?

    Valeu galera. \o/



  5. #5

    Padrão Olá, dúvidas e meu primeiro post no fórum. :)

    Citação Postado originalmente por Bit
    Hum... certo então.
    Baixei o Kurumin aqui e vou ver se consigo instalá-lo na minha máquina.

    Com relação ao servidor do apt-get onde baixa os pacotes estáveis e instáveis, como faço para escolher de onde baixar?

    Valeu galera. \o/
    edita o /etc/apt/source.list
    la vai ter os servidores
    falows

  6. #6

    Padrão Olá, dúvidas e meu primeiro post no fórum. :)

    Citação Postado originalmente por ruyneto
    Citação Postado originalmente por Bit
    Hum... certo então.
    Baixei o Kurumin aqui e vou ver se consigo instalá-lo na minha máquina.

    Com relação ao servidor do apt-get onde baixa os pacotes estáveis e instáveis, como faço para escolher de onde baixar?

    Valeu galera. \o/
    edita o /etc/apt/source.list
    la vai ter os servidores
    falows
    Beleza, eu fiz as alterações no arquivo conforme descrito no Kurumin Linux Painel de Controle.

    Valeu pela dica.



  7. #7
    MasterMan
    Visitante

    Padrão Olá, dúvidas e meu primeiro post no fórum. :)

    Olá, grande amigo e companheiro de morgação
    Seguinte, eu só mexo no meu source.list para adicionar programas que já não tem lá por default.
    Para instalar um pacote instável, basta usar o comando # apt-get install programa -t unstable

  8. #8

    Padrão Olá, dúvidas e meu primeiro post no fórum. :)

    Aê, grande MasterMan. ^^
    Seja bem vindo. \o/

    Valeu pela dica, mas na verdade o que eu queria saber era como instalar apenas os pacotes estáveis. ^^