+ Responder ao Tópico



  1. #1

    Padrão Apaguei o /etc

    Eai Galera..

    Aconteceu um problema sério..
    sem querer foi apagado o /etc
    o servidor ta trabalhando só com o que ta rodando..

    bom.. mas to logado na maquina ainda..
    foi dado o comando rm -Rf /etc

    Me digam por favor que existe uma forma de restaurar..

    Valeu.. :? 8O

  2. #2
    Visitante

    Padrão Apaguei o /etc

    que eu saiba nao, ou talvez se eu estiver errado é muito dificil.
    backup ?



  3. #3

    Padrão Apaguei o /etc

    Nada.. era uma das maquinas que segurava o Backup das outras..
    mas ainda continua logado nela.. porem.. o etc ta limpo

    mto foda :cry:

  4. #4
    slice
    Visitante

    Padrão Apaguei o /etc

    Citação Postado originalmente por budairc
    Nada.. era uma das maquinas que segurava o Backup das outras..
    mas ainda continua logado nela.. porem.. o etc ta limpo

    mto foda :cry:
    coloque o cd da sua distro e instale novamente o /etc...

    se for slack, é mais fácil
    wget http://www.slackware.at/data/slackwa...1-noarch-9.tgz
    installpkg etc-5.1-noarch-9.tgz

    daí vc só vai ter que reconfigurar tudo de novo, o que já é mais fácil que uma pane geral...

    se vc tiver backup, basta restaurar o backup das suas configurações e blz!

    PS.: não se esqueça de atualizar o teu lilo e tua fstab

    []´s

    Slice



  5. #5

    Padrão Apaguei o /etc

    cara... ontem apaguei umas fotos que eu tinha acidentalmente, num micro com linux, aí procurei no google e encontrei um programinha pra windows que recuperava dados em prtições linux, e recuperei.. mas só funciona pra ext2 e 3... pc inspector file recovery

  6. #6
    nod3vic3
    Visitante

    Padrão Apaguei o /etc

    aí 5hu7d0wn teria como me informar se o programa que vc falou é esse

    http://superdownloads.ubbi.com.br/download/i23386.html

    valew



  7. #7

    Padrão Apaguei o /etc

    Citação Postado originalmente por nod3vic3
    aí 5hu7d0wn teria como me informar se o programa que vc falou é esse

    http://superdownloads.ubbi.com.br/download/i23386.html

    valew
    Bem esse...

  8. #8
    whinston
    Visitante

    Padrão 100% ?

    ele recuperou tudo ?
    os nomes voltaram ao normal ou ficaram tudo zoados?



  9. #9

    Padrão Apaguei o /etc

    Amigo, passei exatamente pelo mesmo problema, a cerca de 1 ano atrás. Um funcionário novo, desses curiosos pelo Linux, também fez a mesma coisa. Apagou o etc.
    Nosso servidor roda o Conectiva Linux 8.
    Aí um amigo, me indicou fazer o seguinte :
    Dar boot com o cd do Slackware e depois do boot dar o comando cfdisk /dev/hda . Ele me mostrou o outro hd onde estava os dados da empresa.
    Montei o o hd que eu precisava recuperar com todas as informações que eu queria. Dei um um mount /dev/hda1 /mnt/teste . Aí ls -lia /mnt/teste. Estava tudo lá.
    Bom daí para a frente foi mole. Quer dizer, foi trabalhoso, mas não perdi nada. Instalei novamente o Conectiva num outro hd e depois de tudo pronto foi somente montar novamente o hd bichado e copiar tudo.
    Foi um aprendizado e tanto. Sufoco claro, mas valeu.
    Inté + ......... :wink:

  10. #10

    Padrão Apaguei o /etc

    Olha só galera.. vou explicar como aconteceu..
    essa maquina tinha o backup dos outros servers..
    estava verificando os diretorios de backup..
    sendo que o hd da maquina estava lotadao..

    dai achei um backup antigo la.. e dentro desse backup tinha um etc..
    so que era mais ou menos isso..
    /backup/server1/etc
    e eu tava no diretorio server1.. e dei o comando "rm -Rf "/"etc"
    já era.. ehhe

    mas reinstalei a maquina sem formatar as particoes.. deu tudo blz..
    agora so falta configurar o que esta pendente..

    Valeu..



  11. #11
    Visitante

    Padrão Apaguei o /etc

    vc tinha que dar rm -fr etc/ ehehheehe

  12. #12
    Visitante

    Padrão Apaguei o /etc

    por isso usar a opção "-i" é sempre uma boa...



  13. #13
    Walfredo
    Visitante

    Padrão Apaguei o /etc

    1º vai no setup da placa e coloca para dar o boot pelo cd.

    2º coloca o cd do windows xp no drive reinicia a máquina, instala o win e nunca mais vai ter este problema!

    Depois tenta apagar a pasta etc do win hehehehehe acho que vc nao vai conseguir!

  14. #14
    whinston
    Visitante

    Padrão walfredo

    amigo,aproveitando a deixa do colega walfredo, faz o seguinte tb
    qdo 1 processo travar, se o seu windows ainda tiver em pe, tente fazer o seguinte. de ctrl+alt+del e tente matar o processo. pootz, vc ta tentando varias xx e ele nao mata?

    entao reinstala o linux, de kill -9 processo e seja feliz



  15. #15
    Walfredo
    Visitante

    Padrão Apaguei o /etc

    heheheheh aí whinston tava pensando aqui... acho que pegamos pesado, o cara deve estar desesperado...

    Foi mal aí pela brincadeira fora de hora.

    Mas que foi legal foi hehehhe não podemos discordar não é whinston?

    OBS: Já dizia um grande amigo meu, "...se não puder ajudar, atrapalhe o importante é participar..."


    Abraços e susseso!

  16. #16
    whinston
    Visitante

    Padrão ever

    ever