+ Responder ao Tópico



  1. #1
    None
    Visitante

    Padrão Configuração de interfaces de Rede

    Olá,

    Estou com um problema na configuração da intercafe da minha rede. Tenho aqui uma rede local ligada a internet através de um roteador, mas para eu poder entrar na net tenho que, todas as vezes que inicio o FreeBSD, entrar no sysinstal e configurar as interfaces de rede e mesmo assim não conseigo acessar a rede local. Como faço para configurar a rede?

    Obrigado,
    None.

  2. #2

    Padrão Configuração de interfaces de Rede

    Para iniciar a interface toda a vez que voce iniciar o bsd, coloque no arquivo rc.conf a seguinte variavel...

    csh# vi /etc/rc.conf


    ifconfig_rl0="192.168.1.1"
    defaultrouter="192.168.1.254"


    Algo do genero podera te ajudar.

    Sem mais,
    :twisted:



  3. #3
    None
    Visitante

    Padrão Configuração de interfaces de Rede

    Olá,

    Não funcionou não. O que faço?

    Obrigado,
    None.

  4. #4
    TicoTuco
    Visitante

    Padrão Configuração de interfaces de Rede

    entao...
    primeiro digite:
    pciconf -l -v
    ... vai ser listados os dispositivos pci, procure pela sua placa de rede, no meu caso... sis0 que é a minha sis900 e rl0 que é a minha realtech 8139...
    manualmente vc pode configurar dessa forma
    ifconfig sis0 inet 10.1.1.100 netmask 255.255.255.0
    ifconfig rl0 inet 10.0.0.100 netmask 255.255.255.0
    route add default 10.0.0.138
    para resolver nomes edite seu /etc/resolv.conf e adicione
    nameserver 200.250.15.1

    se quiser que ao inciar o free jah levante as redes com os ips certos... edit o rc.conf e remova as linhas que começarem com ifconfig e dafaultrouter (para nao haver confusao) e adicione novamente

    ifconfig_sis0="inet 10.1.1.100 netmask 255.255.255.0"
    ifconfig_rl0="inet 10.0.0.1 netmask 255.255.255.0"
    default_route="10.0.0.138"

    entendeu... ai vc altera os ips como desejar...

    e se nao conseguir pingar ainda... pode ser o cabo de rede, a placa de rede... a porta do hub, a placa de rede do destinatario ou algum firewall...
    se vc habilitou o ipfw provavelmente a sua ultima regra é ipfw deny all from any to any e vc nao tem nenuma regra para habilitar o trafego...
    tente digitar ipfw add 001 allow all from any to any... se depois disso vc conseguir pingar as maquinas pegunte pro google.com.br sobre freebsd+ipfw em portugues que vai aparecer uma porrada de resultados sobre ipfw e deixe do jeito que achar melhor o seu firewall.