+ Responder ao Tópico



  1. #1
    bandlinux
    Visitante

    Padrão Problema em rodar o Squid(Erro no RunCache)

    Bom dia!!!
    Estou com problemas no squid, pois quando rodo o RunCache, o mesmo fica acusando erro na linha 35, e daí o mesmo aborta, recomecando novamente o processo.
    Ainda não consegui navegar, usando o squid...
    Só navego com o nat , quando rodo o squid , nada!!!!!!!!!!
    O erro é este abaixo.....
    ./RunCache: line 35: 28741 Aborted squid -NsY $conf >>$logdir/squid.out 2>&1
    O que será que pode estar derrubando a conexão do squid...
    Quando utilizo o squid.out, o mesmo só me repassa isto:
    Startup: Wed Mar 2 23:36:30 BRT 2005
    Startup: Wed Mar 2 23:36:41 BRT 2005
    Startup: Wed Mar 2 23:36:51 BRT 2005
    Startup: Wed Mar 2 23:38:18 BRT 2005
    Startup: Wed Mar 2 23:38:28 BRT 2005
    Startup: Wed Mar 2 23:38:39 BRT 2005
    Startup: Wed Mar 2 23:51:01 BRT 2005
    Startup: Wed Mar 2 23:51:12 BRT 2005
    Startup: Wed Mar 2 23:51:22 BRT 2005
    Startup: Wed Mar 2 23:51:33 BRT 2005
    Startup: Wed Mar 2 23:51:43 BRT 2005
    Startup: Wed Mar 2 23:51:54 BRT 2005

    Já não sei mais o que fazer!!!
    Obrigado!!!!!
    OBS:Estou usando o slak 10.0, e o squid-2.5.STABLE8
    Nem acls estou utilizando,só liberei a porta 3128,e o sistema de cache, como abaixo:
    #Default:
    cache_dir ufs /usr/local/squid/var/cache 100 64 64
    Me Ajudem!!!!!

  2. #2

    Padrão Re: Problema em rodar o Squid(Erro no RunCache)

    Opa tudo blz:
    faça ai
    Código :
    rm -rf /usr/local/squid/var/cache/*
    squid -z

    como esta as permissoes do seu diretorio de cache?

    Citação Postado originalmente por bandlinux
    Bom dia!!!
    Estou com problemas no squid, pois quando rodo o RunCache, o mesmo fica acusando erro na linha 35, e daí o mesmo aborta, recomecando novamente o processo.
    Ainda não consegui navegar, usando o squid...
    Só navego com o nat , quando rodo o squid , nada!!!!!!!!!!
    O erro é este abaixo.....
    ./RunCache: line 35: 28741 Aborted squid -NsY $conf >>$logdir/squid.out 2>&1
    O que será que pode estar derrubando a conexão do squid...
    Quando utilizo o squid.out, o mesmo só me repassa isto:
    Startup: Wed Mar 2 23:36:30 BRT 2005
    Startup: Wed Mar 2 23:36:41 BRT 2005
    Startup: Wed Mar 2 23:36:51 BRT 2005
    Startup: Wed Mar 2 23:38:18 BRT 2005
    Startup: Wed Mar 2 23:38:28 BRT 2005
    Startup: Wed Mar 2 23:38:39 BRT 2005
    Startup: Wed Mar 2 23:51:01 BRT 2005
    Startup: Wed Mar 2 23:51:12 BRT 2005
    Startup: Wed Mar 2 23:51:22 BRT 2005
    Startup: Wed Mar 2 23:51:33 BRT 2005
    Startup: Wed Mar 2 23:51:43 BRT 2005
    Startup: Wed Mar 2 23:51:54 BRT 2005

    Já não sei mais o que fazer!!!
    Obrigado!!!!!
    OBS:Estou usando o slak 10.0, e o squid-2.5.STABLE8
    Nem acls estou utilizando,só liberei a porta 3128,e o sistema de cache, como abaixo:
    #Default:
    cache_dir ufs /usr/local/squid/var/cache 100 64 64
    Me Ajudem!!!!!



  3. #3
    bandlinux
    Visitante

    Padrão Problema em rodar o Squid(Erro no RunCache)

    Minhas permissoes estao assim
    >usr/local/ chown -R squidadm squid/
    chmod -R 775 squid/

    São somente estas !!!!!
    Qualuquer coisa me fale!!!
    Não funcionou o procedimento!!!!
    Caso você tenha alguma idéia me fale!!!
    Obrigado

  4. #4
    dispatcher
    Visitante

    Padrão Problema em rodar o Squid(Erro no RunCache)

    Citação Postado originalmente por bandlinux
    Minhas permissoes estao assim
    >usr/local/ chown -R squidadm squid/
    chmod -R 775 squid/

    São somente estas !!!!!
    Qualuquer coisa me fale!!!
    Não funcionou o procedimento!!!!
    Caso você tenha alguma idéia me fale!!!
    Obrigado
    Perceba que vc mudou o dono do diretorio squid e todos os seus sub-diretorios para squidadm. Vc criou esse usuario no sistema e acrescentou a linha:
    cache_effective_user squidadm
    no squid.conf?



  5. #5
    Giliano
    Visitante

    Padrão Squid

    Rapaz... O usuário e o grupo de acesso à paste /cache deve ser o mesmo cadastrado no squid.conf, pois só assim o sistema irá entender!!! Qualquer coisa tente colocar a pasta /cache com o usuário e grupo squid....


    Qualquer Coisa posrt aqui!!


    Falows!!


    Giliano Guerra
    Administrador de Redes

  6. #6

    Padrão Problema em rodar o Squid(Erro no RunCache)

    Isso mesmo kro colega... tudo o que os manos falarão esta correto
    Citação Postado originalmente por dispatcher
    Citação Postado originalmente por bandlinux
    Minhas permissoes estao assim
    >usr/local/ chown -R squidadm squid/
    chmod -R 775 squid/

    São somente estas !!!!!
    Qualuquer coisa me fale!!!
    Não funcionou o procedimento!!!!
    Caso você tenha alguma idéia me fale!!!
    Obrigado
    Perceba que vc mudou o dono do diretorio squid e todos os seus sub-diretorios para squidadm. Vc criou esse usuario no sistema e acrescentou a linha:
    cache_effective_user squidadm
    no squid.conf?