Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Gente to numa maquina da rede 192.168.1.50 fazendo o seguinte teste:

    [[email protected] root]# telnet 192.168.1.1 53
    Trying 192.168.1.1...
    Connected to 192.168.1.1.
    Escape character is '^]'.
    Connection closed by foreign host.

    O que isso significa ? O bind não tá respondendo ou está a requisição ???

    Porque quando tento configurar meu dominio na fapesp da "Tempo Esgotado" ??

    Se tento o mesmo passando pelo firewall

    [email protected] root]# telnet 200.x.x.x 53
    Trying 200.x.x.x...
    telnet: connect to address 200.x.x.x: Connection refused

  2. #2

    Padrão Bind está respondendo ??

    Cara seu firewall ta ainda bloqueando o bind, cara ja tentou deixar sem firewall e ve se da o mesmo erro?? pq ja vi que configurou e reconfigurou seu firewall e não deu certo, seu modem que pode ta bloqueando isso.

    falows



  3. #3
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Hehehe.. podecre Ruy .. tá um novela isso... Hoje qdo não tiver mais ninguém na firma vou colocar o cabo mo modem ADSL direto na maquina com o bind e ver se funciona..
    Eu coloquei toda minha configuração (firewall, bind, etc) no fórum pra ver se alguém me dava uma dica, mas acho q ou o negócio tá muito cabeludo ou tão me zuando, ninguém respodeu .. hehehehehehe...

    Mas vamos ver hoje se consigo resolver ... Se der certo eu posto como resolvi, se não der posto o problema pra ver se alguém sabe o que pode ser...

    Valeu..

  4. #4

    Padrão Bind está respondendo ??

    blz, mas so uma coisa como seu modem adsl ta configurado eh como bridge ou router??

    falows



  5. #5
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Como eu vejo isso ?

  6. #6
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Dá uma olhada nisso:

    [[email protected] /]# nmap 200.x.x.x

    Starting nmap 3.50 ( http://www.insecure.org/nmap/ ) at 2005-03-03 19:37 BRT
    Interesting ports on desenv.kardecbooks.com.br (200.x.x.x):
    (The 1657 ports scanned but not shown below are in state: closed)
    PORT STATE SERVICE
    111/tcp open rpcbind
    631/tcp open ipp

    Nmap run completed -- 1 IP address (1 host up) scanned in 1.205 seconds
    [[email protected] /]#

    ---------------------------- Agora Localhost ------------------------------
    [[email protected] /]# nmap localhost

    Starting nmap 3.50 ( http://www.insecure.org/nmap/ ) at 2005-03-03 19:36 BRT
    Interesting ports on desenv.kardecbooks.com.br (127.0.0.1):
    (The 1655 ports scanned but not shown below are in state: closed)
    PORT STATE SERVICE
    53/tcp open domain
    111/tcp open rpcbind
    631/tcp open ipp
    953/tcp open rndc

    Nmap run completed -- 1 IP address (1 host up) scanned in 1.194 seconds
    [[email protected] /]#


    Porque quando dou o nmap no meu IP externo (eth0) a porta 53 não aparece ??



  7. #7

    Padrão Bind está respondendo ??

    Seguinte seu computador ta com ip publico nele ou com ip invalido??

    Seguinte isso ta com cara de firewall, experimenta desbilita ro firewall e ve o que rola.

    falows

  8. #8
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    O IP é válido. Estou usando o Speedy Business.

    Nessa máquina nem tem firewall .. to com o cabo ADSL direto.

    Tem algum teste que eu possa fazer localmente para ter certeza de que a configuração está correta ??

    Alguma coisa q dependendo do resultado a gente fale:
    "O servidor DNS tá funcionando com certeza, o problema é outro."



  9. #9

    Padrão Bind está respondendo ??

    Cara isso ta com cara de firewall na boa, pois de fora não consegue achar a porta do dns e de dentro consegue, entao ou ele não ta dando um listen pra rede externa ou eh firewal.

    falows

  10. #10
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Como funciona esse esquema do listen ???



  11. #11

    Padrão Bind está respondendo ??

    tem um listen-on no named.conf, ve se tem esse parametro, se tiver pode tirar.

    falows

  12. #12
    rmars
    Visitante

    Padrão Bind está respondendo ??

    Acho que agora chegamos ao ponto....
    verifique o parâmetro listen on dentro do named.conf. :roll:



  13. #13
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Desabilitei o listen e mesmo assim não funciona.
    Continua dando "tempo esgotado" na fapesp

  14. #14

    Padrão Bind está respondendo ??

    Cara o nmap devia ta mostrando a 53, pra rede externa, enquanto não tiver isso quer dizer que a porta ta bloqueada.

    falows



  15. #15
    rmars
    Visitante

    Padrão Bind está respondendo ??

    O que você acha de postar o seu named.conf aqui?

  16. #16
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Tá começando a melhorar... hehehehe...

    [[email protected] root]# nmap 200.x.x.x

    Starting nmap 3.50 ( http://www.insecure.org/nmap/ ) at 2005-03-03 21:03 BRT
    Interesting ports on desenv.kardecbooks.com.br (200.x.x.x):
    (The 1656 ports scanned but not shown below are in state: closed)
    PORT STATE SERVICE
    53/tcp open domain
    111/tcp open rpcbind
    631/tcp open ipp

    Nmap run completed -- 1 IP address (1 host up) scanned in 1.171 seconds
    [[email protected] root]#

    ---------------------------------- named.conf --------------------------------
    // generated by named-bootconf.pl

    options {
    directory "/var/named";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    //query-source address * port 53;
    dump-file "/var/named/dump/named_dump.db";
    statistics-file "/var/named/dump/named.stats";
    memstatistics-file "/var/named/dump/named.memstats";
    // remove this next line if you want named to listen on
    // all available interfaces, or adjust add new ones as
    // you see fit
    //listen-on { 127.0.0.1/32; };

    };

    //
    // a caching only nameserver config
    //
    zone "." {
    type hint;
    file "named.ca";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "named.local";
    };

    zone "localhost" IN {
    type master;
    file "localhost.zone";
    };

    zone "x.x.200.in-addr.arpa" IN {
    type master;
    file "dominio.rev";
    };

    zone "kardecbooks.com.br" IN {
    type master;
    file "kardecbooks.zone";
    };

    zone "espiritanet.com.br" IN {
    type master;
    file "espiritanet.zone";
    };


    ------------------------------ kardecbooks.zone ----------------------------
    $TTL 86400
    @ IN SOA desenv. desenv.kardecbooks.com.br. (
    2005030301 ;serial (aaaammddxx)
    10800 ;refresh 3 horas
    1800 ;retry 30 minutos
    36000 ;expiry 10 horas
    86400) ;minimum 24 horas

    IN NS desenv.kardecbooks.com.br.

    kardecbooks.com.br. IN MX 0 mx
    kardecbooks.com.br. IN MX 10 mx


    localhost IN A 127.0.0.1
    www IN A 200.x.x.x
    ns1 IN A 200.x.x.x

    ------------------------------ espiritanet.zone ---------------------------------
    $TTL 86400
    @ IN SOA desenv. desenv.kardecbooks.com.br. (
    2005030301 ;serial (aaaammddxx)
    10800 ;refresh 3 horas
    1800 ;retry 30 minutos
    36000 ;expiry 10 horas
    86400) ;minimum 24 horas

    IN NS desenv.espiritanet.com.br.

    espiritanet.com.br. IN MX 0 mx
    espiritanet.com.br. IN MX 10 mx


    localhost IN A 127.0.0.1
    www IN A 200.x.x.x
    ns1 IN A 200.x.x.x

    ---------------------------- dominio.rev --------------------------------------
    x.x.200.in-addr.arpa. IN SOA desenv.kardecbooks.com.br. root.kardecbooks.com.br.(
    2005030301 ; Serial number (increase it after edit)
    10800 ; Refresh after 3 hours (3 x 3600 sec)
    3600 ; Retry after 1 hour (1 x 3600 sec)
    604800 ; Expire after 1 week (7 x 24 x 3600 sec)
    86400 ) ; Minimum TTL of 1 day (24 x 3600 sec)
    ; Name servers
    x.x.200.in-addr.arpa. IN NS desenv.kardecbooks.com.br.
    ; Addresses point to canonical name
    x.x.x.200.in-addr.arpa. IN PTR desenv.kardecbooks.com.br.


    ---------------------------------- localhost.zone ------------------------------
    $TTL 86400
    @ 1D IN SOA @ root (
    2005030301 ;serial (aaaammddxx)
    10800 ;refresh 3 horas
    1800 ;retry 30 minutos
    36000 ;expiry 10 horas
    86400) ;minimum 24 horas

    1D IN NS @
    1D IN A 127.0.0.1

    -------------------------------------- named.local ------------------------------
    @ IN SOA localhost. root.localhost. (
    1997022700 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum
    IN NS localhost.

    1 IN PTR localhost.



  17. #17

    Padrão Bind está respondendo ??

    Seguitne ainda da timeout na fapesp? seguinte vai em uma maquina fora da sua rede, edita o resolve.conf pra so apontar pro seu servidor e roa um nslookup e tenta verificar se ele resolve seus dominios.

    falows

  18. #18
    karfax
    Visitante

    Padrão Bind está respondendo ??

    netstat -an | grep 53 | less


    ...
    listen-on { any; };

    :lol:



  19. #19
    Alexandre_Catanduva
    Visitante

    Padrão Bind está respondendo ??

    Karfax:
    tcp 0 0 200.x.x.x:53 0.0.0.0:* OUÇA
    tcp 0 0 127.0.0.1:53 0.0.0.0:* OUÇA
    tcp 0 0 127.0.0.1:953 0.0.0.0:* OUÇA
    udp 0 0 200.x.x.x:53 0.0.0.0:*
    udp 0 0 127.0.0.1:53 0.0.0.0:*
    unix 3 [ ] STREAM CONECTADO 3853
    unix 3 [ ] STREAM CONECTADO 3253 /tmp/.ICE-unix/2013

    Alterei o listen-on para any, mas mesmo assim ainda ta dando timeout

    Ruy: Não tenho como testar de outra máquina, só tenho um ponto de acesso a internet.

  20. #20
    buribai
    Visitante

    Padrão Bind está respondendo ??

    Afinal, vc usa firewall ou naum ???

    Se usar, desabilite ele enquanto vc testa !!!

    iptables -F
    iptables -P INPUT ACCEPT
    iptables -P OUTPUT ACCEPT
    iptables -P FORWARD ACCEPT

    -----

    coloque o ip da maquina DNS no listen



    falowww